aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 18:29:20 +0800
committermat <mat@FreeBSD.org>2018-09-10 18:29:20 +0800
commitc2e693b5eb31c08809a311b0a542fd6244eef182 (patch)
treee91a5b23823e99cf6c613fdc2ff2ccb8bb801a33
parent15779363cf5d5dc5d22fea9ce26bd394e50e0fba (diff)
downloadfreebsd-ports-gnome-c2e693b5eb31c08809a311b0a542fd6244eef182.tar.gz
freebsd-ports-gnome-c2e693b5eb31c08809a311b0a542fd6244eef182.tar.zst
freebsd-ports-gnome-c2e693b5eb31c08809a311b0a542fd6244eef182.zip
Update to latest commit.
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in11
-rw-r--r--dns/bind9-devel/files/patch-lib_isc_unix_include_isc_Makefile.in11
6 files changed, 15 insertions, 37 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 2692b8b7d62f..b00b0490149d 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.1a0.2018.08.31
+ISCVERSION= 9.13.1a0.2018.09.09
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 73b26484801af8b34baaa440a8195867a639ead7
+GL_COMMIT= d98de244c35cba90a00ac85810030d08255ce37a
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index d80d8e9c3d3e..3c359c5d245e 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535966389
-SHA256 (isc-projects-bind9-73b26484801af8b34baaa440a8195867a639ead7_GL0.tar.gz) = 42133bfdba9dd8504588cf93f6692ca90fc390794bb0745adc483ef01d9ea9ec
-SIZE (isc-projects-bind9-73b26484801af8b34baaa440a8195867a639ead7_GL0.tar.gz) = 7820950
+TIMESTAMP = 1536573567
+SHA256 (isc-projects-bind9-d98de244c35cba90a00ac85810030d08255ce37a_GL0.tar.gz) = 18c6c2911296dc57cba31d7f0e80028b3e7842f5ee1f6e557158bfff930e47b3
+SIZE (isc-projects-bind9-d98de244c35cba90a00ac85810030d08255ce37a_GL0.tar.gz) = 7263006
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 81f5d835f41a..2e0a406c1b19 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-08-31 20:57:12 UTC
+--- bin/named/config.c.orig 2018-09-10 00:21:25 UTC
+++ bin/named/config.c
@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,7 +15,7 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-08-31 20:57:12 UTC
+--- bin/named/server.c.orig 2018-09-10 00:21:25 UTC
+++ bin/named/server.c
@@ -4074,6 +4074,16 @@ configure_view(dns_view_t *view, dns_vie
}
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-08-31 20:57:12 UTC
+--- lib/dns/include/dns/view.h.orig 2018-09-10 00:21:25 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,8 @@ struct dns_view {
bool requestnsid;
@@ -45,7 +45,7 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-08-31 20:57:12 UTC
+--- lib/dns/resolver.c.orig 2018-09-10 00:21:25 UTC
+++ lib/dns/resolver.c
@@ -5758,6 +5758,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -66,9 +66,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-08-31 20:57:12 UTC
+--- lib/isccfg/namedconf.c.orig 2018-09-10 00:21:25 UTC
+++ lib/isccfg/namedconf.c
-@@ -1919,6 +1919,8 @@ view_clauses[] = {
+@@ -1920,6 +1920,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 6dd93f2a6c9b..6ddc9075e41d 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-08-31 20:57:12 UTC
+--- configure.orig 2018-09-10 00:21:25 UTC
+++ configure
-@@ -16468,27 +16468,9 @@ done
+@@ -16203,27 +16203,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16531,47 +16513,7 @@ $as_echo "no" >&6; } ;;
+@@ -16266,47 +16248,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -21337,7 +21279,7 @@ $as_echo "" >&6; }
+@@ -20809,7 +20751,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in b/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
deleted file mode 100644
index 3de4e38673b2..000000000000
--- a/dns/bind9-devel/files/patch-lib_isc_include_isc_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/isc/include/isc/Makefile.in.orig 2018-08-31 20:57:12 UTC
-+++ lib/isc/include/isc/Makefile.in
-@@ -32,7 +32,7 @@ HEADERS = aes.h app.h assertions.h atomi
- radix.h random.h ratelimiter.h refcount.h regex.h \
- region.h resource.h result.h resultclass.h rwlock.h \
- safe.h serial.h sha1.h sha2.h sockaddr.h socket.h \
-- stats.h stdio.h stdlib.h strerr.h string.h symtab.h \
-+ stats.h stdio.h strerr.h string.h symtab.h \
- task.h taskpool.h timer.h tm.h types.h util.h version.h \
- xml.h
-
diff --git a/dns/bind9-devel/files/patch-lib_isc_unix_include_isc_Makefile.in b/dns/bind9-devel/files/patch-lib_isc_unix_include_isc_Makefile.in
deleted file mode 100644
index 1a135681df78..000000000000
--- a/dns/bind9-devel/files/patch-lib_isc_unix_include_isc_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/isc/unix/include/isc/Makefile.in.orig 2018-08-31 20:57:12 UTC
-+++ lib/isc/unix/include/isc/Makefile.in
-@@ -14,7 +14,7 @@ top_srcdir = @top_srcdir@
- VERSION=@BIND9_VERSION@
-
- HEADERS = dir.h net.h netdb.h offset.h stat.h \
-- stdtime.h strerror.h syslog.h time.h
-+ stdtime.h syslog.h time.h
-
- SUBDIRS =
- TARGETS =