aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-29 19:53:56 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-29 19:53:56 +0800
commitc327ce0d986edf99e1fa6cf7e6157a62a53c71c3 (patch)
treefe0099d2fec4e58a3c5fe4fc88511ee9a4d6cf1f
parent84ba9b96f50c0939b0af0060060ad6d9a07d1004 (diff)
downloadfreebsd-ports-gnome-c327ce0d986edf99e1fa6cf7e6157a62a53c71c3.tar.gz
freebsd-ports-gnome-c327ce0d986edf99e1fa6cf7e6157a62a53c71c3.tar.zst
freebsd-ports-gnome-c327ce0d986edf99e1fa6cf7e6157a62a53c71c3.zip
add glass
GLASS (openGL Articulated Structure System) is a 3D library PR: 29991 Submitted by: Patrick Li <pat@databits.net>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/glass/Makefile37
-rw-r--r--graphics/glass/distinfo1
-rw-r--r--graphics/glass/files/patch-Makefile18
-rw-r--r--graphics/glass/pkg-comment1
-rw-r--r--graphics/glass/pkg-descr8
-rw-r--r--graphics/glass/pkg-plist7
7 files changed, 73 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8454ba1900fb..e8e234b34fd0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -67,6 +67,7 @@
SUBDIR += gimp-manual-ps
SUBDIR += gimp1
SUBDIR += giram
+ SUBDIR += glass
SUBDIR += gle
SUBDIR += glide3
SUBDIR += gliv
diff --git a/graphics/glass/Makefile b/graphics/glass/Makefile
new file mode 100644
index 000000000000..992982e0698a
--- /dev/null
+++ b/graphics/glass/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: glass
+# Date created: Thu Aug 23 09:10:22 EDT 2001
+# Whom: pat@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= glass
+PORTVERSION= 1.1.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+USE_MESA= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+INSTALLS_SHLIB= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/libglass.so.1 ${PREFIX}/lib
+ @${LN} -sf ${PREFIX}/lib/libglass.so.1 ${PREFIX}/lib/libglass.so
+ @${INSTALL_DATA} ${WRKSRC}/glass.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/glass_types.h ${PREFIX}/include
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../docs/*.html \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/glass/distinfo b/graphics/glass/distinfo
new file mode 100644
index 000000000000..5d3b592c5c1f
--- /dev/null
+++ b/graphics/glass/distinfo
@@ -0,0 +1 @@
+MD5 (glass-1.1.1.tar.gz) = 2bb0850bddc41ba9575dc5ef79f13d76
diff --git a/graphics/glass/files/patch-Makefile b/graphics/glass/files/patch-Makefile
new file mode 100644
index 000000000000..64332c4515bf
--- /dev/null
+++ b/graphics/glass/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Sun Aug 19 04:00:33 2001
++++ Makefile Thu Aug 23 10:06:34 2001
+@@ -1,12 +1,11 @@
+-CC = gcc
+ GLASS_VERSION = 1.1.1
+-CFLAGS = -g -O3 -Wall -DVERSION_STRING=\"$(GLASS_VERSION)\"
+-LIBS = -lGL
++CFLAGS += -Wall -I/usr/X11R6/include -DVERSION_STRING=\"$(GLASS_VERSION)\"
++LIBS = -L/usr/X11R6/lib -lGL
+ OBJS = glass_apoint.o glass_component.o glass_draw.o glass_interface.o glass_library.o \
+ glass_load.o glass_material.o glass_object.o glass_rgb.o glass_save.o \
+ glass_texture.o glass_tlist.o glass_transform.o glass_triangle.o glass_variable.o
+ all: $(OBJS)
+- $(CC) -shared -Wl,-soname,libglass.so.1 -o libglass.so.$(GLASS_VERSION) $(OBJS) -lc
++ $(CC) -shared -Wl,-soname,libglass.so.1 -o libglass.so.1 $(OBJS) $(LIBS) -lc
+
+ $(OBJS): glass_types.h glass.h
+
diff --git a/graphics/glass/pkg-comment b/graphics/glass/pkg-comment
new file mode 100644
index 000000000000..f3d906ece496
--- /dev/null
+++ b/graphics/glass/pkg-comment
@@ -0,0 +1 @@
+GLASS (openGL Articulated Structure System) is a 3D library
diff --git a/graphics/glass/pkg-descr b/graphics/glass/pkg-descr
new file mode 100644
index 000000000000..a5738ecd657c
--- /dev/null
+++ b/graphics/glass/pkg-descr
@@ -0,0 +1,8 @@
+GLASS is a 3D library, designed to make easy use of structured
+models in open GL applications. What do I mean by structured? That
+is models, that are made up of components linked by basic transforms,
+for example, rotations and translations. By using GLASS in an
+application, these models can be loaded, modified, and displayed
+using a minimum of function calls.
+
+WWW: http://glass.sourceforge.net/
diff --git a/graphics/glass/pkg-plist b/graphics/glass/pkg-plist
new file mode 100644
index 000000000000..ba2d9f8baec0
--- /dev/null
+++ b/graphics/glass/pkg-plist
@@ -0,0 +1,7 @@
+include/glass.h
+include/glass_types.h
+lib/libglass.so
+lib/libglass.so.1
+%%PORTDOCS%%share/doc/glass/specification.html
+%%PORTDOCS%%share/doc/glass/tutorial.html
+%%PORTDOCS%%@dirrm share/doc/glass