aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-08-31 00:22:15 +0800
committerclsung <clsung@FreeBSD.org>2004-08-31 00:22:15 +0800
commitc381823809fe7f1bde4e7f7a28ef6d4d6960ff66 (patch)
tree9445e58215a9ce4145284866132a0eec8221e300
parenta0a34acbf5cf8f47696b7c2c73b49d00600254cd (diff)
downloadfreebsd-ports-gnome-c381823809fe7f1bde4e7f7a28ef6d4d6960ff66.tar.gz
freebsd-ports-gnome-c381823809fe7f1bde4e7f7a28ef6d4d6960ff66.tar.zst
freebsd-ports-gnome-c381823809fe7f1bde4e7f7a28ef6d4d6960ff66.zip
Add a Kwiki plugin,
Kwiki::NewPage enables a "NewPage" button on Kwiki's toolbar. PR: ports/71044 Submitted by: elvis <elvis@sslab.cs.ccu.edu.tw> Approved by: vanilla (co-mentor)
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Kwiki-NewPage/Makefile34
-rw-r--r--www/p5-Kwiki-NewPage/distinfo2
-rw-r--r--www/p5-Kwiki-NewPage/pkg-descr6
-rw-r--r--www/p5-Kwiki-NewPage/pkg-message9
-rw-r--r--www/p5-Kwiki-NewPage/pkg-plist5
6 files changed, 57 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ad24b1e041e2..37535f8d0f40 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -483,6 +483,7 @@
SUBDIR += p5-Kwiki
SUBDIR += p5-Kwiki-Archive-Rcs
SUBDIR += p5-Kwiki-Archive-SVK
+ SUBDIR += p5-Kwiki-NewPage
SUBDIR += p5-Kwiki-RecentChanges
SUBDIR += p5-Kwiki-RecentChangesRSS
SUBDIR += p5-Kwiki-Revisions
diff --git a/www/p5-Kwiki-NewPage/Makefile b/www/p5-Kwiki-NewPage/Makefile
new file mode 100644
index 000000000000..3d5231fbfbc4
--- /dev/null
+++ b/www/p5-Kwiki-NewPage/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Kwiki-NewPage
+# Date created: 2004-08-28
+# Whom: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-NewPage
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= elvis@sslab.cs.ccu.edu.tw
+COMMENT= Kwiki New Page Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::NewPage.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-NewPage/distinfo b/www/p5-Kwiki-NewPage/distinfo
new file mode 100644
index 000000000000..c7cdf99ca357
--- /dev/null
+++ b/www/p5-Kwiki-NewPage/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-NewPage-0.11.tar.gz) = 50a12d1ab0196ae499945fc6dad96e6c
+SIZE (Kwiki-NewPage-0.11.tar.gz) = 8423
diff --git a/www/p5-Kwiki-NewPage/pkg-descr b/www/p5-Kwiki-NewPage/pkg-descr
new file mode 100644
index 000000000000..496cd71ac9dc
--- /dev/null
+++ b/www/p5-Kwiki-NewPage/pkg-descr
@@ -0,0 +1,6 @@
+Kwiki::NewPage - Kwiki NewPage plugin
+
+Kwiki::NewPage enables a "NewPage" button on Kwiki's toolbar.
+
+Author: Brian Ingerson <ingy@cpan.org>
+WWW: http://search.cpan.org/~ingy/
diff --git a/www/p5-Kwiki-NewPage/pkg-message b/www/p5-Kwiki-NewPage/pkg-message
new file mode 100644
index 000000000000..81c923aee756
--- /dev/null
+++ b/www/p5-Kwiki-NewPage/pkg-message
@@ -0,0 +1,9 @@
+/* ================================================================= */
+Note:
+ Kwiki-NewPage plugin installed! Now you should add
+ to your kwiki in kwiki installation directory:
+
+$ cd cgi-bin/my-kwiki
+$ kwiki -add Kwiki::NewPage
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-NewPage/pkg-plist b/www/p5-Kwiki-NewPage/pkg-plist
new file mode 100644
index 000000000000..1c2ab0d81814
--- /dev/null
+++ b/www/p5-Kwiki-NewPage/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Kwiki/NewPage.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/NewPage/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/NewPage
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki 2>/dev/null || true