aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-04-12 01:26:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-04-12 01:26:10 +0800
commitc3c8496fbf482572a245db080e1867585941427e (patch)
treecb240a44452f95852fafab274b63f039d858f4b5
parent21178bf696b57b6957a54620333431e171cfb5f0 (diff)
downloadfreebsd-ports-gnome-c3c8496fbf482572a245db080e1867585941427e.tar.gz
freebsd-ports-gnome-c3c8496fbf482572a245db080e1867585941427e.tar.zst
freebsd-ports-gnome-c3c8496fbf482572a245db080e1867585941427e.zip
- Add p5-Test-Requires-Git 1.005
Test::Requires::Git checks if the version of Git available for testing meets the given requirements. The "current git" is obtained by running git --version (so the first git binary found in the PATH will be tested). If the checks fail, then all tests will be skipped. WWW: http://search.cpan.org/dist/Test-Requires-Git/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Requires-Git/Makefile24
-rw-r--r--devel/p5-Test-Requires-Git/distinfo2
-rw-r--r--devel/p5-Test-Requires-Git/pkg-descr9
-rw-r--r--devel/p5-Test-Requires-Git/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5f3cee61b0fa..9d6a9a1533d1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3276,6 +3276,7 @@
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Reporter-Transport-Metabase
SUBDIR += p5-Test-Requires
+ SUBDIR += p5-Test-Requires-Git
SUBDIR += p5-Test-RequiresInternet
SUBDIR += p5-Test-Script
SUBDIR += p5-Test-Script-Run
diff --git a/devel/p5-Test-Requires-Git/Makefile b/devel/p5-Test-Requires-Git/Makefile
new file mode 100644
index 000000000000..e8cf5d46f35c
--- /dev/null
+++ b/devel/p5-Test-Requires-Git/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Test-Requires-Git
+PORTVERSION= 1.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Check your test requirements against the available version of Git
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Git-Version-Compare>=1.001:devel/p5-Git-Version-Compare
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Requires-Git/distinfo b/devel/p5-Test-Requires-Git/distinfo
new file mode 100644
index 000000000000..fd99fcbc0f06
--- /dev/null
+++ b/devel/p5-Test-Requires-Git/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Requires-Git-1.005.tar.gz) = f0d8e0f77d12122cf884bf48f0a65883eb208f8222a58b52d2e720d379f675ed
+SIZE (Test-Requires-Git-1.005.tar.gz) = 16767
diff --git a/devel/p5-Test-Requires-Git/pkg-descr b/devel/p5-Test-Requires-Git/pkg-descr
new file mode 100644
index 000000000000..625bfc6c13da
--- /dev/null
+++ b/devel/p5-Test-Requires-Git/pkg-descr
@@ -0,0 +1,9 @@
+Test::Requires::Git checks if the version of Git available for testing meets the
+given requirements.
+
+The "current git" is obtained by running git --version (so the first git binary
+found in the PATH will be tested).
+
+If the checks fail, then all tests will be skipped.
+
+WWW: http://search.cpan.org/dist/Test-Requires-Git/
diff --git a/devel/p5-Test-Requires-Git/pkg-plist b/devel/p5-Test-Requires-Git/pkg-plist
new file mode 100644
index 000000000000..c199b3625c6c
--- /dev/null
+++ b/devel/p5-Test-Requires-Git/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Test/Requires/Git.pm
+%%PERL5_MAN3%%/Test::Requires::Git.3.gz