aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-30 02:19:06 +0800
committerbapt <bapt@FreeBSD.org>2014-01-30 02:19:06 +0800
commitc5f770fdbd1f247400df55f1f742082715b287eb (patch)
treeba1d5deeeb3bfce1e3647d65e6bfb31e45193672
parent2b2a09eb715719b57f53ecbb444f487ac9cf6f55 (diff)
downloadfreebsd-ports-gnome-c5f770fdbd1f247400df55f1f742082715b287eb.tar.gz
freebsd-ports-gnome-c5f770fdbd1f247400df55f1f742082715b287eb.tar.zst
freebsd-ports-gnome-c5f770fdbd1f247400df55f1f742082715b287eb.zip
Add libcxxrt into the ports tree, that is a necessary piece of bringing
a one true unique c++ ABI for the ports tree
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libcxxrt/Makefile25
-rw-r--r--devel/libcxxrt/distinfo2
-rw-r--r--devel/libcxxrt/pkg-descr8
-rw-r--r--devel/libcxxrt/pkg-plist11
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c6c4c033d03c..731254b9b45e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -949,6 +949,7 @@
SUBDIR += libconfig
SUBDIR += libconfuse
SUBDIR += libcwd
+ SUBDIR += libcxxrt
SUBDIR += libdaemon
SUBDIR += libdap
SUBDIR += libdasm
diff --git a/devel/libcxxrt/Makefile b/devel/libcxxrt/Makefile
new file mode 100644
index 000000000000..b1927eb5f616
--- /dev/null
+++ b/devel/libcxxrt/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libcxxrt
+PORTVERSION= 20141225
+CATEGORIES= devel
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Implementation of the Code Sourcery C++ ABI
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= pathscale
+GH_COMMIT= 2f150a6
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= cmake
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/lib/libcxxrt.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/lib/libcxxrt.a ${STAGEDIR}${PREFIX}/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/cxxrt
+ ${INSTALL_DATA} ${WRKSRC}/src/*.h ${STAGEDIR}${PREFIX}/include/cxxrt
+
+.include <bsd.port.mk>
diff --git a/devel/libcxxrt/distinfo b/devel/libcxxrt/distinfo
new file mode 100644
index 000000000000..383269a40068
--- /dev/null
+++ b/devel/libcxxrt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcxxrt-20141225.tar.gz) = 87c3ac078944185087a6d7dcf269410fef67f6454cbcb75d09064ce4c939c5ac
+SIZE (libcxxrt-20141225.tar.gz) = 70263
diff --git a/devel/libcxxrt/pkg-descr b/devel/libcxxrt/pkg-descr
new file mode 100644
index 000000000000..5a746d4c11b5
--- /dev/null
+++ b/devel/libcxxrt/pkg-descr
@@ -0,0 +1,8 @@
+This library implements the Code Sourcery C++ ABI, as documented here:
+
+http://www.codesourcery.com/public/cxx-abi/abi.html
+
+It is intended to sit below an STL implementation, and provide features required
+by the compiler for implementation of the C++ language.
+
+WWW: https://github.com/pathscale/libcxxrt
diff --git a/devel/libcxxrt/pkg-plist b/devel/libcxxrt/pkg-plist
new file mode 100644
index 000000000000..7692a5636dd8
--- /dev/null
+++ b/devel/libcxxrt/pkg-plist
@@ -0,0 +1,11 @@
+include/cxxrt/abi_namespace.h
+include/cxxrt/atomic.h
+include/cxxrt/cxxabi.h
+include/cxxrt/dwarf_eh.h
+include/cxxrt/stdexcept.h
+include/cxxrt/typeinfo.h
+include/cxxrt/unwind-arm.h
+include/cxxrt/unwind-itanium.h
+include/cxxrt/unwind.h
+lib/libcxxrt.a
+lib/libcxxrt.so