aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2013-09-10 02:05:40 +0800
committernox <nox@FreeBSD.org>2013-09-10 02:05:40 +0800
commitc7313bae5ef9f5efc9ddd4545748d764dfdc6f40 (patch)
tree2bff871594d32ab542eb71cd068982381e4e3cbb
parent2052a2ef195835cb25e75a8942016d3dd48d7c69 (diff)
downloadfreebsd-ports-gnome-c7313bae5ef9f5efc9ddd4545748d764dfdc6f40.tar.gz
freebsd-ports-gnome-c7313bae5ef9f5efc9ddd4545748d764dfdc6f40.tar.zst
freebsd-ports-gnome-c7313bae5ef9f5efc9ddd4545748d764dfdc6f40.zip
- Update to 2.0.8 .
- Add subtitle, video, and audio track scrolling to VLC's ncurses.c module. [1] - Add GME knob. (audio/libgme dependency) [2] - Fix build with clang+libc++. [3] PR: ports/181596 [1], ports/181909 [3] Submitted by: Cam Karnes <karnes.cameron@gmail.com> [1] Submitted by: pawel (on -multimedia) [2] Submitted by: "O. Hartmann" <ohartman@zedat.fu-berlin.de>, bapt via pb2 [3] Obtained from: vlc upstream git [1]
-rw-r--r--multimedia/vlc/Makefile16
-rw-r--r--multimedia/vlc/distinfo4
-rw-r--r--multimedia/vlc/files/patch-modules-codec-avcodec-vaapi.c13
-rw-r--r--multimedia/vlc/files/patch-modules-codec-flac.c13
-rw-r--r--multimedia/vlc/files/patch-modules-gui-ncurses.c54
-rw-r--r--multimedia/vlc/files/patch-modules-gui-qt4-Makefile.in11
-rw-r--r--multimedia/vlc/files/patch-modules-stream_filter-dash-mpd-SegmentInfoCommon.h10
-rw-r--r--multimedia/vlc/files/patch-share-Makefile.in25
8 files changed, 114 insertions, 32 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 81b633ed3b25..43fa44e64883 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vlc
-DISTVERSION= 2.0.7
+DISTVERSION= 2.0.8
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/p/-pre/}/ \
@@ -29,7 +29,7 @@ OPTIONS_DEFINE= A52 AALIB ASS AVAHI CACA DBUS DIRAC DOCS DTS DVDREAD \
SAMBA SCHROED SDL SHOUTCAST SKINS STREAM SPEEX SQLITE SVG \
TAGLIB THEORA TWOLAME UPNP V4L VAAPI VCD VORBIS \
X11 X264 XCB XOSD XVIDEO ZVBI SERVER_ONLY DEBUG \
- NO_DVD LIBBLURAY SAMPLERATE SIDPLAY
+ GME NO_DVD LIBBLURAY SAMPLERATE SIDPLAY
OPTIONS_DEFAULT=A52 AVAHI DBUS DTS DVDREAD DVDNAV FAAD FLAC GLX GNUTLS \
HTTPD LUA MAD MATROSKA MPEG2 OGG OPUS PNG QT4 REALAUDIO \
SDL SKINS STREAM SPEEX TAGLIB THEORA TWOLAME V4L \
@@ -39,6 +39,7 @@ DTS_DESC= DTS DVD audio decoder
DVDREAD_DESC= DVD Playback support
DVDNAV_DESC= DVD menu navigation
FLUID_DESC= Fluidsynth MIDI support
+GME_DESC= Game_Music_Emu (libgme) support
GNOMEVFS_DESC= Gnome VFS support
GOOM_DESC= the Goom visual effect library
NCURSES_DESC= ncurses (console) interface
@@ -64,7 +65,7 @@ NO_DVD_DESC= disable DVD specific features
USE_XZ= yes
USES= iconv perl5 gmake pkgconfig
USE_PERL5= build
-USE_GL=yes
+USE_GL= yes
USE_CSTD= gnu99
WANT_GNOME= yes
@@ -273,6 +274,13 @@ IGNORE= GLX option requires XCB option
CONFIGURE_ARGS+=--disable-glx
.endif
+.if ${PORT_OPTIONS:MGME}
+LIB_DEPENDS+= gme:${PORTSDIR}/audio/libgme
+CONFIGURE_ARGS+=--enable-gme
+.else
+CONFIGURE_ARGS+=--disable-gme
+.endif
+
.if ${PORT_OPTIONS:MGNOMEVFS}
USE_GNOME+= gnomevfs2
CONFIGURE_ARGS+=--enable-gnomevfs
@@ -800,7 +808,7 @@ pre-install:
.if ${PORT_OPTIONS:MNLS}
cd ${FAKEDIR}/share/locale && ${FIND} -s * -type f -o -type l | \
${SED} -e 's|^|share/locale/|' >> ${PLIST}
-.for locale in ach an az cgg bn_IN ckb co ff fur gd ia kk km kmr ky lg my oc or_IN ps tet tl zu
+.for locale in ach an az cgg bn_IN ckb co ff fur gd ia kk km kmr kn ky lg my oc or_IN ps tet tl zu
${ECHO_CMD} "@dirrmtry share/locale/${locale}/LC_MESSAGES" >> ${PLIST}
${ECHO_CMD} "@dirrmtry share/locale/${locale}" >> ${PLIST}
.endfor
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index 1f620c2de21c..10dfdd8a5053 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vlc-2.0.7.tar.xz) = 243107d59e4bd0b942cb4ce10292eab8233394f8109ff4fde44e64d0ee745314
-SIZE (vlc-2.0.7.tar.xz) = 18538256
+SHA256 (vlc-2.0.8.tar.xz) = a02af28345d4560e718066623f881b6eaf29ddce3b778fbf839e08b2415d1702
+SIZE (vlc-2.0.8.tar.xz) = 18858236
diff --git a/multimedia/vlc/files/patch-modules-codec-avcodec-vaapi.c b/multimedia/vlc/files/patch-modules-codec-avcodec-vaapi.c
deleted file mode 100644
index f534f7786acd..000000000000
--- a/multimedia/vlc/files/patch-modules-codec-avcodec-vaapi.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- modules/codec/avcodec/vaapi.c.orig 2013-01-22 10:51:40.000000000 +0100
-+++ modules/codec/avcodec/vaapi.c 2013-07-05 01:43:15.340713238 +0200
-@@ -246,8 +246,8 @@
-
- /* Create surfaces */
- VASurfaceID pi_surface_id[p_va->i_surface_count];
-- if( vaCreateSurfaces( p_va->p_display, i_width, i_height, VA_RT_FORMAT_YUV420,
-- p_va->i_surface_count, pi_surface_id ) )
-+ if( vaCreateSurfaces( p_va->p_display, VA_RT_FORMAT_YUV420, i_width, i_height,
-+ pi_surface_id, p_va->i_surface_count, NULL, 0 ) )
- {
- for( int i = 0; i < p_va->i_surface_count; i++ )
- p_va->p_surface[i].i_id = VA_INVALID_SURFACE;
diff --git a/multimedia/vlc/files/patch-modules-codec-flac.c b/multimedia/vlc/files/patch-modules-codec-flac.c
deleted file mode 100644
index 87c09587047e..000000000000
--- a/multimedia/vlc/files/patch-modules-codec-flac.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- modules/codec/flac.c.orig 2013-01-25 13:30:14.000000000 +0100
-+++ modules/codec/flac.c 2013-06-10 14:39:04.000000000 +0200
-@@ -38,8 +38,8 @@
- #include <vlc_codec.h>
- #include <vlc_aout.h>
-
--#include <stream_decoder.h>
--#include <stream_encoder.h>
-+#include <FLAC/stream_decoder.h>
-+#include <FLAC/stream_encoder.h>
-
- #include <vlc_block_helper.h>
- #include <vlc_bits.h>
diff --git a/multimedia/vlc/files/patch-modules-gui-ncurses.c b/multimedia/vlc/files/patch-modules-gui-ncurses.c
new file mode 100644
index 000000000000..8188d44e09ba
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules-gui-ncurses.c
@@ -0,0 +1,54 @@
+--- modules/gui/ncurses.c.orig
++++ modules/gui/ncurses.c
+@@ -880,6 +880,9 @@ static int DrawHelp(intf_thread_t *intf)
+ H(_(" s Stop"));
+ H(_(" <space> Pause/Play"));
+ H(_(" f Toggle Fullscreen"));
++ H(_(" c Cycle through audio tracks"));
++ H(_(" v Cycle through subtitles tracks"));
++ H(_(" b Cycle through video tracks"));
+ H(_(" n, p Next/Previous playlist item"));
+ H(_(" [, ] Next/Previous title"));
+ H(_(" <, > Next/Previous chapter"));
+@@ -1543,6 +1546,30 @@ static void InputNavigate(input_thread_t* p_input, const char *var)
+ var_TriggerCallback(p_input, var);
+ }
+
++static void CycleESTrack(intf_sys_t *sys, const char *var)
++{
++ input_thread_t *input = sys->p_input;
++
++ if (!input)
++ return;
++
++ vlc_value_t val;
++ if (var_Change(input, var, VLC_VAR_GETLIST, &val, NULL) < 0)
++ return;
++
++ vlc_list_t *list = val.p_list;
++ int64_t current = var_GetInteger(input, var);
++
++ int i;
++ for (i = 0; i < list->i_count; i++)
++ if (list->p_values[i].i_int == current)
++ break;
++
++ if (++i >= list->i_count)
++ i = 0;
++ var_SetInteger(input, var, list->p_values[i].i_int);
++}
++
+ static void HandleCommonKey(intf_thread_t *intf, int key)
+ {
+ intf_sys_t *sys = intf->p_sys;
+@@ -1611,6 +1638,10 @@ static void HandleCommonKey(intf_thread_t *intf, int key)
+ case 'z': playlist_VolumeDown(p_playlist, 1, NULL); break;
+ case 'm': playlist_MuteToggle(p_playlist); break;
+
++ case 'c': CycleESTrack(sys, "audio-es"); break;
++ case 'v': CycleESTrack(sys, "spu-es"); break;
++ case 'b': CycleESTrack(sys, "video-es"); break;
++
+ case 0x0c: /* ^l */
+ case KEY_CLEAR:
+ break;
diff --git a/multimedia/vlc/files/patch-modules-gui-qt4-Makefile.in b/multimedia/vlc/files/patch-modules-gui-qt4-Makefile.in
new file mode 100644
index 000000000000..e0338c011d79
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules-gui-qt4-Makefile.in
@@ -0,0 +1,11 @@
+--- modules/gui/qt4/Makefile.in.orig
++++ modules/gui/qt4/Makefile.in
+@@ -3499,7 +3499,7 @@ uninstall-am: uninstall-libvlcLTLIBRARIE
+
+
+ resources.cpp: vlc.qrc $(DEPS_res)
+- $(AM_V_GEN)$(RCC) -name vlc -o $@ $<
++ $(AM_V_GEN)$(RCC) -name vlc -o $@ vlc.qrc
+
+ .hpp.moc.cpp:
+ @HAVE_DARWIN_TRUE@ $(moc_verbose)$(MOC) -DQ_WS_MAC $(DEFS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) $(CPPFLAGS_qt4) -o $@ $<
diff --git a/multimedia/vlc/files/patch-modules-stream_filter-dash-mpd-SegmentInfoCommon.h b/multimedia/vlc/files/patch-modules-stream_filter-dash-mpd-SegmentInfoCommon.h
new file mode 100644
index 000000000000..e4a505b122fc
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules-stream_filter-dash-mpd-SegmentInfoCommon.h
@@ -0,0 +1,10 @@
+--- modules/stream_filter/dash/mpd/SegmentInfoCommon.h.orig
++++ modules/stream_filter/dash/mpd/SegmentInfoCommon.h
+@@ -27,6 +27,7 @@
+
+ #include <string>
+ #include <list>
++#include <ctime>
+
+ namespace dash
+ {
diff --git a/multimedia/vlc/files/patch-share-Makefile.in b/multimedia/vlc/files/patch-share-Makefile.in
new file mode 100644
index 000000000000..b7f60ef34900
--- /dev/null
+++ b/multimedia/vlc/files/patch-share-Makefile.in
@@ -0,0 +1,25 @@
+--- share/Makefile.in.orig
++++ share/Makefile.in
+@@ -1734,19 +1734,19 @@ uninstall-am: uninstall-appdataDATA unin
+
+
+ vlc.desktop: vlc.desktop.in $(top_builddir)/config.status
+- $(AM_V_GEN)sed -e 's,\@bindir\@,$(bindir),g' < "$<" > tmp-$@
++ $(AM_V_GEN)sed -e 's,\@bindir\@,$(bindir),g' < vlc.desktop.in > tmp-$@
+ $(AM_V_at)$(DESKTOP_FILE_VALIDATE) tmp-$@
+ $(AM_V_at)mv -f tmp-$@ $@
+
+ osdmenu/default.cfg: osdmenu/default.cfg.in $(top_builddir)/config.status
+ $(AM_V_GEN)mkdir -p osdmenu; \
+- sed -e 's,\@vlcdatadir\@,$(vlcdatadir),g' < "$<" > $@
++ sed -e 's,\@vlcdatadir\@,$(vlcdatadir),g' < osdmenu/default.cfg.in > $@
+
+ skins2/default.vlt: $(skins2_default_vlt_FILES)
+ mkdir -p skins2
+ (cd "$(srcdir)/skins2"; find default -print0 | \
+ LC_ALL=C sort -z | \
+- tar cvv --exclude .svn --no-recursion --null -T -) | \
++ tar cvvf - --exclude .svn --no-recursion --null -T -) | \
+ gzip -n > skins2/default.vlt
+
+ .lua.luac: