aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-03-04 20:38:02 +0800
committerkoobs <koobs@FreeBSD.org>2014-03-04 20:38:02 +0800
commitc78005b4f849273eced011c8e5ebc136c3f29c52 (patch)
tree7ee19eb42828ef79c35ac653d14a0c9bf89dcb05
parent4a642720b2209ee740585af65da26612d25ba753 (diff)
downloadfreebsd-ports-gnome-c78005b4f849273eced011c8e5ebc136c3f29c52.tar.gz
freebsd-ports-gnome-c78005b4f849273eced011c8e5ebc136c3f29c52.tar.zst
freebsd-ports-gnome-c78005b4f849273eced011c8e5ebc136c3f29c52.zip
lang/python33: Update to 3.3.4
- Update to 3.3.4 - Update pkg-plist - Remove patch-CVE-2014-1912 (upstream) - Remove patch-issue20374 (upstream) - Repatch and rename patch-Modules__fcntlmodule.c - Add patch-issue-20695-Lib__test__test_urllibnet.py (tests) [1] - Add regression-test target for QA Changes: 3.3.4 - 09/02/2014 http://docs.python.org/3.3/whatsnew/changelog.html#python-3-3-4 Extra: - Update python-doc-html distinfo for Python 3.3 docs - Update bsd.python.mk to support the new version [1] http://bugs.python.org/issue20695
-rw-r--r--Mk/bsd.python.mk4
-rw-r--r--lang/python-doc-html/distinfo16
-rw-r--r--lang/python33/Makefile6
-rw-r--r--lang/python33/distinfo4
-rw-r--r--lang/python33/files/patch-CVE-2014-191249
-rw-r--r--lang/python33/files/patch-Modules__fcntlmodule.c (renamed from lang/python33/files/patch-Modules-fcntlmodule.c)14
-rw-r--r--lang/python33/files/patch-issue-20695-Lib__test__test_urllibnet.py45
-rw-r--r--lang/python33/files/patch-issue2037455
-rw-r--r--lang/python33/pkg-plist55
9 files changed, 122 insertions, 126 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index a8ebb326e54b..8ead231ee4cc 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -335,9 +335,9 @@ PYTHON_PORTVERSION= ${PYTHON_DEFAULT_PORTVERSION}
# Python-3.3
.if ${PYTHON_VERSION} == "python3.3"
-PYTHON_PORTVERSION?= 3.3.3
+PYTHON_PORTVERSION?= 3.3.4
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python33
-PYTHON_REL= 333
+PYTHON_REL= 334
PYTHON_SUFFIX= 33
PYTHON_VER= 3.3
.if exists(${PYTHON_CMD}-config)
diff --git a/lang/python-doc-html/distinfo b/lang/python-doc-html/distinfo
index 4847248432be..0198117d0bb8 100644
--- a/lang/python-doc-html/distinfo
+++ b/lang/python-doc-html/distinfo
@@ -22,11 +22,11 @@ SHA256 (python/python-3.2.5-docs-pdf-letter.tar.bz2) = 55327e6e05c5c1f6669512e40
SIZE (python/python-3.2.5-docs-pdf-letter.tar.bz2) = 10429112
SHA256 (python/python-3.2.5-docs-text.tar.bz2) = 8940c6bb7c93ffdb5be2573ff236ac06b6082132dd97a404be8400033d805523
SIZE (python/python-3.2.5-docs-text.tar.bz2) = 1569706
-SHA256 (python/python-3.3.3-docs-html.tar.bz2) = 414dca9cac934c06c6d21ad0068ebbf907a08f8a58b40b1ffb920426840b618c
-SIZE (python/python-3.3.3-docs-html.tar.bz2) = 4944388
-SHA256 (python/python-3.3.3-docs-pdf-a4.tar.bz2) = 025edfbd46bfb11a266e6011145396adffb6519a3b1bf752f46eedd2232af3d2
-SIZE (python/python-3.3.3-docs-pdf-a4.tar.bz2) = 11133707
-SHA256 (python/python-3.3.3-docs-pdf-letter.tar.bz2) = c03f9023587e7cffc9f4e58bc0016ecc140bff7b6bf70cb43ace0e3f3e4cc369
-SIZE (python/python-3.3.3-docs-pdf-letter.tar.bz2) = 11180442
-SHA256 (python/python-3.3.3-docs-text.tar.bz2) = d8af078e6fbddfaaba84405dec8fa377c017888dc3994616d8a02d3a383844b4
-SIZE (python/python-3.3.3-docs-text.tar.bz2) = 1794451
+SHA256 (python/python-3.3.4-docs-html.tar.bz2) = 43ab01c98d5bacb301519a99ed25192cebe0b69ac4a85b95302958b225868efc
+SIZE (python/python-3.3.4-docs-html.tar.bz2) = 4951380
+SHA256 (python/python-3.3.4-docs-pdf-a4.tar.bz2) = 692eb7dd255b12252c701ca32f530932d3761e4f0582b7461c8277cd70282251
+SIZE (python/python-3.3.4-docs-pdf-a4.tar.bz2) = 11284079
+SHA256 (python/python-3.3.4-docs-pdf-letter.tar.bz2) = 21aabe30ad03ef4c78e57b14fa257670ea8899ae053cc709805d7807efe58b7a
+SIZE (python/python-3.3.4-docs-pdf-letter.tar.bz2) = 11337167
+SHA256 (python/python-3.3.4-docs-text.tar.bz2) = 82c98238d9df22650d27f3bff40b31888306aaf5f7636bbb145f94266365f273
+SIZE (python/python-3.3.4-docs-text.tar.bz2) = 1783407
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index a05334c819de..bd01d8c278d9 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= python33
-PORTVERSION= 3.3.3
-PORTREVISION= 3
+PORTVERSION= 3.3.4
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -213,4 +212,7 @@ post-install:
@${CAT} ${PKGMESSAGE}
+regression-test: build
+ @cd ${WRKSRC} && ${GMAKE} TESTOPTS=-j${MAKE_JOBS_NUMBER} test
+
.include <bsd.port.post.mk>
diff --git a/lang/python33/distinfo b/lang/python33/distinfo
index 1c2a0c9810a2..565cecfffd8d 100644
--- a/lang/python33/distinfo
+++ b/lang/python33/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.3.3.tar.xz) = 339275b30a1a3fef1589016bf6302c14e870f7a6fd2522bf87a6c2c6d383c685
-SIZE (python/Python-3.3.3.tar.xz) = 12057744
+SHA256 (python/Python-3.3.4.tar.xz) = c6cc126d91c04e0348882cfbd36d7a844d4e50acc37a3f6a64d67764e3995689
+SIZE (python/Python-3.3.4.tar.xz) = 12087568
diff --git a/lang/python33/files/patch-CVE-2014-1912 b/lang/python33/files/patch-CVE-2014-1912
deleted file mode 100644
index 027d52350e0d..000000000000
--- a/lang/python33/files/patch-CVE-2014-1912
+++ /dev/null
@@ -1,49 +0,0 @@
-# HG changeset patch
-# User Benjamin Peterson <benjamin@python.org>
-# Date 1389672775 18000
-# Node ID 7f176a45211ff3cb85a2fbdc75f7979d642bb563
-# Parent ed1c27b68068c942c6e845bdf8e987e963d50920# Parent 9c56217e5c793685eeaf0ee224848c402bdf1e4c
-merge 3.2 (#20246)
-
-# HG changeset patch
-# User Stefan Krah <skrah@bytereef.org>
-# Date 1390341520 -3600
-# Node ID 5c4f4db8107cc7b99e0a4e9c7b760c816dafa034
-# Parent 2fe0b2dcc98cd9013642fb9642365de80ff0dc30
-Issue #20246: Fix test failures on FreeBSD. Patch by Ryan Smith-Roberts.
-
-diff --git a/Lib/test/test_socket.py b/Lib/test/test_socket.py
---- Lib/test/test_socket.py
-+++ Lib/test/test_socket.py
-@@ -4538,6 +4538,14 @@ class BufferIOTest(SocketConnectedTest):
-
- _testRecvFromIntoMemoryview = _testRecvFromIntoArray
-
-+ def testRecvFromIntoSmallBuffer(self):
-+ # See issue #20246.
-+ buf = bytearray(8)
-+ self.assertRaises(ValueError, self.cli_conn.recvfrom_into, buf, 1024)
-+
-+ def _testRecvFromIntoSmallBuffer(self):
-+ self.serv_conn.send(MSG)
-+
-
- TIPC_STYPE = 2000
- TIPC_LOWER = 200
-
-diff --git a/Modules/socketmodule.c b/Modules/socketmodule.c
---- Modules/socketmodule.c
-+++ Modules/socketmodule.c
-@@ -2935,6 +2935,11 @@ sock_recvfrom_into(PySocketSockObject *s
- if (recvlen == 0) {
- /* If nbytes was not specified, use the buffer's length */
- recvlen = buflen;
-+ } else if (recvlen > buflen) {
-+ PyBuffer_Release(&pbuf);
-+ PyErr_SetString(PyExc_ValueError,
-+ "nbytes is greater than the length of the buffer");
-+ return NULL;
- }
-
- readlen = sock_recvfrom_guts(s, buf, recvlen, flags, &addr);
-
diff --git a/lang/python33/files/patch-Modules-fcntlmodule.c b/lang/python33/files/patch-Modules__fcntlmodule.c
index 88188d09963e..39fdb250730e 100644
--- a/lang/python33/files/patch-Modules-fcntlmodule.c
+++ b/lang/python33/files/patch-Modules__fcntlmodule.c
@@ -1,6 +1,6 @@
---- ./Modules/fcntlmodule.c.orig 2012-09-29 18:00:45.000000000 +1000
-+++ ./Modules/fcntlmodule.c 2012-10-04 20:21:15.000000000 +1000
-@@ -97,20 +97,15 @@
+--- ./Modules/fcntlmodule.c.orig 2014-03-04 20:15:17.641117835 +1100
++++ ./Modules/fcntlmodule.c 2014-03-04 20:19:36.141145958 +1100
+@@ -98,20 +98,15 @@
{
#define IOCTL_BUFSZ 1024
int fd;
@@ -12,7 +12,7 @@
whereas the system expects it to be a 32bit bit field value
regardless of it being passed as an int or unsigned long on
- various platforms. See the termios.TIOCSWINSZ constant across
-- platforms for an example of thise.
+- platforms for an example of this.
-
- If any of the 64bit platforms ever decide to use more than 32bits
- in their unsigned long ioctl codes this will break and need
@@ -24,7 +24,7 @@
int arg;
int ret;
Py_buffer pstr;
-@@ -119,7 +114,7 @@
+@@ -120,7 +115,7 @@
int mutate_arg = 1;
char buf[IOCTL_BUFSZ+1]; /* argument plus NUL byte */
@@ -33,7 +33,7 @@
conv_descriptor, &fd, &code,
&pstr, &mutate_arg)) {
char *arg;
-@@ -174,7 +169,7 @@
+@@ -175,7 +170,7 @@
}
PyErr_Clear();
@@ -42,7 +42,7 @@
conv_descriptor, &fd, &code, &pstr)) {
str = pstr.buf;
len = pstr.len;
-@@ -201,7 +196,7 @@
+@@ -202,7 +197,7 @@
PyErr_Clear();
arg = 0;
if (!PyArg_ParseTuple(args,
diff --git a/lang/python33/files/patch-issue-20695-Lib__test__test_urllibnet.py b/lang/python33/files/patch-issue-20695-Lib__test__test_urllibnet.py
new file mode 100644
index 000000000000..b11f7224048b
--- /dev/null
+++ b/lang/python33/files/patch-issue-20695-Lib__test__test_urllibnet.py
@@ -0,0 +1,45 @@
+# HG changeset patch
+# User Benjamin Peterson <benjamin@python.org>
+# Date 1392869184 18000
+# Node ID c9261cf05db67ec57cf66bee7b2064adef04d550
+# Parent 8d1528dddc7df1002237921d3e2f22cea1cf18d5# Parent 29b1eebecb8ed946e1db8e4bb86310d681cf4a91
+merge 3.2 (#20695)
+
+--- ./Lib/test/test_urllibnet.py.orig 2014-03-04 20:56:25.532422505 +1100
++++ ./Lib/test/test_urllibnet.py 2014-03-04 20:57:48.725949896 +1100
+@@ -103,7 +103,7 @@
+ # Make sure fd returned by fileno is valid.
+ with self.urlopen("http://www.python.org/", timeout=None) as open_url:
+ fd = open_url.fileno()
+- with os.fdopen(fd, encoding='utf-8') as f:
++ with os.fdopen(fd, 'rb') as f:
+ self.assertTrue(f.read(), "reading from file created using fd "
+ "returned by fileno failed")
+
+@@ -151,7 +151,7 @@
+ with self.urlretrieve("http://www.python.org/") as (file_location, info):
+ self.assertTrue(os.path.exists(file_location), "file location returned by"
+ " urlretrieve is not a valid path")
+- with open(file_location, encoding='utf-8') as f:
++ with open(file_location, 'rb') as f:
+ self.assertTrue(f.read(), "reading from the file location returned"
+ " by urlretrieve failed")
+
+@@ -161,7 +161,7 @@
+ support.TESTFN) as (file_location, info):
+ self.assertEqual(file_location, support.TESTFN)
+ self.assertTrue(os.path.exists(file_location))
+- with open(file_location, encoding='utf-8') as f:
++ with open(file_location, 'rb') as f:
+ self.assertTrue(f.read(), "reading from temporary file failed")
+
+ def test_header(self):
+@@ -170,7 +170,7 @@
+ self.assertIsInstance(info, email.message.Message,
+ "info is not an instance of email.message.Message")
+
+- logo = "http://www.python.org/community/logos/python-logo-master-v3-TM.png"
++ logo = "http://www.python.org/static/community_logos/python-logo-master-v3-TM.png"
+
+ def test_data_header(self):
+ with self.urlretrieve(self.logo) as (file_location, fileheaders):
diff --git a/lang/python33/files/patch-issue20374 b/lang/python33/files/patch-issue20374
deleted file mode 100644
index 763125f80b18..000000000000
--- a/lang/python33/files/patch-issue20374
+++ /dev/null
@@ -1,55 +0,0 @@
-# Description: fix readline.so build with readline 6.3
-# Patch obtained from upstream, issue #20374
-# http://bugs.python.org/issue20374
-# PR: ports/187176
-
---- ./Modules/readline.c.orig 2013-11-17 07:23:01.000000000 +0000
-+++ ./Modules/readline.c 2014-03-01 13:05:47.000000000 +0000
-@@ -774,14 +774,22 @@
- }
-
- static int
-+#if defined(_RL_FUNCTION_TYPEDEF)
- on_startup_hook(void)
-+#else
-+on_startup_hook()
-+#endif
- {
- return on_hook(startup_hook);
- }
-
- #ifdef HAVE_RL_PRE_INPUT_HOOK
- static int
-+#if defined(_RL_FUNCTION_TYPEDEF)
- on_pre_input_hook(void)
-+#else
-+on_pre_input_hook()
-+#endif
- {
- return on_hook(pre_input_hook);
- }
-@@ -877,7 +885,7 @@
- * before calling the normal completer */
-
- static char **
--flex_complete(char *text, int start, int end)
-+flex_complete(const char *text, int start, int end)
- {
- #ifdef HAVE_RL_COMPLETION_APPEND_CHARACTER
- rl_completion_append_character ='\0';
-@@ -936,12 +944,12 @@
- rl_bind_key_in_map ('\t', rl_complete, emacs_meta_keymap);
- rl_bind_key_in_map ('\033', rl_complete, emacs_meta_keymap);
- /* Set our hook functions */
-- rl_startup_hook = (Function *)on_startup_hook;
-+ rl_startup_hook = on_startup_hook;
- #ifdef HAVE_RL_PRE_INPUT_HOOK
-- rl_pre_input_hook = (Function *)on_pre_input_hook;
-+ rl_pre_input_hook = on_pre_input_hook;
- #endif
- /* Set our completion function */
-- rl_attempted_completion_function = (CPPFunction *)flex_complete;
-+ rl_attempted_completion_function = flex_complete;
- /* Set Python word break characters */
- completer_word_break_characters =
- rl_completer_word_break_characters =
diff --git a/lang/python33/pkg-plist b/lang/python33/pkg-plist
index d6719e738212..824b5a48409e 100644
--- a/lang/python33/pkg-plist
+++ b/lang/python33/pkg-plist
@@ -1687,6 +1687,49 @@ man/man1/python3.3.1.gz
%%PYTHON_LIBDIR%%/idlelib/dynOptionMenuWidget.py
%%PYTHON_LIBDIR%%/idlelib/extend.txt
%%PYTHON_LIBDIR%%/idlelib/help.txt
+%%PYTHON_LIBDIR%%/idlelib/idle_test/README.txt
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__init__.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/__init__.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/__init__.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/mock_idle.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/mock_idle.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/mock_tk.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/mock_tk.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_calltips.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_calltips.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_config_name.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_config_name.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_delegator.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_delegator.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_formatparagraph.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_formatparagraph.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_grep.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_grep.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_idlehistory.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_idlehistory.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_pathbrowser.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_pathbrowser.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_rstrip.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_rstrip.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_searchengine.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_searchengine.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_text.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_text.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_warning.cpython-33.pyc
+%%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__/test_warning.cpython-33.pyo
+%%PYTHON_LIBDIR%%/idlelib/idle_test/mock_idle.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/mock_tk.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_calltips.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_config_name.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_delegator.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_formatparagraph.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_grep.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_idlehistory.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_pathbrowser.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_rstrip.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_searchengine.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_text.py
+%%PYTHON_LIBDIR%%/idlelib/idle_test/test_warning.py
%%PYTHON_LIBDIR%%/idlelib/idle.bat
%%PYTHON_LIBDIR%%/idlelib/idle.py
%%PYTHON_LIBDIR%%/idlelib/idle.pyw
@@ -2612,6 +2655,8 @@ man/man1/python3.3.1.gz
%%PYTHON_LIBDIR%%/test/__pycache__/test_getargs2.cpython-33.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/test_getopt.cpython-33.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/test_getopt.cpython-33.pyo
+%%PYTHON_LIBDIR%%/test/__pycache__/test_getpass.cpython-33.pyc
+%%PYTHON_LIBDIR%%/test/__pycache__/test_getpass.cpython-33.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/test_gettext.cpython-33.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/test_gettext.cpython-33.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/test_glob.cpython-33.pyc
@@ -3684,6 +3729,7 @@ man/man1/python3.3.1.gz
%%PYTHON_LIBDIR%%/test/test_genexps.py
%%PYTHON_LIBDIR%%/test/test_getargs2.py
%%PYTHON_LIBDIR%%/test/test_getopt.py
+%%PYTHON_LIBDIR%%/test/test_getpass.py
%%PYTHON_LIBDIR%%/test/test_gettext.py
%%PYTHON_LIBDIR%%/test/test_glob.py
%%PYTHON_LIBDIR%%/test/test_global.py
@@ -4176,8 +4222,11 @@ man/man1/python3.3.1.gz
%%PYTHON_LIBDIR%%/tkinter/test/__pycache__/runtktests.cpython-33.pyo
%%PYTHON_LIBDIR%%/tkinter/test/__pycache__/support.cpython-33.pyc
%%PYTHON_LIBDIR%%/tkinter/test/__pycache__/support.cpython-33.pyo
+%%PYTHON_LIBDIR%%/tkinter/test/__pycache__/widget_tests.cpython-33.pyc
+%%PYTHON_LIBDIR%%/tkinter/test/__pycache__/widget_tests.cpython-33.pyo
%%PYTHON_LIBDIR%%/tkinter/test/runtktests.py
%%PYTHON_LIBDIR%%/tkinter/test/support.py
+%%PYTHON_LIBDIR%%/tkinter/test/widget_tests.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__init__.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/__init__.cpython-33.pyc
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/__init__.cpython-33.pyo
@@ -4191,11 +4240,14 @@ man/man1/python3.3.1.gz
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/test_text.cpython-33.pyo
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/test_variables.cpython-33.pyc
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/test_variables.cpython-33.pyo
+%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/test_widgets.cpython-33.pyc
+%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/__pycache__/test_widgets.cpython-33.pyo
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_font.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_loadtk.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_misc.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_text.py
%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_variables.py
+%%PYTHON_LIBDIR%%/tkinter/test/test_tkinter/test_widgets.py
%%PYTHON_LIBDIR%%/tkinter/test/test_ttk/__init__.py
%%PYTHON_LIBDIR%%/tkinter/test/test_ttk/__pycache__/__init__.cpython-33.pyc
%%PYTHON_LIBDIR%%/tkinter/test/test_ttk/__pycache__/__init__.cpython-33.pyo
@@ -4552,6 +4604,8 @@ man/man1/python3.3.1.gz
@dirrm %%PYTHON_LIBDIR%%/html
@dirrm %%PYTHON_LIBDIR%%/http/__pycache__
@dirrm %%PYTHON_LIBDIR%%/http
+@dirrm %%PYTHON_LIBDIR%%/idlelib/idle_test/__pycache__
+@dirrm %%PYTHON_LIBDIR%%/idlelib/idle_test
@dirrm %%PYTHON_LIBDIR%%/idlelib/Icons
@dirrm %%PYTHON_LIBDIR%%/idlelib/__pycache__
@dirrm %%PYTHON_LIBDIR%%/idlelib
@@ -4743,7 +4797,6 @@ man/man1/python3.3.1.gz
%%PORTDATA%%%%DATADIR%%/Tools/freeze/winmakemakefile.py
%%PORTDATA%%%%DATADIR%%/Tools/gdb/libpython.py
%%PORTDATA%%%%DATADIR%%/Tools/hg/hgtouch.py
-%%PORTDATA%%%%DATADIR%%/Tools/hg/hgtouch.pyc
%%PORTDATA%%%%DATADIR%%/Tools/i18n/makelocalealias.py
%%PORTDATA%%%%DATADIR%%/Tools/i18n/msgfmt.py
%%PORTDATA%%%%DATADIR%%/Tools/i18n/pygettext.py