aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2001-04-17 02:58:32 +0800
committerkris <kris@FreeBSD.org>2001-04-17 02:58:32 +0800
commitc8e780b3531bce8f26d58a679a624c3904951e86 (patch)
treefa6611e5f4515b219e5786f86919a132b452c6b5
parente07b423f398c394c2af8a29cb6fe41ea5490e2c6 (diff)
downloadfreebsd-ports-gnome-c8e780b3531bce8f26d58a679a624c3904951e86.tar.gz
freebsd-ports-gnome-c8e780b3531bce8f26d58a679a624c3904951e86.tar.zst
freebsd-ports-gnome-c8e780b3531bce8f26d58a679a624c3904951e86.zip
This port has been broken for a long time, and is also obsolete
software. Wave goodbye, now! Approved by: maintainer
-rw-r--r--www/Makefile1
-rw-r--r--www/vrweb/Makefile46
-rw-r--r--www/vrweb/distinfo2
-rw-r--r--www/vrweb/files/patch-aa77
-rw-r--r--www/vrweb/files/patch-ab10
-rw-r--r--www/vrweb/files/patch-ac10
-rw-r--r--www/vrweb/files/patch-ad11
-rw-r--r--www/vrweb/files/patch-ae21
-rw-r--r--www/vrweb/files/patch-af11
-rw-r--r--www/vrweb/files/patch-ag23
-rw-r--r--www/vrweb/files/patch-ah26
-rw-r--r--www/vrweb/files/patch-ai14
-rw-r--r--www/vrweb/files/patch-aj23
-rw-r--r--www/vrweb/pkg-comment1
-rw-r--r--www/vrweb/pkg-descr18
-rw-r--r--www/vrweb/pkg-plist28
16 files changed, 0 insertions, 322 deletions
diff --git a/www/Makefile b/www/Makefile
index 77b0f02dfdca..8d760c4ac847 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -254,7 +254,6 @@
SUBDIR += transproxy
SUBDIR += udmsearch
SUBDIR += viewml
- SUBDIR += vrweb
SUBDIR += w3
SUBDIR += w3-4
SUBDIR += w3c-httpd
diff --git a/www/vrweb/Makefile b/www/vrweb/Makefile
deleted file mode 100644
index 50334cafd05d..000000000000
--- a/www/vrweb/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: vrweb
-# Date created: 20 June 1997
-# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
-#
-# $FreeBSD$
-#
-
-PORTNAME= vrweb
-PORTVERSION= 1.5
-CATEGORIES= www
-MASTER_SITES= ftp://ftp.iicm.edu/pub/VRweb/UNIX/vrweb-1.5/ \
- ftp://ftp.sunet.se/pub/nir/Hyper-G/VRweb/UNIX/vrweb-1.5/ \
- ftp://metalab.unc.edu/pub/packages/infosystems/WWW/VRML/VRweb/UNIX/vrweb-1.5/
-DISTFILES= vrweb-src-1.5.tar.gz help-1.5.tar.gz
-
-MAINTAINER= saper@system.pl
-
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
-
-USE_GMAKE= yes
-USE_X_PREFIX= yes
-USE_MESA= yes
-
-do-configure:
- (cd ${WRKSRC}; \
- ${LN} -s `which ${GMAKE}` ${WRKSRC}/config/scripts/make; \
- ${WRKSRC}/makeall -r; \
- ${WRKSRC}/makeall -m; )
-
-do-build:
- (cd ${WRKSRC}; \
- ${WRKSRC}/makeall -i; )
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/installed/harmony/bin/FREEBSD/vrweb-mesa \
- ${PREFIX}/bin/vrweb
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/vrweb
- ${CP} -R ${WRKDIR}/help/* ${PREFIX}/share/doc/vrweb
- ${MKDIR} ${PREFIX}/share/doc/vrweb/icons
- ${CP} ${WRKDIR}/icons/* ${PREFIX}/share/doc/vrweb/icons
-.endif
-
-BROKEN= "does not compile with recent Mesa"
-
-.include <bsd.port.mk>
diff --git a/www/vrweb/distinfo b/www/vrweb/distinfo
deleted file mode 100644
index b0ecca84363a..000000000000
--- a/www/vrweb/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (vrweb-src-1.5.tar.gz) = 48c9867d538bda770a288834bb63e90d
-MD5 (help-1.5.tar.gz) = 658d46bc14a7178a61b81dd5e89b3505
diff --git a/www/vrweb/files/patch-aa b/www/vrweb/files/patch-aa
deleted file mode 100644
index 09ffdb6ec8ff..000000000000
--- a/www/vrweb/files/patch-aa
+++ /dev/null
@@ -1,77 +0,0 @@
---- src/common/utils/unixsocket.C.orig Fri Feb 21 21:41:25 1997
-+++ src/common/utils/unixsocket.C Wed Oct 20 19:35:42 1999
-@@ -67,6 +67,9 @@
- #if defined(BSDI)
- # define DONT_HAVE_SENDFD
- #endif
-+#if defined(FreeBSD)
-+# define DONT_HAVE_SENDFD
-+#endif
-
- #if ! (defined HAVE_SENDFD || defined DONT_HAVE_SENDFD)
- #error SEND_FD
-@@ -110,19 +113,29 @@
- sock = ::socket (AF_UNIX, SOCK_STREAM, 0) ;
- if (sock < 0) {
- DEBUGNL ("UNIXSocket::connect(): could not create socket") ;
-+#ifndef __FreeBSD__
- set_errno_(::errno) ;
-+#endif
- perror_("UNIXSocket::connect(): ::socket()") ;
- return false ;
- }
- if (::connect (sock, (struct sockaddr*)&addr, addrlen) < 0) {
-+#ifdef __FreeBSD__
-+ if (errno == ECONNREFUSED && retries > 0) {
-+#else
- if (::errno == ECONNREFUSED && retries > 0) {
-+#endif
- // try again since peer's backlog may just be full
- ::close (sock) ;
- ::sleep (1) ; // ++++
- continue ;
- } else {
- DEBUGNL ("UNIXSocket::connect(): cannot connect") ;
-+#ifdef __FreeBSD__
-+ set_errno_(errno) ;
-+#else
- set_errno_(::errno) ;
-+#endif
- perror_("UNIXSocket::connect(): ::connect()") ;
- ::close (sock) ;
- return false ;
-@@ -143,7 +156,11 @@
- int sock = ::socket (AF_UNIX, SOCK_STREAM, 0) ;
- if (sock < 0) {
- DEBUGNL ("UNIXSocket::listen(): could not create socket") ;
-+#ifdef __FreeBSD__
-+ set_errno_(errno) ;
-+#else
- set_errno_(::errno) ;
-+#endif
- perror_("UNIXSocket::listen(): ::socket()") ;
- return false ;
- }
-@@ -160,14 +177,22 @@
- // systems have 2 chars (len and family) instead.
- if (::bind (sock, (struct sockaddr*)&addr, 2 + pathlen) < 0) {
- DEBUGNL ("UNIXSocket::listen(): ::bind() error") ;
-+#ifdef __FreeBSD__
-+ set_errno_(errno) ;
-+#else
- set_errno_(::errno) ;
-+#endif
- perror_("UNIXSocket::listen(): ::bind()") ;
- ::close (sock) ;
- return false ;
- }
- if (::listen (sock, SOMAXCONN) < 0) {
- DEBUGNL ("UNIXSocket::listen(): ::listen() error") ;
-+#ifdef __FreeBSD__
-+ set_errno_(errno) ;
-+#else
- set_errno_(::errno) ;
-+#endif
- perror_("UNIXSocket::listen(): ::listen()") ;
- ::close (sock);
- return false ;
diff --git a/www/vrweb/files/patch-ab b/www/vrweb/files/patch-ab
deleted file mode 100644
index 22946a241c76..000000000000
--- a/www/vrweb/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/common/OS/directory.C.orig Thu Jan 30 18:58:15 1997
-+++ src/common/OS/directory.C Fri Oct 22 14:58:52 1999
-@@ -32,6 +32,7 @@
- * includes <sys/dir.h>, which is silly because <sys/dir.h>
- * needs <sys/types.h>.
- */
-+#include <sys/types.h>
- #include "types.h"
- #ifdef apollo
- #include <sys/dir.h>
diff --git a/www/vrweb/files/patch-ac b/www/vrweb/files/patch-ac
deleted file mode 100644
index ad151494404f..000000000000
--- a/www/vrweb/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/harmony/Imakefile.orig Fri Apr 17 12:39:50 1998
-+++ src/harmony/Imakefile Fri Apr 17 12:39:57 1998
-@@ -1,7 +1,6 @@
- # src/harmony Imakefile
-
- DIRS = \
-- mesa \
- ge3d \
- vrml \
- iicmviews \
diff --git a/www/vrweb/files/patch-ad b/www/vrweb/files/patch-ad
deleted file mode 100644
index 81b1ee70a33e..000000000000
--- a/www/vrweb/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/harmony/ge3d/mesa/ge3d_mesa.C.orig Thu Apr 23 16:05:07 1998
-+++ src/harmony/ge3d/mesa/ge3d_mesa.C Thu Apr 23 16:05:30 1998
-@@ -131,7 +131,7 @@
- #endif
-
- /* #include <GL/glx.h> */
--#include <mesa/GL/glu.h>
-+#include <GL/glu.h>
-
- #include <stdio.h>
- #include <math.h>
diff --git a/www/vrweb/files/patch-ae b/www/vrweb/files/patch-ae
deleted file mode 100644
index 8482d0292306..000000000000
--- a/www/vrweb/files/patch-ae
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/harmony/scene/mesacontext.C.orig Wed Feb 26 02:06:48 1997
-+++ src/harmony/scene/mesacontext.C Fri Oct 22 15:19:42 1999
-@@ -95,8 +95,8 @@
-
- #include <IV-X11/Xdefs.h> /* Display, Font of X11 */
- /* include <mesa/GL/xmesa.h> */
--#include <mesa/GL/glx.h>
--#include <mesa/GL/glu.h>
-+#include <GL/glx.h>
-+#include <GL/glu.h>
- #include <IV-X11/Xundefs.h> /* get back to IV's names */
-
- #include <iostream.h>
-@@ -236,6 +236,7 @@
- xdpy, &xvisinfo_, 1, // rgb mode
- 0, // no alpha planes (Mesa 2.0)
- double_buffered_,
-+ 0,
- imgcontext, // ximage or pixmap
- 1, 0, 0, // depth buffer, no stencil, no accum (Mesa 2.0)
- 0 // level (Mesa 2.0)
diff --git a/www/vrweb/files/patch-af b/www/vrweb/files/patch-af
deleted file mode 100644
index 433def17cda2..000000000000
--- a/www/vrweb/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/harmony/scene/Imakefile.orig Thu Apr 23 16:25:17 1998
-+++ src/harmony/scene/Imakefile Thu Apr 23 16:29:05 1998
-@@ -135,7 +135,7 @@
- #endif
- #ifdef MESA_GL
- MESA_CCLDLIBS = $(APP_CCLDLIBS) -l$(MESA_GE3D) $(MESA_LIBS) $(IV_CCLDLIBS) $(EXTRA_CCLDLIBS)
--MESA_CCDEPLIBS = $(HGLIBDIR)/lib$(MESA_GE3D).a $(HGLIBDIR)/libMesaGL.a $(HGLIBDIR)/libMesaGLU.a
-+MESA_CCDEPLIBS = $(HGLIBDIR)/lib$(MESA_GE3D).a
- #endif
-
- # Mosaic CCI
diff --git a/www/vrweb/files/patch-ag b/www/vrweb/files/patch-ag
deleted file mode 100644
index b32ddb5b9469..000000000000
--- a/www/vrweb/files/patch-ag
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/common/utils/socket.C.orig Wed Oct 20 19:23:22 1999
-+++ src/common/utils/socket.C Wed Oct 20 19:36:04 1999
-@@ -53,6 +53,8 @@
- //
- //
- // </file>
-+
-+#include <stdio.h>
- #include "socket.h"
-
- #include "new.h"
-@@ -186,7 +188,11 @@
- #ifndef WIN32
- int dupfd = ::dup (fd()) ;
- if (dupfd < 0) {
-+#ifdef __FreeBSD__
-+ set_errno_(errno) ;
-+#else
- set_errno_(::errno) ;
-+#endif
- perror_("Socket::accept_(sockaddr&,int&): ::dup()") ;
- return dupfd ;
- }
diff --git a/www/vrweb/files/patch-ah b/www/vrweb/files/patch-ah
deleted file mode 100644
index 834e89276661..000000000000
--- a/www/vrweb/files/patch-ah
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/common/Dispatch/connect.C.orig Wed Oct 20 19:39:20 1999
-+++ src/common/Dispatch/connect.C Wed Oct 20 19:41:38 1999
-@@ -102,7 +102,11 @@
- if ((iError=WSAGetLastError()) != WSAEWOULDBLOCK) {
- cerr << "ConnectRequest::ConnectRequest(): ::connect() code:" << iError<<endl;
- #else
-+#ifdef __FreeBSD__
-+ if (errno != EINPROGRESS) {
-+#else
- if (::errno != EINPROGRESS) {
-+#endif
- ::perror ("ConnectRequest::ConnectRequest(): ::connect()") ;
- #endif
- HGSOCKCLOSE (socket_) ;
-@@ -154,7 +158,11 @@
- sockaddr_in that ;
- int thatlen = sizeof (that) ;
- if (::getpeername (fd, (sockaddr*)&that, &thatlen) < 0) {
-+#ifdef __FreeBSD__
-+ if (! (errno==ENOTCONN || errno==ECONNREFUSED))
-+#else
- if (! (::errno==ENOTCONN || ::errno==ECONNREFUSED))
-+#endif
- ::perror ("ConnectRequest::outputReady(): ::getpeername()") ;
- callback->connectError (a) ;
- ::close (fd) ;
diff --git a/www/vrweb/files/patch-ai b/www/vrweb/files/patch-ai
deleted file mode 100644
index 7e9267d67f41..000000000000
--- a/www/vrweb/files/patch-ai
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/common/Dispatch/dispatcher.C.orig Wed Oct 20 19:42:05 1999
-+++ src/common/Dispatch/dispatcher.C Wed Oct 20 19:42:42 1999
-@@ -359,7 +359,11 @@
- DEBUGNL ("Dispatcher::waitForChild()") ;
- pid_t pid ;
- int status ;
-+#ifdef __FreeBSD__
-+ while ((pid = ::waitpid (-1, &status, WNOHANG)) > 0 || (pid < 0 && errno == EINTR)) {
-+#else
- while ((pid = ::waitpid (-1, &status, WNOHANG)) > 0 || (pid < 0 && ::errno == EINTR)) {
-+#endif
- DEBUGNL ("Dispatcher::waitForChild(): pid: "<<pid) ;
- DChildHandler lookup (pid) ;
- int pos ;
diff --git a/www/vrweb/files/patch-aj b/www/vrweb/files/patch-aj
deleted file mode 100644
index f08eb6070c05..000000000000
--- a/www/vrweb/files/patch-aj
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/common/Dispatch/rpcbuf.C.orig Wed Oct 20 19:42:58 1999
-+++ src/common/Dispatch/rpcbuf.C Wed Oct 20 19:44:12 1999
-@@ -977,12 +977,20 @@
- // jfasch 24 Apr 1995
- int rpcbuf :: rpc_read (int fd, char* buf, int len) {
- int nread ;
-+#ifdef __FreeBSD__
-+ while ((nread = ::read (fd, buf, len)) < 0 && errno == EINTR) ;
-+#else
- while ((nread = ::read (fd, buf, len)) < 0 && ::errno == EINTR) ;
-+#endif
- return nread ;
- }
- int rpcbuf :: rpc_write (int fd, const char* buf, int len) {
- int nwritten ;
-+#ifdef __FreeBSD__
-+ while ((nwritten = ::write (fd, buf, len)) < 0 && errno == EINTR) ;
-+#else
- while ((nwritten = ::write (fd, buf, len)) < 0 && ::errno == EINTR) ;
-+#endif
- return nwritten ;
- }
- #endif
diff --git a/www/vrweb/pkg-comment b/www/vrweb/pkg-comment
deleted file mode 100644
index c817cdef15cf..000000000000
--- a/www/vrweb/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A browser for a VRML 1.0 format file
diff --git a/www/vrweb/pkg-descr b/www/vrweb/pkg-descr
deleted file mode 100644
index 00b2e2821e48..000000000000
--- a/www/vrweb/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-VRweb is a browser for VRML 1.0.
-
-VRweb homepage is:
- http://www.iicm.edu/vrweb/
-
-VRML sample files in:
- http://www.iicm.edu/vrml
-
-You need texture files for some samples. Get
-http://www.iicm.edu/0x811b9908_0x002e3f24
-http://www.iicm.edu/0x811b9908_0x002e3c4a
-
-and untar them in your directory.
-
-tar xzvf 0x811b9908_0x002e3f24
-tar xzvf 0x811b9908_0x002e3c4a
-
-WWW: http://www.iicm.edu/vrweb/
diff --git a/www/vrweb/pkg-plist b/www/vrweb/pkg-plist
deleted file mode 100644
index 669ff28d7855..000000000000
--- a/www/vrweb/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-bin/vrweb
-share/doc/vrweb/README-help
-share/doc/vrweb/anchors.html
-share/doc/vrweb/basics.html
-share/doc/vrweb/custom.html
-share/doc/vrweb/display.html
-share/doc/vrweb/edit.html
-share/doc/vrweb/editdlg.html
-share/doc/vrweb/icons/harmonylogo.tif
-share/doc/vrweb/icons/harmonymask.xbm
-share/doc/vrweb/icons/hyperg.tif
-share/doc/vrweb/icons/hyperg_mask.xbm
-share/doc/vrweb/install.html
-share/doc/vrweb/keybd.html
-share/doc/vrweb/keybd1c.html
-share/doc/vrweb/mouse.html
-share/doc/vrweb/navigate/index.html
-share/doc/vrweb/navigate/modes.html
-share/doc/vrweb/statline.gif
-share/doc/vrweb/toolbar.gif
-share/doc/vrweb/vrweb.gif
-share/doc/vrweb/vrwebbg.gif
-share/doc/vrweb/vrwebhlp.html
-share/doc/vrweb/vrwebsmall.gif
-share/doc/vrweb/whatsnew.html
-@dirrm share/doc/vrweb/icons
-@dirrm share/doc/vrweb/navigate
-@dirrm share/doc/vrweb