aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-08-30 10:37:47 +0800
committermarcus <marcus@FreeBSD.org>2002-08-30 10:37:47 +0800
commitc9a78252b652d9884a78e939e8fdd9321a8c1520 (patch)
treee25e3722ebaac9f9cd374b8b188c0e1479fe2c9a
parent91e84559b483470ce5c1a413bb0ca7bc137f3896 (diff)
downloadfreebsd-ports-gnome-c9a78252b652d9884a78e939e8fdd9321a8c1520.tar.gz
freebsd-ports-gnome-c9a78252b652d9884a78e939e8fdd9321a8c1520.tar.zst
freebsd-ports-gnome-c9a78252b652d9884a78e939e8fdd9321a8c1520.zip
Update to 4.1.9.
-rw-r--r--math/gcalctool/Makefile18
-rw-r--r--math/gcalctool/distinfo2
-rw-r--r--math/gcalctool/files/patch-gcalctool_Makefile.in11
3 files changed, 10 insertions, 21 deletions
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index 3c9a9f4182a5..e2ae8354759a 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gcalctool
-PORTVERSION= 4.1.0
+PORTVERSION= 4.1.9
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/sources/gcalctool
+MASTER_SITE_SUBDIR= 2.0.1/sources/${PORTNAME}
DIST_SUBDIR= gnome2
MAINTAINER= marcus@FreeBSD.org
@@ -20,19 +20,19 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-MAN1= calctool.1
+MAN1= gcalctool.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
.include <bsd.port.mk>
diff --git a/math/gcalctool/distinfo b/math/gcalctool/distinfo
index 4fc78ed414f9..4c37f153030b 100644
--- a/math/gcalctool/distinfo
+++ b/math/gcalctool/distinfo
@@ -1 +1 @@
-MD5 (gnome2/gcalctool-4.1.0.tar.bz2) = 8ea71ea69c35e6fe84425ee47846f068
+MD5 (gnome2/gcalctool-4.1.9.tar.bz2) = e13948f80fd67e8e26fbddbdd8739526
diff --git a/math/gcalctool/files/patch-gcalctool_Makefile.in b/math/gcalctool/files/patch-gcalctool_Makefile.in
deleted file mode 100644
index fab5a43bc0b7..000000000000
--- a/math/gcalctool/files/patch-gcalctool_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcalctool/Makefile.in.orig Wed Jun 12 02:34:38 2002
-+++ gcalctool/Makefile.in Wed Jun 12 02:34:53 2002
-@@ -114,7 +114,7 @@
- extern.h
-
-
--gcalctool_LDADD = @PACKAGE_LIBS@ -lX11 -lsocket -lnsl
-+gcalctool_LDADD = @PACKAGE_LIBS@ -lX11
-
- pkgdata_DATA = calctool.gif
-