aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-20 16:54:11 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-20 16:54:11 +0800
commitc9d6d342850a049d11915722dd5ca2af481cf03a (patch)
treeff9eb5b2e1ecb1878d181d5d7dff4d270962d6c6
parent93a92faacbb581ae11a9438e93f81a8b85d2c48a (diff)
downloadfreebsd-ports-gnome-c9d6d342850a049d11915722dd5ca2af481cf03a.tar.gz
freebsd-ports-gnome-c9d6d342850a049d11915722dd5ca2af481cf03a.tar.zst
freebsd-ports-gnome-c9d6d342850a049d11915722dd5ca2af481cf03a.zip
- Add p5-Carp-Always-Color 0.05
Stack traces are hard to read when the messages wrap, because it's hard to tell when one message ends and the next message starts. Carp::Always::Color just colors the first line of each stacktrace, based on whether it's a warning or an error. If messages are being sent to a terminal, it colors them with terminal escape codes, otherwise it colors them with HTML (ideas for more intelligent behavior here are welcome). WWW: http://search.cpan.org/dist/Carp-Always-Color/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Carp-Always-Color/Makefile36
-rw-r--r--devel/p5-Carp-Always-Color/distinfo2
-rw-r--r--devel/p5-Carp-Always-Color/pkg-descr8
-rw-r--r--devel/p5-Carp-Always-Color/pkg-plist10
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e65943e2f3a5..35d945d2b85e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1272,6 +1272,7 @@
SUBDIR += p5-Calendar-Simple
SUBDIR += p5-Capture-Tiny
SUBDIR += p5-Carp-Always
+ SUBDIR += p5-Carp-Always-Color
SUBDIR += p5-Carp-Assert
SUBDIR += p5-Carp-Assert-More
SUBDIR += p5-Carp-Clan
diff --git a/devel/p5-Carp-Always-Color/Makefile b/devel/p5-Carp-Always-Color/Makefile
new file mode 100644
index 000000000000..df7a867ff9b3
--- /dev/null
+++ b/devel/p5-Carp-Always-Color/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Carp-Always-Color
+# Date created: 2011-09-11
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp-Always-Color
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Carp::Always, but with color
+
+BUILD_DEPENDS= p5-Carp-Always>=0.10:${PORTSDIR}/devel/p5-Carp-Always
+RUN_DEPENDS= p5-Carp-Always>=0.10:${PORTSDIR}/devel/p5-Carp-Always
+
+PERL_CONFIGURE= yes
+
+MAN3= Carp::Always::Color.3 \
+ Carp::Always::Color::HTML.3 \
+ Carp::Always::Color::Term.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500808
+BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.30:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+.endif
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Carp-Always-Color/distinfo b/devel/p5-Carp-Always-Color/distinfo
new file mode 100644
index 000000000000..ec89ff398714
--- /dev/null
+++ b/devel/p5-Carp-Always-Color/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Carp-Always-Color-0.05.tar.gz) = eef444c6641b2962d6d855ee191a184ea53aa7f35574d6e434c0db464bc78acd
+SIZE (Carp-Always-Color-0.05.tar.gz) = 12619
diff --git a/devel/p5-Carp-Always-Color/pkg-descr b/devel/p5-Carp-Always-Color/pkg-descr
new file mode 100644
index 000000000000..4288faa65441
--- /dev/null
+++ b/devel/p5-Carp-Always-Color/pkg-descr
@@ -0,0 +1,8 @@
+Stack traces are hard to read when the messages wrap, because it's hard to tell
+when one message ends and the next message starts. Carp::Always::Color just
+colors the first line of each stacktrace, based on whether it's a warning or an
+error. If messages are being sent to a terminal, it colors them with terminal
+escape codes, otherwise it colors them with HTML (ideas for more intelligent
+behavior here are welcome).
+
+WWW: http://search.cpan.org/dist/Carp-Always-Color/
diff --git a/devel/p5-Carp-Always-Color/pkg-plist b/devel/p5-Carp-Always-Color/pkg-plist
new file mode 100644
index 000000000000..a6802f099fb8
--- /dev/null
+++ b/devel/p5-Carp-Always-Color/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Carp/Always/Color.pm
+%%SITE_PERL%%/Carp/Always/Color/HTML.pm
+%%SITE_PERL%%/Carp/Always/Color/Term.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Always/Color/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Always/Color
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Always
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp
+@dirrm %%SITE_PERL%%/Carp/Always/Color
+@dirrmtry %%SITE_PERL%%/Carp/Always
+@dirrmtry %%SITE_PERL%%/Carp