aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-11-17 17:28:40 +0800
committerale <ale@FreeBSD.org>2008-11-17 17:28:40 +0800
commitc9f43bfa416e763829f80b97c15d36eb943dc5ca (patch)
tree08c4b9cf9945db83f25e9702792f8bc384475fe6
parent93581bbcf1ff0e77dc1ca970fe74981e572505a6 (diff)
downloadfreebsd-ports-gnome-c9f43bfa416e763829f80b97c15d36eb943dc5ca.tar.gz
freebsd-ports-gnome-c9f43bfa416e763829f80b97c15d36eb943dc5ca.tar.zst
freebsd-ports-gnome-c9f43bfa416e763829f80b97c15d36eb943dc5ca.zip
Accept all linuxthreads library major versions.
-rw-r--r--databases/mysql323-server/Makefile2
-rw-r--r--databases/mysql40-server/Makefile2
-rw-r--r--databases/mysql41-server/Makefile2
-rw-r--r--databases/mysql50-server/Makefile2
-rw-r--r--databases/mysql51-server/Makefile2
-rw-r--r--databases/mysql54-server/Makefile2
-rw-r--r--databases/mysql55-server/Makefile2
-rw-r--r--databases/mysql60-server/Makefile2
-rw-r--r--databases/percona55-server/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/databases/mysql323-server/Makefile b/databases/mysql323-server/Makefile
index d963ad2d316c..ba902950496c 100644
--- a/databases/mysql323-server/Makefile
+++ b/databases/mysql323-server/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index a924a95f15ae..453c9e8a954c 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -63,7 +63,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 6f453c8d8f30..69e4abe20bfb 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 4ade8dec8095..4a5169c4cf2d 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 34d3c4ba1d5e..76022e7c20c8 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 34d3c4ba1d5e..76022e7c20c8 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 34d3c4ba1d5e..76022e7c20c8 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 6cd8184323e6..0a33096322f9 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -74,7 +74,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 34d3c4ba1d5e..76022e7c20c8 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS+= lthread:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}