aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-10 02:26:40 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-10 02:26:40 +0800
commitcbbcf196aca40d0de5d2d1043f3e4d4d43029828 (patch)
tree4d97cf24329b12b9bf9d5897f9712405bbbae61f
parent48cdf414c656deb6c6a6117228e7db0f8b356ba8 (diff)
downloadfreebsd-ports-gnome-cbbcf196aca40d0de5d2d1043f3e4d4d43029828.tar.gz
freebsd-ports-gnome-cbbcf196aca40d0de5d2d1043f3e4d4d43029828.tar.zst
freebsd-ports-gnome-cbbcf196aca40d0de5d2d1043f3e4d4d43029828.zip
- Remove BROKEN statement for Tier-2 systems (tested on PowerPC only due
to lots of dependencies and lack of hardware or working SPARC emulation to perform tinderbox tests; c.f. https://reviews.freebsd.org/D2791) - Clean up `post-install' target and fix numerous whitespace issues
-rw-r--r--security/sssd/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 0b2e7e3966e7..931bb004d4eb 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -5,7 +5,7 @@ PORTNAME= sssd
DISTVERSION= 1.11.7
PORTREVISION= 2
CATEGORIES= security
-MASTER_SITES= https://fedorahosted.org/released/${PORTNAME}/ \
+MASTER_SITES= https://fedorahosted.org/released/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
MAINTAINER= lukas.slebodnik@intrak.sk
@@ -47,7 +47,7 @@ CONFIGURE_ARGS= --with-selinux=no --with-semanage=no \
--disable-cifs-idmap-plugin --disable-config-lib
CFLAGS+= -fstack-protector-all
PLIST_SUB= PYTHON_VER=${PYTHON_VER}
-#DEBUG_FLAGS= -g
+#DEBUG_FLAGS= -g
MAKE_ENV+= LINGUAS="bg de eu es fr hu id it ja nb nl pl pt ru sv tg tr uk zh_CN zh_TW"
SUB_FILES= pkg-message
@@ -59,7 +59,7 @@ PATHFIX_MAKEFILEIN= Makefile.am
INSTALL_TARGET= install-strip
CPE_VENDOR= fedoraproject
-python_CMD= ${SETENV} python2
+python_CMD= ${SETENV} python2
SHEBANG_FILES= src/tools/sss_obfuscate \
src/sbus/sbus_codegen
@@ -76,10 +76,6 @@ SMB_CONFIGURE_WITH= samba
.include <bsd.port.options.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not link on ia64, powerpc, or sparc64
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|SIGCLD|SIGCHLD|g' ${WRKSRC}/src/util/signal.c
@${REINPLACE_CMD} -e 's|NSS_STATUS_NOTFOUND|NS_NOTFOUND|g' \
@@ -102,14 +98,14 @@ post-patch:
@${CP} ${FILESDIR}/sss_bsd_errno.h ${WRKSRC}/src/util/sss_bsd_errno.h
post-install:
- ${INSTALL_DATA} ${WRKSRC}/src/examples/sssd-example.conf ${STAGEDIR}${ETCDIR}/sssd.conf.sample
- (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s nss_sss.so nss_sss.so.1)
-
- # clean these up from the install; we create them in rc script start_precmd
-.for VARDIRS in db/sss db/sss_mc log/sssd run/sss/krb5.include.d run/sss/private run/sss
- @${RMDIR} ${STAGEDIR}/var/${VARDIRS}
+ ${INSTALL_DATA} ${WRKSRC}/src/examples/sssd-example.conf \
+ ${STAGEDIR}${ETCDIR}/sssd.conf.sample
+ ${LN} -sf nss_sss.so ${STAGEDIR}${PREFIX}/lib/nss_sss.so.1
+# clean these up from the install; we create them in rc script start_precmd
+.for d in db/sss db/sss_mc log/sssd run/sss/krb5.include.d run/sss/private run/sss
+ @${RMDIR} ${STAGEDIR}/var/${d}
.endfor
- # clean unused man dirs
+# clean unused man dirs
.for i in nl/man1 nl/man5 pt/man1 pt/man5
@${RMDIR} ${STAGEDIR}${PREFIX}/man/${i}
.endfor