aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-06-07 01:25:52 +0800
committerculot <culot@FreeBSD.org>2011-06-07 01:25:52 +0800
commitcbbd6ae5c989d254d8265448d7751c499453d0d4 (patch)
tree92f4026a36e66c3b75bf5fd49717357338c97c19
parent868f32943de6fe6931cf59830d34a7070ed2132d (diff)
downloadfreebsd-ports-gnome-cbbd6ae5c989d254d8265448d7751c499453d0d4.tar.gz
freebsd-ports-gnome-cbbd6ae5c989d254d8265448d7751c499453d0d4.tar.zst
freebsd-ports-gnome-cbbd6ae5c989d254d8265448d7751c499453d0d4.zip
Sub::Alias does a compile-time code injection to let you define subroutine
aliases based on its name. This differs from p5-Sub-Name in that it defines a typeglob in a more correct way and keeps you from manipulating the symbols table directly. You can use the subroutine as if it was defined the ordinary way then. This is particularly useful in the cases when you need to have several identical subroutines with different names. WWW: http://search.cpan.org/dist/Sub-Alias/ PR: ports/157632 Submitted by: Peter Vereshagin <peter@vereshagin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Alias/Makefile30
-rw-r--r--devel/p5-Sub-Alias/distinfo2
-rw-r--r--devel/p5-Sub-Alias/pkg-descr11
-rw-r--r--devel/p5-Sub-Alias/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b4712f144735..27458c6f000e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2257,6 +2257,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
+ SUBDIR += p5-Sub-Alias
SUBDIR += p5-Sub-Current
SUBDIR += p5-Sub-Delete
SUBDIR += p5-Sub-Exporter
diff --git a/devel/p5-Sub-Alias/Makefile b/devel/p5-Sub-Alias/Makefile
new file mode 100644
index 000000000000..a99b124a0e13
--- /dev/null
+++ b/devel/p5-Sub-Alias/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: devel/p5-Sub-Alias
+# Date created: 2011-06-06
+# Whom: Peter Vereshagin <peter@vereshagin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Alias
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= peter@vereshagin.org
+COMMENT= Simple subroutine alias
+
+BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Devel-Declare>=0:${PORTSDIR}/devel/p5-Devel-Declare \
+ p5-Devel-BeginLift>=0:${PORTSDIR}/devel/p5-Devel-BeginLift
+RUN_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Devel-Declare>=0:${PORTSDIR}/devel/p5-Devel-Declare \
+ p5-Devel-BeginLift>=0:${PORTSDIR}/devel/p5-Devel-BeginLift
+
+PERL_CONFIGURE= 5.8.0+
+
+LICENSE= MIT
+
+MAN3= Sub::Alias.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sub-Alias/distinfo b/devel/p5-Sub-Alias/distinfo
new file mode 100644
index 000000000000..a346405e98d3
--- /dev/null
+++ b/devel/p5-Sub-Alias/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Sub-Alias-0.03.tar.gz) = 8a408483ddb7d5daefbe3e25ad50b027b08e6af0b089d30bf7f32de83bd629d1
+SIZE (Sub-Alias-0.03.tar.gz) = 16333
diff --git a/devel/p5-Sub-Alias/pkg-descr b/devel/p5-Sub-Alias/pkg-descr
new file mode 100644
index 000000000000..488d881667cd
--- /dev/null
+++ b/devel/p5-Sub-Alias/pkg-descr
@@ -0,0 +1,11 @@
+This module does a compile-time code injection to let you define subroutine
+aliases based on its name.
+
+This differs from p5-Sub-Name in that it defines a typeglob in a more correct
+way and keeps you from manipulating the symbols table directly. You can use
+the subroutine as if it was defined the ordinary way then.
+
+This is particularly useful in the cases when you need to have several
+identical subroutines with different names.
+
+WWW: http://search.cpan.org/dist/Sub-Alias/
diff --git a/devel/p5-Sub-Alias/pkg-plist b/devel/p5-Sub-Alias/pkg-plist
new file mode 100644
index 000000000000..23c7e1d85102
--- /dev/null
+++ b/devel/p5-Sub-Alias/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sub/Alias.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Alias/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Alias
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sub