aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2013-08-20 05:25:22 +0800
committervg <vg@FreeBSD.org>2013-08-20 05:25:22 +0800
commitcd28fc10b0b0fb81ca46508a7228f65e34e20e69 (patch)
tree61cbb941dcb970da9ba407d10e3ab5600a3047d7
parent7bc172e31e171ba531e93388625b8383211e25e1 (diff)
downloadfreebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.tar.gz
freebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.tar.zst
freebsd-ports-gnome-cd28fc10b0b0fb81ca46508a7228f65e34e20e69.zip
- Bump portrevision
- USES gmake pkgconfig pathfix icon - Add docs - Trim NLS - Add DOCS and NLS Option - Add Desktop entry file - Add patch linux/soundcard --> sys/soundcard - Add Icons - Trim WWW - Trim pkg-plist, remove docs PR: ports/181180 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler (mentor)
-rw-r--r--audio/gvolwheel/Makefile40
-rw-r--r--audio/gvolwheel/files/patch-Makefile.in17
-rw-r--r--audio/gvolwheel/files/pkg-message.in21
-rw-r--r--audio/gvolwheel/pkg-descr2
-rw-r--r--audio/gvolwheel/pkg-plist10
5 files changed, 62 insertions, 28 deletions
diff --git a/audio/gvolwheel/Makefile b/audio/gvolwheel/Makefile
index c825aa0e0efd..b3014cbb83cd 100644
--- a/audio/gvolwheel/Makefile
+++ b/audio/gvolwheel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gvolwheel
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}
@@ -15,26 +16,37 @@ BUILD_DEPENDS= intltoolize:${PORTSDIR}/textproc/intltool
CONFIGURE_ARGS+=--enable-oss
GNU_CONFIGURE= yes
-USES= pkgconfig pathfix iconv
-USE_GMAKE= yes
+USES= gmake iconv pathfix pkgconfig
USE_GNOME= gtk30
-OPTIONS_DEFINE= NLS
-NLS_DESC= Native language support
+PORTDOCS= AUTHORS ChangeLog README
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
-USES+= gettext
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+
+SUB_FILES= pkg-message
-pre-configure:
- ${ECHO} "${DOCSDIR}"
+DESKTOP_ENTRIES="GVolWheel" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "GTK;AudioVideo;Audio;Mixer;" true
+
+.include <bsd.port.options.mk>
+
+post-patch:
${REINPLACE_CMD} -e 's|linux/soundcard|sys/soundcard|g' \
${WRKSRC}/src/callbacks.c ${WRKSRC}/src/actions.c
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ ${LN} -sf ${PREFIX}/share/pixmaps/gvolwheel/audio-volume-high.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
.include <bsd.port.mk>
diff --git a/audio/gvolwheel/files/patch-Makefile.in b/audio/gvolwheel/files/patch-Makefile.in
index 1413476ee004..9db7ea06a7c0 100644
--- a/audio/gvolwheel/files/patch-Makefile.in
+++ b/audio/gvolwheel/files/patch-Makefile.in
@@ -1,11 +1,18 @@
---- Makefile.in.orig 2010-04-03 19:20:45.000000000 +0800
-+++ Makefile.in 2010-06-08 13:08:12.000000000 +0800
-@@ -268,7 +268,7 @@
+--- Makefile.in.orig 2012-04-08 00:37:17.000000000 +0200
++++ Makefile.in 2013-08-03 17:39:52.000000000 +0200
+@@ -315,14 +315,8 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = src po
-gvolwheeldocdir = ${prefix}/doc/gvolwheel
+gvolwheeldocdir = ${prefix}/share/doc/gvolwheel
gvolwheeldoc_DATA = \
- README\
- COPYING\
+- README\
+- COPYING\
+- AUTHORS\
+- ChangeLog\
+- INSTALL\
+- NEWS
+
+ EXTRA_DIST = $(gvolwheeldoc_DATA) \
+ $(intltool_DATA)\
diff --git a/audio/gvolwheel/files/pkg-message.in b/audio/gvolwheel/files/pkg-message.in
new file mode 100644
index 000000000000..1f51d06b8c8f
--- /dev/null
+++ b/audio/gvolwheel/files/pkg-message.in
@@ -0,0 +1,21 @@
+===============================================================================
+
+GVolWheel has been installed.
+
+
+You could adjust which mixer you wish to use with
+
+GVolWheel / Preferences / Default mixer
+
+
+Default is used ALSA with
+
+ gnome-alsamixer
+
+
+You could use aumix with similar settings
+
+ aumix -d /dev/mixer2 -I
+
+
+===============================================================================
diff --git a/audio/gvolwheel/pkg-descr b/audio/gvolwheel/pkg-descr
index 7501c0220df8..03aff1a40b9b 100644
--- a/audio/gvolwheel/pkg-descr
+++ b/audio/gvolwheel/pkg-descr
@@ -3,4 +3,4 @@ volume. GVolWheel is application which lets you control the volume easily
through a tray icon you can scroll on. Easily integrate with minimal
desktops (Openbox,IceWM,XFCE etc).
-WWW: http://sourceforge.net/projects/gvolwheel/
+WWW: http://sourceforge.net/projects/gvolwheel/
diff --git a/audio/gvolwheel/pkg-plist b/audio/gvolwheel/pkg-plist
index 50a02d910515..df6b58a688c6 100644
--- a/audio/gvolwheel/pkg-plist
+++ b/audio/gvolwheel/pkg-plist
@@ -1,14 +1,8 @@
-%%DOCSDIR%%/AUTHORS
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/INSTALL
-%%DOCSDIR%%/NEWS
-%%DOCSDIR%%/README
-%%NLS%%share/locale/ru/LC_MESSAGES/gvolwheel.mo
bin/gvolwheel
+%%NLS%%share/locale/ru/LC_MESSAGES/gvolwheel.mo
+share/pixmaps/gvolwheel.png
share/pixmaps/gvolwheel/audio-volume-high.png
share/pixmaps/gvolwheel/audio-volume-low.png
share/pixmaps/gvolwheel/audio-volume-medium.png
share/pixmaps/gvolwheel/audio-volume-muted.png
-@dirrm %%DOCSDIR%%
@dirrm share/pixmaps/gvolwheel