aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-07-23 05:33:46 +0800
committermadpilot <madpilot@FreeBSD.org>2016-07-23 05:33:46 +0800
commitcd564ecf43873ff4a9c5473cd2af5a8632e3e142 (patch)
tree026beed3861d052e730a65f6a2b57e5ea6e183bb
parent4ac5bac4928ef169c882bb0a986db43192ee2efb (diff)
downloadfreebsd-ports-gnome-cd564ecf43873ff4a9c5473cd2af5a8632e3e142.tar.gz
freebsd-ports-gnome-cd564ecf43873ff4a9c5473cd2af5a8632e3e142.tar.zst
freebsd-ports-gnome-cd564ecf43873ff4a9c5473cd2af5a8632e3e142.zip
- Update to 2.63.0
- Add missing direct dependencies reported by poudriere
-rw-r--r--deskutils/calibre/Makefile8
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/files/patch-setup_build.py20
-rw-r--r--deskutils/calibre/pkg-plist1
4 files changed, 29 insertions, 6 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index ed2c2418a00d..4ae651297e2a 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 2.62.0
+PORTVERSION= 2.63.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -57,12 +57,14 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
USE_RC_SUBR= calibre
EXTRACT_BEFORE_ARGS= -x -s '/^calibre/~-src/' -f
-USES= desktop-file-utils pkgconfig python:2 shared-mime-info shebangfix tar:xz
+USES= desktop-file-utils pkgconfig python:2 shared-mime-info \
+ shebangfix ssl tar:xz
SHEBANG_FILES= resources/calibre-portable.sh \
src/calibre/ebooks/metadata/odt.py \
src/calibre/utils/*.py \
src/odf/*.py
-USE_QT5= buildtools_build dbus qmake_build
+USE_QT5= buildtools_build core dbus gui qmake_build widgets
+USE_GL= gl
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index fca5b5f38021..7adcd00ea428 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467965226
-SHA256 (calibre-2.62.0.tar.xz) = ca4e7b13bfbf3950e32c91d163bd31a310fb386375d4c02f4bde8dd7b49b1a97
-SIZE (calibre-2.62.0.tar.xz) = 40671664
+TIMESTAMP = 1469190811
+SHA256 (calibre-2.63.0.tar.xz) = 0672a155edfafd50a507ebcfa20de2cfc23780e082eccbb89374f8aab3d98fe7
+SIZE (calibre-2.63.0.tar.xz) = 40700876
diff --git a/deskutils/calibre/files/patch-setup_build.py b/deskutils/calibre/files/patch-setup_build.py
new file mode 100644
index 000000000000..0d2e27901a07
--- /dev/null
+++ b/deskutils/calibre/files/patch-setup_build.py
@@ -0,0 +1,20 @@
+--- setup/build.py.orig 2016-07-22 02:21:05 UTC
++++ setup/build.py
+@@ -79,7 +79,7 @@ def is_ext_allowed(ext):
+ only = ext.get('only', '')
+ if only:
+ only = only.split()
+- q = 'windows' if iswindows else 'osx' if isosx else 'linux'
++ q = 'windows' if iswindows else 'osx' if isosx else 'bsd' if isbsd else 'linux'
+ return q in only
+ return True
+
+@@ -94,6 +94,8 @@ def parse_extension(ext):
+ ans = ext.pop('windows_' + k, ans)
+ elif isosx:
+ ans = ext.pop('osx_' + k, ans)
++ elif isbsd:
++ ans = ext.pop('bsd_' + k, ans)
+ else:
+ ans = ext.pop('linux_' + k, ans)
+ return ans
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 3535915dd2da..0e653fc0c160 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -1597,6 +1597,7 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/catalog/stylesheet.css
%%DATADIR%%/catalog/template.xhtml
%%DATADIR%%/coffee-script.js
+%%DATADIR%%/common-user-agents.txt
%%DATADIR%%/compiled_coffeescript.zip
%%DATADIR%%/content-server/autoreload.js
%%DATADIR%%/content-server/calibre.png