aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-02 18:35:45 +0800
committerbapt <bapt@FreeBSD.org>2013-09-02 18:35:45 +0800
commitce3251af7bb756ec807026d65b889a811a4a9345 (patch)
tree00ee1f37b631a88be4e277a04a111435cefc8d62
parentc408aee7bacfc3e9618d11a9191806712de99f3c (diff)
downloadfreebsd-ports-gnome-ce3251af7bb756ec807026d65b889a811a4a9345.tar.gz
freebsd-ports-gnome-ce3251af7bb756ec807026d65b889a811a4a9345.tar.zst
freebsd-ports-gnome-ce3251af7bb756ec807026d65b889a811a4a9345.zip
Track down the latest USE_GNOME=pkgconfig
-rw-r--r--ports-mgmt/kpackagekit/Makefile8
-rw-r--r--security/yersinia/Makefile9
-rw-r--r--textproc/libxml2/Makefile4
-rw-r--r--x11-fonts/gbdfed/Makefile10
4 files changed, 9 insertions, 22 deletions
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index 7b6dcc83be43..48b68808a230 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: kpackagekit
-# Date created: 11 May 2010
-# Whom: Alberto Villa <avilla@FreeBSD.org>
-#
+# Created by: Alberto Villa <avilla@FreeBSD.org>
# $FreeBSD$
PORTNAME= KPackageKit
@@ -20,10 +17,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= packagekit-qt.14:${PORTSDIR}/ports-mgmt/packagekit-qt4
USE_BZIP2= yes
-USE_GNOME= pkgconfig
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= cmake gettext
+USES= cmake gettext pkgconfig
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index c32a41913ffd..b0f1ff429c54 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yersinia
-# Date created: Sun Jul 24 10:43:13 CEST 2005
-# Whom: se
-#
+# Created by: se
# $FreeBSD$
-#
PORTNAME= yersinia
PORTVERSION= 0.7.1
@@ -22,7 +18,8 @@ WITH_GTK= true
.endif
.endif
.if defined(WITH_GTK)
-USE_GNOME+= pkgconfig gtk20
+USES= pkgconfig
+USE_GNOME+= gtk20
PKGNAMESUFFIX= -gtk
CONFLICTS= yersinia-[0-9]*
.else
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 54b3d6d8b595..7ee713651d37 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -17,10 +17,8 @@ COMMENT?= XML parser library for GNOME
.if !defined(REFERENCE_PORT)
USE_CSTD= gnu89
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USES= pathfix iconv
-USE_GNOME?= pkgconfig
+USES= pathfix gmake iconv pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
diff --git a/x11-fonts/gbdfed/Makefile b/x11-fonts/gbdfed/Makefile
index 81d9cb24f64a..ee0cc62a4838 100644
--- a/x11-fonts/gbdfed/Makefile
+++ b/x11-fonts/gbdfed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gbdfed
-# Date created: 2012-06-05
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= gbdfed
PORTVERSION= 1.6
@@ -16,8 +12,8 @@ COMMENT= A GTK2 bitmap font editor
LICENSE= MIT
USE_BZIP2= yes
-USES= gettext
-USE_GNOME= gtk20 pkgconfig
+USES= gettext pkgconfig
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include