aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-13 20:11:07 +0800
committerpav <pav@FreeBSD.org>2005-07-13 20:11:07 +0800
commitcf62a6d3af05179d11e725dd54a0412c7c11ebea (patch)
tree0c2c62b1e054fc2269edd168bfa559f942267d2a
parentea660fa48f6b259ce68d8ceac1373291e43c689b (diff)
downloadfreebsd-ports-gnome-cf62a6d3af05179d11e725dd54a0412c7c11ebea.tar.gz
freebsd-ports-gnome-cf62a6d3af05179d11e725dd54a0412c7c11ebea.tar.zst
freebsd-ports-gnome-cf62a6d3af05179d11e725dd54a0412c7c11ebea.zip
Gastman is a graphical Manager interface for Asterisk.
It uses the GTK+ library, and so is usually run under XWindows, although GTK+ environments also exist for Windows and Mac OS X. PR: ports/83296 Submitted by: Filippo Natali <filippo.natali@gmail.com>
-rw-r--r--net/Makefile1
-rw-r--r--net/gastman/Makefile30
-rw-r--r--net/gastman/distinfo2
-rw-r--r--net/gastman/pkg-descr3
-rw-r--r--net/gastman/pkg-plist76
5 files changed, 112 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f59134e0d84f..f79cba38102a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -158,6 +158,7 @@
SUBDIR += gaim-rss-reader
SUBDIR += gajim
SUBDIR += gale
+ SUBDIR += gastman
SUBDIR += gatekeeper
SUBDIR += gdesklets-lt-network
SUBDIR += gdesklets-networkinfo
diff --git a/net/gastman/Makefile b/net/gastman/Makefile
new file mode 100644
index 000000000000..250a9b127213
--- /dev/null
+++ b/net/gastman/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gastman
+# Date created: 2005-07-11
+# Whom: Filippo Natali <filippo.natali@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gastman
+PORTVERSION= 1.0.r1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.asterisk.org/pub/gastman/
+DISTNAME= ${PORTNAME}-1.0-RC1
+
+MAINTAINER= filippo.natali@gmail.com
+COMMENT= Graphical Manager interface for Asterisk
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS=|CFLAGS=${CFLAGS} -D__FreeBSD__ |g; \
+ s|$$(INSTALL_PREFIX)/usr/sbin|${PREFIX}/bin|g; \
+ s|$$(INSTALL_PREFIX)/usr/share|${PREFIX}/share|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|ICON_PATH "/usr/share/gastman/icons"|ICON_PATH "${PREFIX}/share/${PORTNAME}/icons"|g' ${WRKSRC}/gui.c
+
+.include <bsd.port.mk>
diff --git a/net/gastman/distinfo b/net/gastman/distinfo
new file mode 100644
index 000000000000..958ceb10351d
--- /dev/null
+++ b/net/gastman/distinfo
@@ -0,0 +1,2 @@
+MD5 (gastman-1.0-RC1.tar.gz) = 367cecdba791acf9e1566632c69347d1
+SIZE (gastman-1.0-RC1.tar.gz) = 333735
diff --git a/net/gastman/pkg-descr b/net/gastman/pkg-descr
new file mode 100644
index 000000000000..72cb5ddc2310
--- /dev/null
+++ b/net/gastman/pkg-descr
@@ -0,0 +1,3 @@
+Gastman is a graphical Manager interface for Asterisk.
+It uses the GTK+ library, and so is usually run under XWindows,
+although GTK+ environments also exist for Windows and Mac OS X.
diff --git a/net/gastman/pkg-plist b/net/gastman/pkg-plist
new file mode 100644
index 000000000000..c8b6ee6dd3cb
--- /dev/null
+++ b/net/gastman/pkg-plist
@@ -0,0 +1,76 @@
+bin/gastman
+%%DATADIR%%/icons/womanonphone-tiny.xpm
+%%DATADIR%%/icons/mailbox-big.xpm
+%%DATADIR%%/icons/receptionist-big.xpm
+%%DATADIR%%/icons/tiredguy-big.xpm
+%%DATADIR%%/icons/nervous-medium.xpm
+%%DATADIR%%/icons/mailbox-tiny.xpm
+%%DATADIR%%/icons/agentlogin-big.xpm
+%%DATADIR%%/icons/wastebasket-big.xpm
+%%DATADIR%%/icons/phone2.xpm
+%%DATADIR%%/icons/queue-tiny.xpm
+%%DATADIR%%/icons/nervous-big.xpm
+%%DATADIR%%/icons/agentlogin-small.xpm
+%%DATADIR%%/icons/queue-medium.xpm
+%%DATADIR%%/icons/manonphone-tiny.xpm
+%%DATADIR%%/icons/cell-tiny.xpm
+%%DATADIR%%/icons/salesguy-big.xpm
+%%DATADIR%%/icons/inkwell.xpm
+%%DATADIR%%/icons/tiredguy-medium.xpm
+%%DATADIR%%/icons/salesguy-tiny.xpm
+%%DATADIR%%/icons/bigboss-tiny.xpm
+%%DATADIR%%/icons/meeting-medium.xpm
+%%DATADIR%%/icons/tiredguy-small.xpm
+%%DATADIR%%/icons/music-medium.xpm
+%%DATADIR%%/icons/tinycaller.xpm
+%%DATADIR%%/icons/music-tiny.xpm
+%%DATADIR%%/icons/programmer-tiny.xpm
+%%DATADIR%%/icons/tinyphone.xpm
+%%DATADIR%%/icons/green_off.xpm
+%%DATADIR%%/icons/manonphone-small.xpm
+%%DATADIR%%/icons/cell-medium.xpm
+%%DATADIR%%/icons/wastebasket-medium.xpm
+%%DATADIR%%/icons/wastebasket-tiny.xpm
+%%DATADIR%%/icons/clouds-tiny.xpm
+%%DATADIR%%/icons/meeting-tiny.xpm
+%%DATADIR%%/icons/agentlogin-tiny.xpm
+%%DATADIR%%/icons/receptionist-tiny.xpm
+%%DATADIR%%/icons/mailbox-small.xpm
+%%DATADIR%%/icons/music-big.xpm
+%%DATADIR%%/icons/mailbox-medium.xpm
+%%DATADIR%%/icons/music-small.xpm
+%%DATADIR%%/icons/womanonphone-medium.xpm
+%%DATADIR%%/icons/meeting-big.xpm
+%%DATADIR%%/icons/receptionist-medium.xpm
+%%DATADIR%%/icons/nervous-tiny.xpm
+%%DATADIR%%/icons/clouds-big.xpm
+%%DATADIR%%/icons/clouds-small.xpm
+%%DATADIR%%/icons/clouds-medium.xpm
+%%DATADIR%%/icons/womanonphone-big.xpm
+%%DATADIR%%/icons/queue-big.xpm
+%%DATADIR%%/icons/bigboss-small.xpm
+%%DATADIR%%/icons/tiredguy-tiny.xpm
+%%DATADIR%%/icons/bigboss-medium.xpm
+%%DATADIR%%/icons/agentlogin-medium.xpm
+%%DATADIR%%/icons/cell-big.xpm
+%%DATADIR%%/icons/bigboss-big.xpm
+%%DATADIR%%/icons/meeting-small.xpm
+%%DATADIR%%/icons/manonphone-medium.xpm
+%%DATADIR%%/icons/wastebasket-small.xpm
+%%DATADIR%%/icons/programmer-small.xpm
+%%DATADIR%%/icons/cell-small.xpm
+%%DATADIR%%/icons/womanonphone-small.xpm
+%%DATADIR%%/icons/nervous-small.xpm
+%%DATADIR%%/icons/receptionist-small.xpm
+%%DATADIR%%/icons/programmer-medium.xpm
+%%DATADIR%%/icons/phone.xpm
+%%DATADIR%%/icons/red_off.xpm
+%%DATADIR%%/icons/red_on.xpm
+%%DATADIR%%/icons/salesguy-medium.xpm
+%%DATADIR%%/icons/manonphone-big.xpm
+%%DATADIR%%/icons/salesguy-small.xpm
+%%DATADIR%%/icons/green_on.xpm
+%%DATADIR%%/icons/programmer-big.xpm
+%%DATADIR%%/icons/queue-small.xpm
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%