aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-11 04:33:16 +0800
committerbapt <bapt@FreeBSD.org>2013-12-11 04:33:16 +0800
commitd0909f0152589437c9aee941ef91f7f767e2f902 (patch)
tree1d5f8845757a150cfffbce1f74599d23527b3e4e
parent3bf25a1825b5b53eda9453cbf90f7a67e9f7ca3f (diff)
downloadfreebsd-ports-gnome-d0909f0152589437c9aee941ef91f7f767e2f902.tar.gz
freebsd-ports-gnome-d0909f0152589437c9aee941ef91f7f767e2f902.tar.zst
freebsd-ports-gnome-d0909f0152589437c9aee941ef91f7f767e2f902.zip
Support stage
-rw-r--r--archivers/stuffit/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/archivers/stuffit/Makefile b/archivers/stuffit/Makefile
index 4c12e28af5ce..ed6642c62e68 100644
--- a/archivers/stuffit/Makefile
+++ b/archivers/stuffit/Makefile
@@ -15,14 +15,12 @@ RESTRICTED= Only unmodified original package can be distributed
ONLY_FOR_ARCHS= i386 amd64
-NO_STAGE= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes
STUFFIT_FILES= bin/unstuff bin/stuff
STUFFIT_MAN= man/man1/stuff.1 man/man1/unstuff.1
-PLIST_FILES= ${STUFFIT_FILES}
-
-MAN1= stuff.1 unstuff.1
+PLIST_FILES= ${STUFFIT_FILES} \
+ ${STUFFIT_MAN:S,$,.gz,}
do-build:
.for sFile in ${STUFFIT_FILES}
@@ -31,10 +29,10 @@ do-build:
do-install:
.for sFile in ${STUFFIT_FILES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${sFile} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${sFile} ${STAGEDIR}${PREFIX}/bin
.endfor
.for mFile in ${STUFFIT_MAN}
- ${INSTALL_MAN} ${WRKSRC}/${mFile} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${mFile} ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>