aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-08 00:26:42 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-08 00:26:42 +0800
commitd1f9494d978fcad31de22993ea868fb8e1c23c9e (patch)
treef68f8821726e405cf2e489fa10e63e3c91130e9e
parente7dac27df99db8ce1369ce5324408eef1e0f3c42 (diff)
downloadfreebsd-ports-gnome-d1f9494d978fcad31de22993ea868fb8e1c23c9e.tar.gz
freebsd-ports-gnome-d1f9494d978fcad31de22993ea868fb8e1c23c9e.tar.zst
freebsd-ports-gnome-d1f9494d978fcad31de22993ea868fb8e1c23c9e.zip
- Add rubygem-http 0.6.1
The HTTP Gem is an easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests Under the hood, The HTTP Gem uses http_parser.rb, a fast HTTP parsing native extension based on the Node.js parser and a Java port thereof. WWW: https://github.com/tarcieri/http RG: https://rubygems.org/gems/http
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-http/Makefile20
-rw-r--r--www/rubygem-http/distinfo2
-rw-r--r--www/rubygem-http/pkg-descr9
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d9b5cee72751..47270f399217 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1801,6 +1801,7 @@
SUBDIR += rubygem-heroku-nav
SUBDIR += rubygem-hpricot
SUBDIR += rubygem-html2haml
+ SUBDIR += rubygem-http
SUBDIR += rubygem-http-cookie
SUBDIR += rubygem-httpi
SUBDIR += rubygem-httparty
diff --git a/www/rubygem-http/Makefile b/www/rubygem-http/Makefile
new file mode 100644
index 000000000000..9d0c61ad3937
--- /dev/null
+++ b/www/rubygem-http/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http
+PORTVERSION= 0.6.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple Ruby DSL for making HTTP requests
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-http_parser.rb>=0.6:${PORTSDIR}/net/rubygem-http_parser.rb
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-http/distinfo b/www/rubygem-http/distinfo
new file mode 100644
index 000000000000..4af559db32cc
--- /dev/null
+++ b/www/rubygem-http/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/http-0.6.1.gem) = 6c1c88b7abe75f6e4da320882761e1b310ab622f410897ba6b845d647d799b16
+SIZE (rubygem/http-0.6.1.gem) = 66048
diff --git a/www/rubygem-http/pkg-descr b/www/rubygem-http/pkg-descr
new file mode 100644
index 000000000000..7d6b6d1d7315
--- /dev/null
+++ b/www/rubygem-http/pkg-descr
@@ -0,0 +1,9 @@
+The HTTP Gem is an easy-to-use client library for making requests from Ruby. It
+uses a simple method chaining system for building requests, similar to Python's
+Requests
+
+Under the hood, The HTTP Gem uses http_parser.rb, a fast HTTP parsing native
+extension based on the Node.js parser and a Java port thereof.
+
+WWW: https://github.com/tarcieri/http
+RG: https://rubygems.org/gems/http