aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-03 22:55:28 +0800
committermarino <marino@FreeBSD.org>2015-03-03 22:55:28 +0800
commitd333718af994f6f58656f8721fb3d4ae0ec3a586 (patch)
tree87bc866292198ff38114c9b3a25fe0d6472dedb8
parentf07391b455db1c31665b5ae5dea6586d0dcfb57c (diff)
downloadfreebsd-ports-gnome-d333718af994f6f58656f8721fb3d4ae0ec3a586.tar.gz
freebsd-ports-gnome-d333718af994f6f58656f8721fb3d4ae0ec3a586.tar.zst
freebsd-ports-gnome-d333718af994f6f58656f8721fb3d4ae0ec3a586.zip
databases/apq-mysql: Support default MySQL (5.6)
This port generates some headers based on MySQL headers, and a couple of the variables must have been deprecated because the resulting variable name ended in "__UNUSED". Double underscores are not allowed in Ada, so the build broke. Since the Ada header is generated during the configure phase, I'm adding a post-configure target to replace "__" with "_" to restore the build. Since the dependencies change from MySQL 5.5 to MySQL 5.6, revbump.
-rw-r--r--databases/apq-mysql/Makefile8
-rw-r--r--databases/apq/Makefile.version2
2 files changed, 7 insertions, 3 deletions
diff --git a/databases/apq-mysql/Makefile b/databases/apq-mysql/Makefile
index 70797f4e7980..aa95818095a6 100644
--- a/databases/apq-mysql/Makefile
+++ b/databases/apq-mysql/Makefile
@@ -20,8 +20,6 @@ RUN_DEPENDS= ${LOCALBASE}/lib/gnat/apq.gpr:${PORTSDIR}/databases/apq
USES= ada tar:bzip2
USE_MYSQL= yes
-MYSQL_DEFAULT= 55
-IGNORE_MYSQL_VER= 56
HAS_CONFIGURE= yes
WRKPATH= ${WRKDIR}/build
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -39,6 +37,12 @@ post-patch:
${REINPLACE_CMD} -e 's|-ws|-ws --autoconf=dummy.cgpr|' \
${WRKSRC}/scripts/buildutil.sh
+post-configure:
+ # The header generated with MySQL 5.6 comes with two instances of
+ # double underscore variables, which is illegal in Ada
+ ${REINPLACE_CMD} -e 's|__|_|' \
+ ${WRKDIR}/build/include/apq-mysql/apq-mysql.ads
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
${STAGEDIR}${PREFIX}/lib/apq-mysql/static \
diff --git a/databases/apq/Makefile.version b/databases/apq/Makefile.version
index 9180d40c6919..3c65ebd5b8ba 100644
--- a/databases/apq/Makefile.version
+++ b/databases/apq/Makefile.version
@@ -3,5 +3,5 @@
APQ_VERSION= 3.2.0
BASE_PORTREV= 0
DRV_ODBC_PR= 0
-DRV_MYSQL_PR= 0
+DRV_MYSQL_PR= 1
DRV_PGSQL_PR= 0