aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-10-18 23:31:20 +0800
committertijl <tijl@FreeBSD.org>2013-10-18 23:31:20 +0800
commitd3ce27f4ffe66205a3d683df7b1f998a1fb6c81d (patch)
tree2f8c8961a85f3a4a0409b4bc99681f3a854a25c8
parent08e4df1394ee9ca1d609b933ebdcdb3e063b5365 (diff)
downloadfreebsd-ports-gnome-d3ce27f4ffe66205a3d683df7b1f998a1fb6c81d.tar.gz
freebsd-ports-gnome-d3ce27f4ffe66205a3d683df7b1f998a1fb6c81d.tar.zst
freebsd-ports-gnome-d3ce27f4ffe66205a3d683df7b1f998a1fb6c81d.zip
- Distinguish clang from Microsoft cl.exe [1]
- Treat g++*, c++* and clang* the same. - Remove ?= assignments because this isn't a master port. - Remove libtool dependency. - Remove pkgconfig dependency. The port only installs a .pc file. - Disable use of MMX for now. It cannot be used in i386 packages and on amd64 the compiler already uses SSE. - Support staging. - Support WITH_DEBUG. PR: ports/173741 [1] Submitted by: Jeremy Huddleston Sequoia <jeremyhu@freedesktop.org> [1]
-rw-r--r--multimedia/dirac/Makefile15
-rw-r--r--multimedia/dirac/files/patch-configure55
2 files changed, 64 insertions, 6 deletions
diff --git a/multimedia/dirac/Makefile b/multimedia/dirac/Makefile
index d259de782cd8..2e7003e39409 100644
--- a/multimedia/dirac/Makefile
+++ b/multimedia/dirac/Makefile
@@ -3,21 +3,24 @@
PORTNAME= dirac
PORTVERSION= 1.0.2
-PORTREVISION?= 0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-codec/Dirac-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
-COMMENT?= Open source video codec from the BBC
+COMMENT= Open source video codec from the BBC
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-USES= gmake pathfix pkgconfig
+USES= gmake pathfix
USE_LDCONFIG= yes
-CONFIGURE_ENV?= HAVE_LATEX=${FALSE} HAVE_DVIPDFM=${FALSE} \
+CONFIGURE_ARGS= --disable-mmx
+CONFIGURE_ENV= HAVE_LATEX=${FALSE} HAVE_DVIPDFM=${FALSE} \
HAVE_DOXYGEN=${FALSE} HAVE_DOT=${FALSE}
CPPFLAGS+= -I${LOCALBASE}/include
-NO_STAGE= yes
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
.include <bsd.port.mk>
diff --git a/multimedia/dirac/files/patch-configure b/multimedia/dirac/files/patch-configure
new file mode 100644
index 000000000000..e45a7bb82dc8
--- /dev/null
+++ b/multimedia/dirac/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig 2009-02-11 02:43:40.000000000 +0100
++++ configure 2013-10-18 16:28:11.000000000 +0200
+@@ -15904,6 +15904,7 @@
+
+
+ case "$CXX" in
++ clang*) ;;
+ cl*|CL*)
+ CXXFLAGS="-nologo -W1 -EHsc -DWIN32"
+ if test x"$enable_shared" = "xyes"; then
+@@ -19744,7 +19745,7 @@
+
+ OPT_CFLAGS=""
+ case "$CXX" in
+- g++*)
++ nomatch)
+ TRY_CFLAGS="$OPT_CFLAGS -g"
+ { $as_echo "$as_me:$LINENO: checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags" >&5
+ $as_echo_n "checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags... " >&6; }
+@@ -20147,7 +20148,7 @@
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
+ case "$CXX" in
+- g++*)
++ g++*|c++*|clang*)
+ CXXFLAGS=`echo $CXXFLAGS | sed 's/-O[0-9]*//g'`
+ OPT_CFLAGS=""
+ TRY_CFLAGS="-O0"
+@@ -20237,7 +20238,7 @@
+ $as_echo "no" >&6; }
+ OPT_CFLAGS=""
+ case "$CXX" in
+- g++*|icc)
++ nomatch)
+ TRY_CFLAGS="-O3"
+ { $as_echo "$as_me:$LINENO: checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags" >&5
+ $as_echo_n "checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags... " >&6; }
+@@ -20416,7 +20417,7 @@
+
+ #Try more optimising flags if supported
+ case "$CXX" in
+- g++*)
++ nomatch)
+ TRY_CFLAGS="$OPT_CFLAGS -fexpensive-optimizations"
+ { $as_echo "$as_me:$LINENO: checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags" >&5
+ $as_echo_n "checking if $CXX supports $TRY_CFLAGS $CXXFLAGS flags... " >&6; }
+@@ -20941,7 +20942,7 @@
+
+ if test x"${enable_mmx}" = x"yes" ; then
+ case "$CXX" in
+- g++*)
++ g++*|c++*|clang*)
+ ac_ext=cpp
+ ac_cpp='$CXXCPP $CPPFLAGS'
+ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'