aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-01-21 04:12:52 +0800
committersobomax <sobomax@FreeBSD.org>2003-01-21 04:12:52 +0800
commitd452c539eff1be9d05f6de14ac2c53b611947312 (patch)
tree83e34c45ead5e0f95a6af4153be4974372ff8e64
parent768b7c470acc47bcf21db7ebd06eca0fad90e472 (diff)
downloadfreebsd-ports-gnome-d452c539eff1be9d05f6de14ac2c53b611947312.tar.gz
freebsd-ports-gnome-d452c539eff1be9d05f6de14ac2c53b611947312.tar.zst
freebsd-ports-gnome-d452c539eff1be9d05f6de14ac2c53b611947312.zip
Update 0.3.2 and provide support for SIP-specific attributes, which is
necessary for SER port to be added later on. Sponsored by: Porta Software Ltd.
-rw-r--r--net/radiusclient/Makefile4
-rw-r--r--net/radiusclient/distinfo2
-rw-r--r--net/radiusclient/files/patch-include::radiusclient.h46
3 files changed, 49 insertions, 3 deletions
diff --git a/net/radiusclient/Makefile b/net/radiusclient/Makefile
index f15536b80773..b41228134594 100644
--- a/net/radiusclient/Makefile
+++ b/net/radiusclient/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= radiusclient
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.2
CATEGORIES= net
-MASTER_SITES= ftp://ftp.hamburg.cityline.net/pub/radiusclient/ \
+MASTER_SITES= ftp://ftp.cityline.net/pub/radiusclient/ \
ftp://ftp.ecrc.net/pub/netsw/Network/IP/Management/RADIUS/
MAINTAINER= maurice@serc.rmit.edu.au
diff --git a/net/radiusclient/distinfo b/net/radiusclient/distinfo
index 50ff738d7681..6cf0313a5697 100644
--- a/net/radiusclient/distinfo
+++ b/net/radiusclient/distinfo
@@ -1 +1 @@
-MD5 (radiusclient-0.3.1.tar.gz) = 383814675a97a26717db19f72d5dafb7
+MD5 (radiusclient-0.3.2.tar.gz) = dd6a85f2f6fcb944cbf1dddd05ab132f
diff --git a/net/radiusclient/files/patch-include::radiusclient.h b/net/radiusclient/files/patch-include::radiusclient.h
new file mode 100644
index 000000000000..4fe770209770
--- /dev/null
+++ b/net/radiusclient/files/patch-include::radiusclient.h
@@ -0,0 +1,46 @@
+
+$FreeBSD$
+
+--- include/radiusclient.h.orig Thu Jan 7 01:53:04 1999
++++ include/radiusclient.h Wed Jan 8 16:12:50 2003
+@@ -169,6 +169,40 @@
+ #define PW_ACCT_MULTI_SESSION_ID 50 /* string */
+ #define PW_ACCT_LINK_COUNT 51 /* integer */
+
++/* Experimental SIP-specific attributes */
++
++#define PW_SIP_METHOD 101 /* integer */
++#define PW_SIP_RESPONSE_CODE 102 /* integer */
++#define PW_SIP_CSEQ 103 /* string */
++#define PW_SIP_TO_TAG 104 /* string */
++#define PW_SIP_FROM_TAG 105 /* string */
++#define PW_SIP_BRANCH_ID 106 /* string */
++#define PW_SIP_TRANSLATED_REQUEST_URI 107 /* string */
++#define PW_SIP_SOURCE_IP_ADDRESS 108 /* ipaddr */
++#define PW_SIP_SOURCE_PORT 109 /* integer */
++#define PW_SIP_USER_ID 110 /* string */
++#define PW_SIP_USER_REALM 111 /* string */
++#define PW_SIP_USER_NONCE 112 /* string */
++#define PW_SIP_USER_METHOD 113 /* string */
++#define PW_SIP_USER_DIGEST_URI 114 /* string */
++#define PW_SIP_USER_NONCE_COUNT 115 /* string */
++#define PW_SIP_USER_QOP 116 /* string */
++#define PW_SIP_USER_OPAQUE 117 /* string */
++#define PW_SIP_USER_RESPONSE 118 /* string */
++
++#define PW_DIGEST_RESPONSE 206 /* string */
++#define PW_DIGEST_ATTRIBUTES 207 /* string */
++#define PW_DIGEST_REALM 1063 /* string */
++#define PW_DIGEST_NONCE 1064 /* string */
++#define PW_DIGEST_METHOD 1065 /* string */
++#define PW_DIGEST_URI 1066 /* string */
++#define PW_DIGEST_QOP 1067 /* string */
++#define PW_DIGEST_ALGORITHM 1068 /* string */
++#define PW_DIGEST_BODY_DIGEST 1069 /* string */
++#define PW_DIGEST_CNONCE 1070 /* string */
++#define PW_DIGEST_NONCE_COUNT 1071 /* string */
++#define PW_DIGEST_USER_NAME 1072 /* string */
++
+ /* Merit Experimental Extensions */
+
+ #define PW_USER_ID 222 /* string */