aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-28 01:21:38 +0800
committermarcus <marcus@FreeBSD.org>2003-07-28 01:21:38 +0800
commitd5e79e7dc41ea5604e97b6a89f16b2f385df9c07 (patch)
treefa5d9eda881279e75432fb0976158df33c237c05
parentc4d59248189fa93c84495c62f1c9ff21bf22e01c (diff)
downloadfreebsd-ports-gnome-d5e79e7dc41ea5604e97b6a89f16b2f385df9c07.tar.gz
freebsd-ports-gnome-d5e79e7dc41ea5604e97b6a89f16b2f385df9c07.tar.zst
freebsd-ports-gnome-d5e79e7dc41ea5604e97b6a89f16b2f385df9c07.zip
Do not patch the asm blocks on 5.x since GCC 3.x can take full
advantage of MMX and SSE registers. Submitted by: Alexander Nedotsukov <bland@mail.ru>
-rw-r--r--graphics/gimp-app-devel/Makefile7
-rw-r--r--graphics/gimp-app-devel/files/asm_old_gcc.patch (renamed from graphics/gimp-app-devel/files/patch-asm_old_gcc)0
-rw-r--r--graphics/gimp-app/Makefile7
-rw-r--r--graphics/gimp-app/files/asm_old_gcc.patch (renamed from graphics/gimp-app/files/patch-asm_old_gcc)0
-rw-r--r--graphics/gimp-devel/Makefile7
-rw-r--r--graphics/gimp-devel/files/asm_old_gcc.patch (renamed from graphics/gimp-devel/files/patch-asm_old_gcc)0
-rw-r--r--graphics/gimp/Makefile7
-rw-r--r--graphics/gimp/files/asm_old_gcc.patch (renamed from graphics/gimp/files/patch-asm_old_gcc)0
-rw-r--r--graphics/gimpshop/Makefile7
-rw-r--r--graphics/gimpshop/files/asm_old_gcc.patch (renamed from graphics/gimpshop/files/patch-asm_old_gcc)0
10 files changed, 30 insertions, 5 deletions
diff --git a/graphics/gimp-app-devel/Makefile b/graphics/gimp-app-devel/Makefile
index 236ddf658910..f3aa4d190aa7 100644
--- a/graphics/gimp-app-devel/Makefile
+++ b/graphics/gimp-app-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -68,6 +69,10 @@ LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/asm_old_gcc.patch
+.endif
+
.if exists(${X11BASE}/libdata/pkgconfig/libgtkhtml-2.0.pc)
WITH_HTML_HELP_BROWSER= yes
.endif
@@ -80,7 +85,7 @@ PKGNAMESUFFIX= -gnome
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
-PLIST_SUB+= HELPBROWSER:=""
+PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
.endif
diff --git a/graphics/gimp-app-devel/files/patch-asm_old_gcc b/graphics/gimp-app-devel/files/asm_old_gcc.patch
index 56515dc5f61f..56515dc5f61f 100644
--- a/graphics/gimp-app-devel/files/patch-asm_old_gcc
+++ b/graphics/gimp-app-devel/files/asm_old_gcc.patch
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 236ddf658910..f3aa4d190aa7 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -68,6 +69,10 @@ LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/asm_old_gcc.patch
+.endif
+
.if exists(${X11BASE}/libdata/pkgconfig/libgtkhtml-2.0.pc)
WITH_HTML_HELP_BROWSER= yes
.endif
@@ -80,7 +85,7 @@ PKGNAMESUFFIX= -gnome
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
-PLIST_SUB+= HELPBROWSER:=""
+PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
.endif
diff --git a/graphics/gimp-app/files/patch-asm_old_gcc b/graphics/gimp-app/files/asm_old_gcc.patch
index 56515dc5f61f..56515dc5f61f 100644
--- a/graphics/gimp-app/files/patch-asm_old_gcc
+++ b/graphics/gimp-app/files/asm_old_gcc.patch
diff --git a/graphics/gimp-devel/Makefile b/graphics/gimp-devel/Makefile
index 236ddf658910..f3aa4d190aa7 100644
--- a/graphics/gimp-devel/Makefile
+++ b/graphics/gimp-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -68,6 +69,10 @@ LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/asm_old_gcc.patch
+.endif
+
.if exists(${X11BASE}/libdata/pkgconfig/libgtkhtml-2.0.pc)
WITH_HTML_HELP_BROWSER= yes
.endif
@@ -80,7 +85,7 @@ PKGNAMESUFFIX= -gnome
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
-PLIST_SUB+= HELPBROWSER:=""
+PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
.endif
diff --git a/graphics/gimp-devel/files/patch-asm_old_gcc b/graphics/gimp-devel/files/asm_old_gcc.patch
index 56515dc5f61f..56515dc5f61f 100644
--- a/graphics/gimp-devel/files/patch-asm_old_gcc
+++ b/graphics/gimp-devel/files/asm_old_gcc.patch
diff --git a/graphics/gimp/Makefile b/graphics/gimp/Makefile
index 236ddf658910..f3aa4d190aa7 100644
--- a/graphics/gimp/Makefile
+++ b/graphics/gimp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -68,6 +69,10 @@ LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/asm_old_gcc.patch
+.endif
+
.if exists(${X11BASE}/libdata/pkgconfig/libgtkhtml-2.0.pc)
WITH_HTML_HELP_BROWSER= yes
.endif
@@ -80,7 +85,7 @@ PKGNAMESUFFIX= -gnome
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
-PLIST_SUB+= HELPBROWSER:=""
+PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
.endif
diff --git a/graphics/gimp/files/patch-asm_old_gcc b/graphics/gimp/files/asm_old_gcc.patch
index 56515dc5f61f..56515dc5f61f 100644
--- a/graphics/gimp/files/patch-asm_old_gcc
+++ b/graphics/gimp/files/asm_old_gcc.patch
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index 236ddf658910..f3aa4d190aa7 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gimp
PORTVERSION= 1.3.17
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
@@ -68,6 +69,10 @@ LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/asm_old_gcc.patch
+.endif
+
.if exists(${X11BASE}/libdata/pkgconfig/libgtkhtml-2.0.pc)
WITH_HTML_HELP_BROWSER= yes
.endif
@@ -80,7 +85,7 @@ PKGNAMESUFFIX= -gnome
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
-PLIST_SUB+= HELPBROWSER:=""
+PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
.endif
diff --git a/graphics/gimpshop/files/patch-asm_old_gcc b/graphics/gimpshop/files/asm_old_gcc.patch
index 56515dc5f61f..56515dc5f61f 100644
--- a/graphics/gimpshop/files/patch-asm_old_gcc
+++ b/graphics/gimpshop/files/asm_old_gcc.patch