aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-11-28 03:21:00 +0800
committerwg <wg@FreeBSD.org>2013-11-28 03:21:00 +0800
commitd8f6eda33aa2e443badba0801688599aa84ed65e (patch)
tree5fa70d17b8203ab72973f7fbe6b2fd9379338ca7
parentfa09d7c9d539139fcb98f54affd40bad5aff216d (diff)
downloadfreebsd-ports-gnome-d8f6eda33aa2e443badba0801688599aa84ed65e.tar.gz
freebsd-ports-gnome-d8f6eda33aa2e443badba0801688599aa84ed65e.tar.zst
freebsd-ports-gnome-d8f6eda33aa2e443badba0801688599aa84ed65e.zip
- Fix build with distribute -> setuptools change
Approved by: portmgr (bapt, implicit)
-rw-r--r--science/py-obspy/files/patch-setup.py31
-rw-r--r--sysutils/py-filelike/files/patch-setup.py10
-rw-r--r--www/py-amf/files/patch-setup.py14
-rw-r--r--www/py-cssmin/files/patch-setup.py10
4 files changed, 58 insertions, 7 deletions
diff --git a/science/py-obspy/files/patch-setup.py b/science/py-obspy/files/patch-setup.py
index 62202600ddb5..d37903bca129 100644
--- a/science/py-obspy/files/patch-setup.py
+++ b/science/py-obspy/files/patch-setup.py
@@ -1,13 +1,30 @@
---- setup.py.orig 2012-12-17 14:04:38.000000000 +0000
-+++ setup.py 2013-05-16 15:35:53.000000000 +0000
-@@ -362,8 +362,8 @@
+--- ./setup.py.orig 2013-06-28 18:07:26.000000000 -0300
++++ ./setup.py 2013-11-27 17:04:07.589319517 -0200
+@@ -27,7 +27,6 @@
+ from distutils.unixccompiler import UnixCCompiler
+ from setuptools import find_packages, setup
+ from setuptools.extension import Extension
+-import distribute_setup
+ import glob
+ import os
+ import platform
+@@ -370,8 +369,8 @@
# otherwise we just use the original compile method
UnixCCompiler.linker_so = None
return self._original_compile(obj, src, *args, **kwargs)
- UnixCCompiler.linker_so = ["gfortran"]
- self.compiler_so = ["gfortran"]
-+ UnixCCompiler.linker_so = ["FC"]
-+ self.compiler_so = ["FC"]
++ UnixCCompiler.linker_so = ["gfortran46"]
++ self.compiler_so = ["gfortran46"]
cc_args = ['-c', '-fno-underscoring']
- if sys.platform == 'darwin':
- self.compiler_so = _darwin_compiler_fixup(self.compiler_so,
+ cc_args.append('-fPIC')
+ try:
+@@ -629,8 +628,6 @@
+
+
+ def setupPackage(gfortran=True, ccompiler=True):
+- # automatically install distribute if the user does not have it installed
+- distribute_setup.use_setuptools()
+ # use lib2to3 for Python 3.x
+ if sys.version_info[0] == 3:
+ convert2to3()
diff --git a/sysutils/py-filelike/files/patch-setup.py b/sysutils/py-filelike/files/patch-setup.py
new file mode 100644
index 000000000000..b7e6016b3524
--- /dev/null
+++ b/sysutils/py-filelike/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- ./setup.py.orig 2013-11-27 16:56:21.489321513 -0200
++++ ./setup.py 2013-11-27 16:57:06.823319522 -0200
+@@ -1,7 +1,5 @@
+
+ import sys
+-import distribute_setup
+-distribute_setup.use_setuptools()
+ from setuptools import setup, find_packages
+
+
diff --git a/www/py-amf/files/patch-setup.py b/www/py-amf/files/patch-setup.py
new file mode 100644
index 000000000000..b9dbf2e08d90
--- /dev/null
+++ b/www/py-amf/files/patch-setup.py
@@ -0,0 +1,14 @@
+--- ./setup.py.orig 2013-11-27 16:59:40.606322333 -0200
++++ ./setup.py 2013-11-27 17:00:06.922319988 -0200
+@@ -3,11 +3,6 @@
+ # Copyright (c) The PyAMF Project.
+ # See LICENSE.txt for details.
+
+-from distribute_setup import use_setuptools
+-
+-# 15 seconds is far too long ....
+-use_setuptools(download_delay=3)
+-
+ # import ordering is important
+ import setupinfo
+ from setuptools import setup, find_packages
diff --git a/www/py-cssmin/files/patch-setup.py b/www/py-cssmin/files/patch-setup.py
new file mode 100644
index 000000000000..3c761773f42f
--- /dev/null
+++ b/www/py-cssmin/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- ./setup.py.orig 2013-11-27 16:51:22.144320041 -0200
++++ ./setup.py 2013-11-27 16:51:29.013319136 -0200
+@@ -4,7 +4,6 @@
+ import os
+ import re
+
+-from distribute_setup import use_setuptools; use_setuptools()
+ from setuptools import setup, find_packages
+
+