aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-12-28 04:55:08 +0800
committerpav <pav@FreeBSD.org>2010-12-28 04:55:08 +0800
commitd941294017a2cc0b2943cb0a510cc653307a7d41 (patch)
treebee7141075a9d73b62206c5cad9471cfcba05d24
parent40a3c51c71db6265168d356264feb5f1b8f6c4eb (diff)
downloadfreebsd-ports-gnome-d941294017a2cc0b2943cb0a510cc653307a7d41.tar.gz
freebsd-ports-gnome-d941294017a2cc0b2943cb0a510cc653307a7d41.tar.zst
freebsd-ports-gnome-d941294017a2cc0b2943cb0a510cc653307a7d41.zip
- Fix build with new boost
Submitted by: Alexander Churanov <alexanderchuranov@gmail.com>
-rw-r--r--databases/hypertable/Makefile2
-rw-r--r--databases/hypertable/files/patch-src_cc_Hypertable_Lib_HqlInterpreter.cc29
-rw-r--r--games/alephone/files/patch-Source_Files_Network_Metaserver_network_metaserver.h10
-rw-r--r--games/spring/files/patch-rts-lib-lobby-Connection.h10
-rw-r--r--graphics/scantailor/files/patch-ProjectFilesDialog.cpp30
-rw-r--r--net-p2p/hrktorrent/files/patch-hrktorrent.h10
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_udp_socket.hpp10
-rw-r--r--net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_udp_socket.hpp10
-rw-r--r--net-p2p/qbittorrent-22/files/patch-src_main.cpp10
9 files changed, 119 insertions, 2 deletions
diff --git a/databases/hypertable/Makefile b/databases/hypertable/Makefile
index 28f57287549d..0e38ab002a1f 100644
--- a/databases/hypertable/Makefile
+++ b/databases/hypertable/Makefile
@@ -26,8 +26,6 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
BUILD_DEPENDS= ${RUN_DEPENDS} \
ant:${PORTSDIR}/devel/apache-ant
-BROKEN= does not build
-
OPTIONS= TCMALLOC "Use Tcmalloc" on \
HOARD "Use Hoard" off \
PYTHONLIBS "Add Python binding" off \
diff --git a/databases/hypertable/files/patch-src_cc_Hypertable_Lib_HqlInterpreter.cc b/databases/hypertable/files/patch-src_cc_Hypertable_Lib_HqlInterpreter.cc
new file mode 100644
index 000000000000..bfa5f41ffb09
--- /dev/null
+++ b/databases/hypertable/files/patch-src_cc_Hypertable_Lib_HqlInterpreter.cc
@@ -0,0 +1,29 @@
+--- src/cc/Hypertable/Lib/HqlInterpreter.cc.orig 2010-12-13 17:56:18.000000000 +0300
++++ src/cc/Hypertable/Lib/HqlInterpreter.cc 2010-12-13 17:55:27.000000000 +0300
+@@ -272,7 +272,7 @@
+ }
+ else {
+ out_fd = dup(fileno(outf));
+- fout.push(boost::iostreams::file_descriptor_sink(out_fd));
++ fout.push(boost::iostreams::file_descriptor_sink(out_fd, boost::iostreams::never_close_handle));
+ }
+
+ HT_ON_SCOPE_EXIT(&close_file, out_fd);
+@@ -397,7 +397,7 @@
+ }
+ else {
+ out_fd = dup(fileno(outf));
+- fout.push(boost::iostreams::file_descriptor_sink(out_fd));
++ fout.push(boost::iostreams::file_descriptor_sink(out_fd, boost::iostreams::never_close_handle));
+ }
+
+ HT_ON_SCOPE_EXIT(&close_file, out_fd);
+@@ -488,7 +488,7 @@
+ else {
+ if (outf) {
+ out_fd = dup(fileno(outf));
+- fout.push(boost::iostreams::file_descriptor_sink(out_fd));
++ fout.push(boost::iostreams::file_descriptor_sink(out_fd, boost::iostreams::never_close_handle));
+ }
+ else
+ fout.push(boost::iostreams::null_sink());
diff --git a/games/alephone/files/patch-Source_Files_Network_Metaserver_network_metaserver.h b/games/alephone/files/patch-Source_Files_Network_Metaserver_network_metaserver.h
new file mode 100644
index 000000000000..8d96ea3d3130
--- /dev/null
+++ b/games/alephone/files/patch-Source_Files_Network_Metaserver_network_metaserver.h
@@ -0,0 +1,10 @@
+--- Source_Files/Network/Metaserver/network_metaserver.h.orig 2010-12-10 15:54:11.000000000 +0300
++++ Source_Files/Network/Metaserver/network_metaserver.h 2010-12-10 15:54:23.000000000 +0300
+@@ -32,6 +32,7 @@
+ #include <map>
+ #include <memory> // auto_ptr
+ #include <set>
++#include <stdexcept>
+
+ #include "Logging.h"
+
diff --git a/games/spring/files/patch-rts-lib-lobby-Connection.h b/games/spring/files/patch-rts-lib-lobby-Connection.h
new file mode 100644
index 000000000000..25ede7f23a5a
--- /dev/null
+++ b/games/spring/files/patch-rts-lib-lobby-Connection.h
@@ -0,0 +1,10 @@
+--- rts/lib/lobby/Connection.h.orig 2010-12-10 17:17:43.000000000 +0300
++++ rts/lib/lobby/Connection.h 2010-12-10 17:19:28.000000000 +0300
+@@ -6,6 +6,7 @@
+ #include <boost/asio/streambuf.hpp>
+ #include <boost/asio/deadline_timer.hpp>
+ #include <boost/asio/ip/tcp.hpp>
++#include <list>
+ #include <string>
+
+ struct ClientStatus
diff --git a/graphics/scantailor/files/patch-ProjectFilesDialog.cpp b/graphics/scantailor/files/patch-ProjectFilesDialog.cpp
new file mode 100644
index 000000000000..d14e625aa5f8
--- /dev/null
+++ b/graphics/scantailor/files/patch-ProjectFilesDialog.cpp
@@ -0,0 +1,30 @@
+--- ProjectFilesDialog.cpp.orig 2010-04-03 23:47:33.000000000 +0400
++++ ProjectFilesDialog.cpp 2010-12-10 20:05:23.000000000 +0300
+@@ -677,6 +677,17 @@
+ endRemoveRows();
+ }
+
++namespace {
++ struct less_for_first_members_of_pairs
++ {
++ template <typename Pair>
++ bool operator()(Pair const& left, Pair const& right) const
++ {
++ return left.first < right.first;
++ }
++ };
++}
++
+ void
+ ProjectFilesDialog::FileList::remove(QItemSelection const& selection)
+ {
+@@ -699,7 +710,8 @@
+ );
+ std::sort(
+ sorted_ranges.begin(), sorted_ranges.end(),
+- bind(&Range::first, _1) < bind(&Range::first, _2)
++ // bind(&Range::first, _1) < bind(&Range::first, _2)
++ less_for_first_members_of_pairs()
+ );
+
+ QVectorIterator<Range> it(sorted_ranges);
diff --git a/net-p2p/hrktorrent/files/patch-hrktorrent.h b/net-p2p/hrktorrent/files/patch-hrktorrent.h
new file mode 100644
index 000000000000..0da691e1b860
--- /dev/null
+++ b/net-p2p/hrktorrent/files/patch-hrktorrent.h
@@ -0,0 +1,10 @@
+--- hrktorrent.h.orig 2010-12-14 18:09:28.000000000 +0300
++++ hrktorrent.h 2010-12-14 18:09:40.000000000 +0300
+@@ -6,6 +6,7 @@
+ #include <iterator>
+ #include <exception>
+
++#include <signal.h>
+ #include <sys/mman.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_udp_socket.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_udp_socket.hpp
new file mode 100644
index 000000000000..f0e6903a97da
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_udp_socket.hpp
@@ -0,0 +1,10 @@
+--- include/libtorrent/udp_socket.hpp.orig 2010-12-10 20:38:45.000000000 +0300
++++ include/libtorrent/udp_socket.hpp 2010-12-10 20:39:05.000000000 +0300
+@@ -37,6 +37,7 @@
+ #include "libtorrent/session_settings.hpp"
+ #include "libtorrent/buffer.hpp"
+
++#include <list>
+ #include <vector>
+ #include <boost/function.hpp>
+ #include <boost/thread/mutex.hpp>
diff --git a/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_udp_socket.hpp b/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_udp_socket.hpp
new file mode 100644
index 000000000000..f0e6903a97da
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_udp_socket.hpp
@@ -0,0 +1,10 @@
+--- include/libtorrent/udp_socket.hpp.orig 2010-12-10 20:38:45.000000000 +0300
++++ include/libtorrent/udp_socket.hpp 2010-12-10 20:39:05.000000000 +0300
+@@ -37,6 +37,7 @@
+ #include "libtorrent/session_settings.hpp"
+ #include "libtorrent/buffer.hpp"
+
++#include <list>
+ #include <vector>
+ #include <boost/function.hpp>
+ #include <boost/thread/mutex.hpp>
diff --git a/net-p2p/qbittorrent-22/files/patch-src_main.cpp b/net-p2p/qbittorrent-22/files/patch-src_main.cpp
new file mode 100644
index 000000000000..422451204ad5
--- /dev/null
+++ b/net-p2p/qbittorrent-22/files/patch-src_main.cpp
@@ -0,0 +1,10 @@
+--- src/main.cpp.orig 2010-12-26 16:04:06.000000000 +0300
++++ src/main.cpp 2010-12-26 16:05:49.000000000 +0300
+@@ -60,6 +60,7 @@
+ #include "stacktrace.h"
+ #endif
+
++#include <csignal>
+ #include <stdlib.h>
+ #include "misc.h"
+ #include "preferences.h"