aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-09-08 09:17:37 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-09-08 09:17:37 +0800
commitd95cb4732cc2e7f12ac59188dad09d797924faa1 (patch)
tree92fd647dd05bc9a6b342a7af2fe423330927540c
parent72caa64511ce47873454f895545757f36428c673 (diff)
downloadfreebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.tar.gz
freebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.tar.zst
freebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.zip
Test::Requires checks to see if the module can be loaded.
If this fails rather than failing tests this skips all tests. WWW: http://search.cpan.org/dist/Test-Requires/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Requires/Makefile21
-rw-r--r--devel/p5-Test-Requires/distinfo3
-rw-r--r--devel/p5-Test-Requires/pkg-descr5
-rw-r--r--devel/p5-Test-Requires/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f05a77ef974..0993e53e8c49 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1972,6 +1972,7 @@
SUBDIR += p5-Test-Portability-Files
SUBDIR += p5-Test-RandomResults
SUBDIR += p5-Test-Reporter
+ SUBDIR += p5-Test-Requires
SUBDIR += p5-Test-Script
SUBDIR += p5-Test-SharedFork
SUBDIR += p5-Test-Simple
diff --git a/devel/p5-Test-Requires/Makefile b/devel/p5-Test-Requires/Makefile
new file mode 100644
index 000000000000..5ea678582bb6
--- /dev/null
+++ b/devel/p5-Test-Requires/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Test::Requires
+# Date created: 08 Sep 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Requires
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for checking to see if the module can be loaded
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Requires.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Requires/distinfo b/devel/p5-Test-Requires/distinfo
new file mode 100644
index 000000000000..a5a8a4b428bf
--- /dev/null
+++ b/devel/p5-Test-Requires/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Requires-0.01.tar.gz) = 8a566fe04aaf9d153a09a35a89a378af
+SHA256 (Test-Requires-0.01.tar.gz) = b8f45193fd8f8c54c586a9cd55997456ffa5e97bf89d4e835abbb3ca42345d47
+SIZE (Test-Requires-0.01.tar.gz) = 40997
diff --git a/devel/p5-Test-Requires/pkg-descr b/devel/p5-Test-Requires/pkg-descr
new file mode 100644
index 000000000000..2bbdce33285c
--- /dev/null
+++ b/devel/p5-Test-Requires/pkg-descr
@@ -0,0 +1,5 @@
+Test::Requires checks to see if the module can be loaded.
+
+If this fails rather than failing tests this skips all tests.
+
+WWW: http://search.cpan.org/dist/Test-Requires/
diff --git a/devel/p5-Test-Requires/pkg-plist b/devel/p5-Test-Requires/pkg-plist
new file mode 100644
index 000000000000..05621859c5ac
--- /dev/null
+++ b/devel/p5-Test-Requires/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Requires/.packlist
+%%SITE_PERL%%/Test/Requires.pm
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Requires
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
devel?h=gstreamer0.10-removal&id=7ae8885335c3a5a4d06a6ed5f1520540797f7f2c'>o Remove USE_GCC dependency on 3.4lioux2005-05-143-9/+28 * Update to snapshot 20050513lioux2005-05-132-3/+3 * USE_GCC=3.4 is required; thus, mark BROKEN for OSVERSION <= 500000lioux2005-05-131-0/+5 * 20050512lioux2005-05-122-3/+3 * o Commit updates after repo copy from multimedia/ffmpeglioux2005-05-1214-372/+475 * Bump PORTREVISION on all ports that received the imlib2 shlib chase.adamw2005-03-081-1/+1 * 1: Upgrade imlib2 to 1.2.0vanilla2005-03-071-1/+1 * Does not compile on alphakris2005-01-021-0/+4 * o Pet devel/portlint(1)lioux2004-12-251-2/+2 * o Fix PLIST: ffplay is only built WITH_SDLlioux2004-12-131-1/+4 * Fix build without NOPORTDOCS: force detection of port textproc/texi2htmllioux2004-12-081-0/+6 * o Update to 0.4.9.p1lioux2004-12-069-122/+156 * Fix build on gcc 3.4lofi2004-09-041-2/+14 * Fix build on -CURRENT i386 ARCH, OSVERSION >= 502000lioux2004-04-151-4/+3 * Fix typo: WITHOUT_A52 -> WITHOUT_LIBA52lioux2004-04-141-1/+1 * 1) Enable shared postprocess per defaultlioux2004-03-213-19/+19 * BROKEN on i386 5.x: Does not compilekris2004-03-191-0/+4 * o Fix "make deinstall reinstall": "unfix" some header files insidelioux2004-03-141-0/+4 * Support moved header files in FreeBSD 5.x branch: the header fileslioux2004-03-141-0/+5 * Properly use SDL everywhere:edwin2004-03-081-2/+3 * Remove a quotation mark that snuck in when I wasn't paying attention.adamw2004-03-011-1/+1 * Add a missing \.adamw2004-02-291-1/+1 * Add faad support, unbreak imlib2 support, and fix the pkg-plist. All toppedadamw2004-02-292-3/+20 * Unbreak on 5.x. Define PIC when compiling with -fpic, some codecskan2004-02-23