aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-04 15:32:39 +0800
committerkris <kris@FreeBSD.org>2003-06-04 15:32:39 +0800
commitdae8d9ed2b928a02a7a243ee17c88db354f854c4 (patch)
tree1df13bd1d3043de06860d3f35528fa29621110c4
parent9395b6f9764a647037ae1a4cce0e3401c1401f67 (diff)
downloadfreebsd-ports-gnome-dae8d9ed2b928a02a7a243ee17c88db354f854c4.tar.gz
freebsd-ports-gnome-dae8d9ed2b928a02a7a243ee17c88db354f854c4.tar.zst
freebsd-ports-gnome-dae8d9ed2b928a02a7a243ee17c88db354f854c4.zip
Fix endian detection on 64-bit machines and bump PORTREVISION. This was
(at least) causing red and blue colour channels to be transposed on sparc64.
-rw-r--r--graphics/Hermes/Makefile1
-rw-r--r--graphics/Hermes/files/patch-configure13
2 files changed, 12 insertions, 2 deletions
diff --git a/graphics/Hermes/Makefile b/graphics/Hermes/Makefile
index 451e46059629..90c3dacb4018 100644
--- a/graphics/Hermes/Makefile
+++ b/graphics/Hermes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Hermes
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.clanlib.org/download/files/
diff --git a/graphics/Hermes/files/patch-configure b/graphics/Hermes/files/patch-configure
index 9703106d38d9..41e1331cd7e9 100644
--- a/graphics/Hermes/files/patch-configure
+++ b/graphics/Hermes/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Mon Mar 17 03:36:28 2003
-+++ configure Mon May 12 16:27:09 2003
+--- configure.orig Wed Jun 4 00:25:16 2003
++++ configure Wed Jun 4 00:25:11 2003
@@ -7766,6 +7766,7 @@
# This can be used to rebuild libtool when needed
@@ -8,3 +8,12 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -10311,7 +10312,7 @@
+ *(c+0)=1; *(c+1)=2;
+ *(c+2)=3; *(c+3)=4;
+
+- if(tst==0x01020304) return 0;
++ if(tst==0x01020304 || tst==0x0102030400000000) return 0;
+ else
+ return 1;
+ }