aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-05 02:38:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-05 02:38:29 +0800
commitdafb61677639830828da3b3ededd962dddf614cf (patch)
tree1f1269452d214669dbd993a4b6c76ca05125a7e1
parentd5eb431aac2ac132a10bab4b12008757806e1d73 (diff)
downloadfreebsd-ports-gnome-dafb61677639830828da3b3ededd962dddf614cf.tar.gz
freebsd-ports-gnome-dafb61677639830828da3b3ededd962dddf614cf.tar.zst
freebsd-ports-gnome-dafb61677639830828da3b3ededd962dddf614cf.zip
- Switch to options helpers
- Always set config dir to %%ETCDIR%% to avoid stage-qa warnings when building as non-root - Add NO_ARCH Approved by: portmgr blanket
-rw-r--r--devel/phpsh/Makefile8
-rw-r--r--devel/phpsh/files/patch-setup.py16
2 files changed, 11 insertions, 13 deletions
diff --git a/devel/phpsh/Makefile b/devel/phpsh/Makefile
index 717ed960b55f..13232c760cfe 100644
--- a/devel/phpsh/Makefile
+++ b/devel/phpsh/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python tar:bzip2
USE_PYTHON= distutils autoplist
USE_PHP= pcre posix tokenizer
+NO_ARCH= yes
WANT_PHP_CLI= yes
@@ -26,12 +27,7 @@ PYDISTUTILS_PKGVERSION= 1.3
OPTIONS_DEFINE= PCNTL
PCNTL_DESC= Fork on every command (pcntl PHP extension)
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPCNTL}
-USE_PHP+= pcntl
-.endif
+PCNTL_USE= PHP=pcntl
post-patch:
@${GREP} -Rl '%%ETCDIR%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
diff --git a/devel/phpsh/files/patch-setup.py b/devel/phpsh/files/patch-setup.py
index 5e280565f49f..29ddf666737c 100644
--- a/devel/phpsh/files/patch-setup.py
+++ b/devel/phpsh/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig
+--- setup.py.orig 2011-05-13 22:16:32 UTC
+++ setup.py
-@@ -7,15 +7,15 @@
+@@ -7,17 +7,14 @@ import os
sys.path.insert(0, 'src')
from phpsh import __version__
@@ -16,13 +16,15 @@
+### EMACS: os.waitpid(p.pid, 0)
# something better than this?
- if os.getenv("USER") == "root":
+-if os.getenv("USER") == "root":
- config_dir = "/etc/phpsh"
-+ config_dir = "%%ETCDIR%%"
- else:
- config_dir = os.getenv("HOME") + "/.phpsh"
+-else:
+- config_dir = os.getenv("HOME") + "/.phpsh"
++config_dir = "%%ETCDIR%%"
-@@ -33,7 +33,7 @@
+ setup(
+ name="phpsh",
+@@ -33,7 +30,7 @@ setup(
"xdebug-clients/geben/LICENSE",
"xdebug-clients/geben/Makefile",
"xdebug-clients/geben/geben.el",