aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-10 13:48:19 +0800
committeraz <az@FreeBSD.org>2013-09-10 13:48:19 +0800
commitdc833d264f50c7dade6af9d8ebeafcc83ea0623c (patch)
tree405d2711d654b223432e84cde15af1735848aad2
parent6e56589e4f7277226001a3471f822c243bc3826d (diff)
downloadfreebsd-ports-gnome-dc833d264f50c7dade6af9d8ebeafcc83ea0623c.tar.gz
freebsd-ports-gnome-dc833d264f50c7dade6af9d8ebeafcc83ea0623c.tar.zst
freebsd-ports-gnome-dc833d264f50c7dade6af9d8ebeafcc83ea0623c.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--devel/cvschangelogbuilder/Makefile8
-rw-r--r--devel/p5-Class-Accessor-Children/Makefile9
-rw-r--r--devel/p5-Class-OOorNO/Makefile9
-rw-r--r--devel/p5-Config-Perl-V/Makefile9
-rw-r--r--devel/p5-Data-HashArray/Makefile9
-rw-r--r--devel/p5-Date-Calc-XS/Makefile9
-rw-r--r--devel/p5-Devel-GlobalDestruction-XS/Makefile3
-rw-r--r--devel/p5-File-Dir-Dumper/Makefile9
-rw-r--r--devel/p5-Gearman-Server/Makefile3
-rw-r--r--devel/p5-Mac-PropertyList/Makefile9
-rw-r--r--devel/p5-Metabase-Client-Simple/Makefile9
-rw-r--r--devel/p5-Module-Reload-Sel/Makefile9
-rw-r--r--devel/p5-POE-Loop-Glib/Makefile9
-rw-r--r--devel/p5-Perl6-Export/Makefile9
-rw-r--r--devel/p5-Proc-SafeExec/Makefile3
-rw-r--r--devel/p5-ReadLine-TTYtter/Makefile3
-rw-r--r--devel/p5-Term-Animation/Makefile9
-rw-r--r--devel/p5-Tie-RegexpHash/Makefile9
-rw-r--r--devel/p5-cpan-listchanges/Makefile3
19 files changed, 51 insertions, 89 deletions
diff --git a/devel/cvschangelogbuilder/Makefile b/devel/cvschangelogbuilder/Makefile
index 3c7cdaba661d..b5d2ba405f48 100644
--- a/devel/cvschangelogbuilder/Makefile
+++ b/devel/cvschangelogbuilder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvschangelogbuilder
-# Date created: Sun Mar 5 16:43:25 EST 2006
-# Whom: Matthew Will <mwill@spingen.com>
-#
+# Created by: Matthew Will <mwill@spingen.com>
# $FreeBSD$
-#
PORTNAME= cvschangelogbuilder
PORTVERSION= 2.5
@@ -18,7 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/cvschangelogbuilder
PORTDOCS= *
diff --git a/devel/p5-Class-Accessor-Children/Makefile b/devel/p5-Class-Accessor-Children/Makefile
index 139b8434508b..e9534dbfc376 100644
--- a/devel/p5-Class-Accessor-Children/Makefile
+++ b/devel/p5-Class-Accessor-Children/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-Accessor-Children
-# Date created: 2010-01-03
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Class-Accessor-Children
PORTVERSION= 0.02
@@ -16,7 +12,8 @@ COMMENT= Automated child-class/accessor generation
RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Accessor::Children.3 \
Class::Accessor::Children::Fast.3
diff --git a/devel/p5-Class-OOorNO/Makefile b/devel/p5-Class-OOorNO/Makefile
index c6f42e5c7b2d..1d30ce2cded9 100644
--- a/devel/p5-Class-OOorNO/Makefile
+++ b/devel/p5-Class-OOorNO/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: p5-Class-OOorNO
-# Date created: 25th April 2007
-# Whom: jeffhung
-#
+# Created by: jeffhung
# $FreeBSD$
-#
PORTNAME= Class-OOorNO
PORTVERSION= 0.011
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jeffhung@mail2000.com.tw
COMMENT= Perl module that give your module classic AND OO interfaces
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Class::OOorNO.3
diff --git a/devel/p5-Config-Perl-V/Makefile b/devel/p5-Config-Perl-V/Makefile
index 116921edc5a8..15decc31d672 100644
--- a/devel/p5-Config-Perl-V/Makefile
+++ b/devel/p5-Config-Perl-V/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Config-Perl-V
-# Date created: 2011-02-05
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Config-Perl-V
PORTVERSION= 0.15
CATEGORIES= devel perl5
@@ -18,7 +14,8 @@ COMMENT= Structured data retrieval of perl -V output
BUILD_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::Perl::V.3
diff --git a/devel/p5-Data-HashArray/Makefile b/devel/p5-Data-HashArray/Makefile
index 1a96eaca916b..0d9dbd940a6b 100644
--- a/devel/p5-Data-HashArray/Makefile
+++ b/devel/p5-Data-HashArray/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Data::HashArray
-# Date created: 2009-08-27
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Data-HashArray
PORTVERSION= 1.0
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Array class of hashes with properties via overloading and AUTOLOAD
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::HashArray.3
diff --git a/devel/p5-Date-Calc-XS/Makefile b/devel/p5-Date-Calc-XS/Makefile
index 1557741b8e6d..b01c35dd15e6 100644
--- a/devel/p5-Date-Calc-XS/Makefile
+++ b/devel/p5-Date-Calc-XS/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Date-Calc-XS
-# Date Created: 11 Dec 2009
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= Date-Calc-XS
PORTVERSION= 6.3
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Date-Calc>=6.2:${PORTSDIR}/devel/p5-Date-Calc \
p5-Carp-Clan>=5.3:${PORTSDIR}/devel/p5-Carp-Clan
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Date::Calc::XS.3
diff --git a/devel/p5-Devel-GlobalDestruction-XS/Makefile b/devel/p5-Devel-GlobalDestruction-XS/Makefile
index 9fe617ce9b03..911b1b3a9983 100644
--- a/devel/p5-Devel-GlobalDestruction-XS/Makefile
+++ b/devel/p5-Devel-GlobalDestruction-XS/Makefile
@@ -13,7 +13,8 @@ COMMENT= Faster implementation of the Devel::GlobalDestruction API
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::GlobalDestruction::XS.3
diff --git a/devel/p5-File-Dir-Dumper/Makefile b/devel/p5-File-Dir-Dumper/Makefile
index 43cc3d60073e..2c8bc1e798c4 100644
--- a/devel/p5-File-Dir-Dumper/Makefile
+++ b/devel/p5-File-Dir-Dumper/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-File-Dir-Dumper
-# Date created: November 18th 2008
-# Whom: Anatoliy Dmytriyev <tolid@tolid.eu.org>
-#
+# Created by: Anatoliy Dmytriyev <tolid@tolid.eu.org>
# $FreeBSD$
-#
PORTNAME= File-Dir-Dumper
PORTVERSION= 0.0.8
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-File-Find-Object>0:${PORTSDIR}/devel/p5-File-Find-Object \
p5-Devel-CheckOS>0:${PORTSDIR}/devel/p5-Devel-CheckOS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= dir-dump.1
MAN3= File::Dir::Dumper.3 File::Dir::Dumper::App.3 File::Dir::Dumper::Base.3 File::Dir::Dumper::Scanner.3 \
diff --git a/devel/p5-Gearman-Server/Makefile b/devel/p5-Gearman-Server/Makefile
index dee88c98036a..1fba4d1277f2 100644
--- a/devel/p5-Gearman-Server/Makefile
+++ b/devel/p5-Gearman-Server/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-Gearman>=1.10:${PORTSDIR}/devel/p5-Gearman \
CONFLICTS= gearmand-0.* gearmand-1.0.* gearmand-1.1.*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= gearmand.1
MAN3= Gearman::Server.3 Gearman::Server::Client.3
diff --git a/devel/p5-Mac-PropertyList/Makefile b/devel/p5-Mac-PropertyList/Makefile
index f77a378f6af4..3d7b00e94872 100644
--- a/devel/p5-Mac-PropertyList/Makefile
+++ b/devel/p5-Mac-PropertyList/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Mac-PropertyList
-# Date created: 24 December 2010
-# Whom: Nobutaka Mantani <nobutaka@FreeBSD.org>
-#
+# Created by: Nobutaka Mantani <nobutaka@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Mac-PropertyList
PORTVERSION= 1.38
@@ -20,7 +16,8 @@ LICENSE= ART10 GPLv1
BUILD_DEPENDS= p5-XML-Entities>=0:${PORTSDIR}/textproc/p5-XML-Entities
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mac::PropertyList.3 \
Mac::PropertyList::ReadBinary.3 \
diff --git a/devel/p5-Metabase-Client-Simple/Makefile b/devel/p5-Metabase-Client-Simple/Makefile
index 3af6af3b083d..35e2bf534cf1 100644
--- a/devel/p5-Metabase-Client-Simple/Makefile
+++ b/devel/p5-Metabase-Client-Simple/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Metabase-Client-Simple
-# Date created: 2011-02-05
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Metabase-Client-Simple
PORTVERSION= 0.009
@@ -23,7 +19,8 @@ RUN_DEPENDS= p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
p5-Metabase-Fact>0:${PORTSDIR}/devel/p5-Metabase-Fact \
p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Metabase::Client::Simple.3
diff --git a/devel/p5-Module-Reload-Sel/Makefile b/devel/p5-Module-Reload-Sel/Makefile
index d98c2efdbf59..8365d1c80f89 100644
--- a/devel/p5-Module-Reload-Sel/Makefile
+++ b/devel/p5-Module-Reload-Sel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Module-Reload-Selective
-# Date created: 25 April 2005
-# Whom: simond@irrelevant.org
-#
+# Created by: simond@irrelevant.org
# $FreeBSD$
-#
PORTNAME= Module-Reload-Sel
PORTVERSION= 1.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= simond@irrelevant.org
COMMENT= Reload perl library files when updated on disk
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Module::Reload::Selective.3
diff --git a/devel/p5-POE-Loop-Glib/Makefile b/devel/p5-POE-Loop-Glib/Makefile
index d7ceeb1c86a8..ebe89abe873f 100644
--- a/devel/p5-POE-Loop-Glib/Makefile
+++ b/devel/p5-POE-Loop-Glib/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Loop-Glib
-# Date created: Jul 30 2010
-# Whom: Jase Thew <freebsd@beardz.net>
-#
+# Created by: Jase Thew <freebsd@beardz.net>
# $FreeBSD$
-#
PORTNAME= POE-Loop-Glib
PORTVERSION= 0.038
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-POE>=1.288:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Loop::Glib.3
diff --git a/devel/p5-Perl6-Export/Makefile b/devel/p5-Perl6-Export/Makefile
index 4a0936688494..b04ca022e481 100644
--- a/devel/p5-Perl6-Export/Makefile
+++ b/devel/p5-Perl6-Export/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Perl6-Export
-# Date created: 21 Oct 2004
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
# $FreeBSD$
-#
PORTNAME= Perl6-Export
PORTVERSION= 0.07
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Implements the Perl 6 'is export(...)' trait
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Perl6::Export.3
diff --git a/devel/p5-Proc-SafeExec/Makefile b/devel/p5-Proc-SafeExec/Makefile
index 55fc06d578b0..a4e4d9852f9b 100644
--- a/devel/p5-Proc-SafeExec/Makefile
+++ b/devel/p5-Proc-SafeExec/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convenient utility for executing external commands in various ways
LICENSE= BSD GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Proc::SafeExec.3 \
Proc::SafeExec::Queue.3
diff --git a/devel/p5-ReadLine-TTYtter/Makefile b/devel/p5-ReadLine-TTYtter/Makefile
index ceaffa6e545b..1db6d6142dd1 100644
--- a/devel/p5-ReadLine-TTYtter/Makefile
+++ b/devel/p5-ReadLine-TTYtter/Makefile
@@ -15,6 +15,7 @@ COMMENT= Perl5 module for Term::ReadLine allowing rich editing
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Term-Animation/Makefile b/devel/p5-Term-Animation/Makefile
index 88075ad5c469..c32f700f370d 100644
--- a/devel/p5-Term-Animation/Makefile
+++ b/devel/p5-Term-Animation/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Term-Animation
-# Date created: Sep 16, 2005
-# Whom: Max Khon <fjoe@FreeBSD.org>
-#
+# Created by: Max Khon <fjoe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Term-Animation
PORTVERSION= 2.6
@@ -17,7 +13,8 @@ COMMENT= ASCII sprite animation framework
BUILD_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Term::Animation.3 Term::Animation::Entity.3
diff --git a/devel/p5-Tie-RegexpHash/Makefile b/devel/p5-Tie-RegexpHash/Makefile
index 990365d277a4..8989d2b22491 100644
--- a/devel/p5-Tie-RegexpHash/Makefile
+++ b/devel/p5-Tie-RegexpHash/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-RegexpHash
-# Date created: 30 April 2010
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Tie-RegexpHash
PORTVERSION= 0.15
@@ -16,6 +12,7 @@ COMMENT= Use regular expressions as hash keys
MAN3= Tie::RegexpHash.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-cpan-listchanges/Makefile b/devel/p5-cpan-listchanges/Makefile
index 97b68afe3c1e..6fd5331dd7b5 100644
--- a/devel/p5-cpan-listchanges/Makefile
+++ b/devel/p5-cpan-listchanges/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= cpan-listchanges.1
MAN3= App::cpanlistchanges.3