aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-07-06 20:07:36 +0800
committertijl <tijl@FreeBSD.org>2013-07-06 20:07:36 +0800
commitdd70778915a150c7b5becfe1d4f0f508ead6841e (patch)
treeeec2f0a3de97b747d9af0ee8f94179f1716d74eb
parent15a5c9fb7591cbbecb156d9d5fc17c7918bafd6d (diff)
downloadfreebsd-ports-gnome-dd70778915a150c7b5becfe1d4f0f508ead6841e.tar.gz
freebsd-ports-gnome-dd70778915a150c7b5becfe1d4f0f508ead6841e.tar.zst
freebsd-ports-gnome-dd70778915a150c7b5becfe1d4f0f508ead6841e.zip
Problems with inline and clang are because clang defaults to C99.
By adding USE_CSTD=gnu89 patch-include-cgen-basic-ops.h can be removed. PR: 180257 Approved by: luca.pizzamiglio@gmail.com (maintainer)
-rw-r--r--devel/gdb/Makefile1
-rw-r--r--devel/gdb/files/patch-include-cgen-basic-ops.h43
2 files changed, 1 insertions, 43 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index e4d75f81af1d..2be99ba3af56 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -13,6 +13,7 @@ COMMENT= GNU GDB of newer version than comes with the system
LICENSE= GPLv3
USE_BZIP2= yes
+USE_CSTD= gnu89
USE_GMAKE= yes
USES= iconv
GNU_CONFIGURE= yes
diff --git a/devel/gdb/files/patch-include-cgen-basic-ops.h b/devel/gdb/files/patch-include-cgen-basic-ops.h
deleted file mode 100644
index 30c9f2ec399c..000000000000
--- a/devel/gdb/files/patch-include-cgen-basic-ops.h
+++ /dev/null
@@ -1,43 +0,0 @@
---- include/cgen/basic-ops.h.orig 2013-03-07 17:31:21.000000000 +0100
-+++ include/cgen/basic-ops.h 2013-03-07 17:31:28.000000000 +0100
-@@ -24,11 +24,16 @@
-
- #include <assert.h>
-
--#if defined (__GNUC__) && ! defined (SEMOPS_DEFINE_INLINE)
-+#if defined (__GNUC__) && ! defined (SEMOPS_DEFINE_INLINE) && ! defined (__clang__)
- #define SEMOPS_DEFINE_INLINE
- #define SEMOPS_INLINE extern inline
- #else
--#define SEMOPS_INLINE
-+# if defined (__clang__) && ! defined (SEMOPS_DEFINE_INLINE)
-+# define SEMOPS_DEFINE_INLINE
-+# define SEMOPS_INLINE static inline
-+# else
-+# define SEMOPS_INLINE
-+# endif
- #endif
-
- /* These don't really have a mode. */
-@@ -295,11 +300,16 @@
- significant and word number 0 is the most significant word.
- ??? May also wish an endian-dependent version. Later. */
-
--QI SUBWORDSIQI (SI, int);
--HI SUBWORDSIHI (SI, int);
--QI SUBWORDDIQI (DI, int);
--HI SUBWORDDIHI (DI, int);
--SI SUBWORDDISI (DI, int);
-+#if defined (__clang__) && defined (SEMOPS_DEFINE_INLINE)
-+#define SEMOPS_STATIC static
-+#else
-+#define SEMOPS_STATIC
-+#endif
-+SEMOPS_STATIC QI SUBWORDSIQI (SI, int);
-+SEMOPS_STATIC HI SUBWORDSIHI (SI, int);
-+SEMOPS_STATIC QI SUBWORDDIQI (DI, int);
-+SEMOPS_STATIC HI SUBWORDDIHI (DI, int);
-+SEMOPS_STATIC SI SUBWORDDISI (DI, int);
-
- #ifdef SEMOPS_DEFINE_INLINE
-