aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-09-03 18:35:09 +0800
committerantoine <antoine@FreeBSD.org>2017-09-03 18:35:09 +0800
commitde8380fede87bfc3ef1c0c2b42bdfb781ec60edf (patch)
tree99d57b8e2d8ecea4adb5b1e337272b7b0f5b6726
parent0c0796b3240de71353092f836cefb192813aec75 (diff)
downloadfreebsd-ports-gnome-de8380fede87bfc3ef1c0c2b42bdfb781ec60edf.tar.gz
freebsd-ports-gnome-de8380fede87bfc3ef1c0c2b42bdfb781ec60edf.tar.zst
freebsd-ports-gnome-de8380fede87bfc3ef1c0c2b42bdfb781ec60edf.zip
Mark BROKEN: fails to build
cythoning bsd/extattr.pyx to bsd/extattr.c Error compiling Cython file: ------------------------------------------------------------ ... attr_name = k attr_data = v data_len = len(v) if isinstance(fobj, file_types): kr = defs.extattr_set_fd(fobj.fileno(), namespace, attr_name, attr_data, data_len) ^ ------------------------------------------------------------ bsd/extattr.pyx:266:21: cimported module has no attribute 'extattr_set_fd' Reported by: pkg-fallout
-rw-r--r--devel/py-bsd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/py-bsd/Makefile b/devel/py-bsd/Makefile
index f5185c1d40ed..6a496a825984 100644
--- a/devel/py-bsd/Makefile
+++ b/devel/py-bsd/Makefile
@@ -10,6 +10,8 @@ COMMENT= Python wrappers for various BSD libc and system calls
LICENSE= BSD3CLAUSE
+BROKEN= fails to build
+
BUILD_DEPENDS= cython>0:lang/cython \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six