aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-04-11 05:59:01 +0800
committerkris <kris@FreeBSD.org>2005-04-11 05:59:01 +0800
commitdea69d49783d69848c65f030a2965702e43ccfc1 (patch)
treed5a40913ee7ec804b4583474e4d8e41c99527def
parentc2d0f03afed97c8b237c0f568efabd5dbb2d5967 (diff)
downloadfreebsd-ports-gnome-dea69d49783d69848c65f030a2965702e43ccfc1.tar.gz
freebsd-ports-gnome-dea69d49783d69848c65f030a2965702e43ccfc1.tar.zst
freebsd-ports-gnome-dea69d49783d69848c65f030a2965702e43ccfc1.zip
BROKEN on 4.x: Does not compile
-rw-r--r--net-mgmt/nfdump-devel/Makefile8
-rw-r--r--net-mgmt/nfdump/Makefile8
-rw-r--r--net/p5-Net-Z3950-SimpleServer/Makefile8
-rw-r--r--www/monkey/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/net-mgmt/nfdump-devel/Makefile b/net-mgmt/nfdump-devel/Makefile
index f3558406c027..e48aabf5a293 100644
--- a/net-mgmt/nfdump-devel/Makefile
+++ b/net-mgmt/nfdump-devel/Makefile
@@ -21,10 +21,16 @@ PLIST_FILES= bin/nfcapd bin/nfdump bin/nfprofile bin/nfreplay bin/nfclean.pl
MAN1= nfcapd.1 nfdump.1 nfprofile.1 nfreplay.1
PORTDOCS= AUTHORS ChangeLog INSTALL README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/nfdump/Makefile b/net-mgmt/nfdump/Makefile
index f3558406c027..e48aabf5a293 100644
--- a/net-mgmt/nfdump/Makefile
+++ b/net-mgmt/nfdump/Makefile
@@ -21,10 +21,16 @@ PLIST_FILES= bin/nfcapd bin/nfdump bin/nfprofile bin/nfreplay bin/nfclean.pl
MAN1= nfcapd.1 nfdump.1 nfprofile.1 nfreplay.1
PORTDOCS= AUTHORS ChangeLog INSTALL README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Z3950-SimpleServer/Makefile b/net/p5-Net-Z3950-SimpleServer/Makefile
index 52568d7a2596..bd65d1c62306 100644
--- a/net/p5-Net-Z3950-SimpleServer/Makefile
+++ b/net/p5-Net-Z3950-SimpleServer/Makefile
@@ -21,4 +21,10 @@ CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
MAN3= Net::Z3950::GRS1.3 Net::Z3950::SimpleServer.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/monkey/Makefile b/www/monkey/Makefile
index 0f7372b56cf7..1728618d192a 100644
--- a/www/monkey/Makefile
+++ b/www/monkey/Makefile
@@ -29,7 +29,13 @@ CONFIGURE_ENV+= EXTRA_CFLAGS="${CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/monkey.sh ${PREFIX}/etc/rc.d/monkey.sh.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>