aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-11-18 10:30:39 +0800
committermarcus <marcus@FreeBSD.org>2002-11-18 10:30:39 +0800
commitdf0b823ad6824a8f518531d911ca442a7771881f (patch)
tree142fc61515f64a02b33faae030934eec45152d21
parenteb7285a6915fd1de1740b04f93ed042cc898d8e2 (diff)
downloadfreebsd-ports-gnome-df0b823ad6824a8f518531d911ca442a7771881f.tar.gz
freebsd-ports-gnome-df0b823ad6824a8f518531d911ca442a7771881f.tar.zst
freebsd-ports-gnome-df0b823ad6824a8f518531d911ca442a7771881f.zip
Make these ports correctly survive a make reinstall.
-rw-r--r--www/mozilla-embedded-devel/Makefile1
-rw-r--r--www/mozilla-embedded-vendor/Makefile1
-rw-r--r--www/mozilla-embedded/Makefile1
-rw-r--r--www/mozilla-headers-devel/Makefile1
-rw-r--r--www/mozilla-headers-vendor/Makefile1
-rw-r--r--www/mozilla-headers/Makefile1
-rw-r--r--www/mozilla-vendor/Makefile1
7 files changed, 7 insertions, 0 deletions
diff --git a/www/mozilla-embedded-devel/Makefile b/www/mozilla-embedded-devel/Makefile
index b4fc1f2aa1d4..9da0f01092b3 100644
--- a/www/mozilla-embedded-devel/Makefile
+++ b/www/mozilla-embedded-devel/Makefile
@@ -42,6 +42,7 @@ do-build:
@${FIND} ${WRKSRC}/dist/Embed -name "*.so" | ${XARGS} ${STRIP_CMD}
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/Embed && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:lib/mozilla-embedded-devel/:' >> ${PLIST} \
diff --git a/www/mozilla-embedded-vendor/Makefile b/www/mozilla-embedded-vendor/Makefile
index 3d27cc7b5012..2d45947be742 100644
--- a/www/mozilla-embedded-vendor/Makefile
+++ b/www/mozilla-embedded-vendor/Makefile
@@ -42,6 +42,7 @@ do-build:
@${FIND} ${WRKSRC}/dist/Embed -name "*.so" | ${XARGS} ${STRIP_CMD}
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/Embed && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:lib/mozilla-embedded-vendor/:' >> ${PLIST} \
diff --git a/www/mozilla-embedded/Makefile b/www/mozilla-embedded/Makefile
index 2d9c3fa18693..dffedbaa1851 100644
--- a/www/mozilla-embedded/Makefile
+++ b/www/mozilla-embedded/Makefile
@@ -41,6 +41,7 @@ do-build:
@${FIND} ${WRKSRC}/dist/Embed -name "*.so" | ${XARGS} ${STRIP_CMD}
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/Embed && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:lib/mozilla-embedded/:' >> ${PLIST} \
diff --git a/www/mozilla-headers-devel/Makefile b/www/mozilla-headers-devel/Makefile
index 1f1bf4e0ac84..8e4c30738d21 100644
--- a/www/mozilla-headers-devel/Makefile
+++ b/www/mozilla-headers-devel/Makefile
@@ -34,6 +34,7 @@ CPIOOWN= -R ${INCOWN}:${INCGRP}
.endif
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:include/mozilla-devel/:' >> ${PLIST} \
diff --git a/www/mozilla-headers-vendor/Makefile b/www/mozilla-headers-vendor/Makefile
index f7c6f2e05fd1..0b487aee6e98 100644
--- a/www/mozilla-headers-vendor/Makefile
+++ b/www/mozilla-headers-vendor/Makefile
@@ -34,6 +34,7 @@ CPIOOWN= -R ${INCOWN}:${INCGRP}
.endif
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:include/mozilla-vendor/:' >> ${PLIST} \
diff --git a/www/mozilla-headers/Makefile b/www/mozilla-headers/Makefile
index 4aef76fecf2b..468b3d309245 100644
--- a/www/mozilla-headers/Makefile
+++ b/www/mozilla-headers/Makefile
@@ -33,6 +33,7 @@ CPIOOWN= -R ${INCOWN}:${INCGRP}
.endif
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:include/mozilla/:' >> ${PLIST} \
diff --git a/www/mozilla-vendor/Makefile b/www/mozilla-vendor/Makefile
index 8394b19408ec..6a77c986def5 100644
--- a/www/mozilla-vendor/Makefile
+++ b/www/mozilla-vendor/Makefile
@@ -125,6 +125,7 @@ post-build:
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
pre-install:
+ ${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
if [ ! -x ${PREFIX}/bin/mozilla -a ! -L ${PREFIX}/bin/mozilla ]; then \
${ECHO_CMD} bin/mozilla >> ${PLIST} ; \