aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-23 21:24:53 +0800
committeradamw <adamw@FreeBSD.org>2014-07-23 21:24:53 +0800
commite273cfa1d1798f129cd57e979464761439387d34 (patch)
tree90ea9c07e1113a3bc340f96d46f703b5020d7eec
parent5207e4c90c4fa601a9fd0cad4d0b9b5c7d1345d6 (diff)
downloadfreebsd-ports-gnome-e273cfa1d1798f129cd57e979464761439387d34.tar.gz
freebsd-ports-gnome-e273cfa1d1798f129cd57e979464761439387d34.tar.zst
freebsd-ports-gnome-e273cfa1d1798f129cd57e979464761439387d34.zip
Add USES=readline to fix build on -current.
-rw-r--r--databases/sqlcached/Makefile2
-rw-r--r--devel/elfsh/Makefile2
-rw-r--r--devel/libreadline-java/Makefile2
-rw-r--r--devel/mspdebug/Makefile2
-rw-r--r--devel/openzz/Makefile2
-rw-r--r--devel/tdl/Makefile2
-rw-r--r--games/gnurobots/Makefile2
-rw-r--r--games/hoichess/Makefile2
-rw-r--r--graphics/s10sh/Makefile2
-rw-r--r--lang/kawa/Makefile2
-rw-r--r--lang/micropython/Makefile2
-rw-r--r--lang/newlisp/Makefile2
-rw-r--r--lang/picoc/Makefile2
-rw-r--r--math/eval/Makefile2
-rw-r--r--math/rpy2/Makefile1
-rw-r--r--math/topaz/Makefile1
-rw-r--r--misc/tempcontrol/Makefile1
-rw-r--r--multimedia/cx88/Makefile2
-rw-r--r--net-p2p/shx/Makefile1
-rw-r--r--net/afpfs-ng/Makefile2
-rw-r--r--net/nfsshell/Makefile2
-rw-r--r--security/ossec-hids-server/Makefile2
-rw-r--r--sysutils/xfsprogs/Makefile2
23 files changed, 29 insertions, 13 deletions
diff --git a/databases/sqlcached/Makefile b/databases/sqlcached/Makefile
index 70630af6eb32..cfcabe992573 100644
--- a/databases/sqlcached/Makefile
+++ b/databases/sqlcached/Makefile
@@ -12,6 +12,8 @@ COMMENT= Cache daemon using SQL for data manipulation
LIB_DEPENDS= libsqlite.so:${PORTSDIR}/databases/sqlite2
+USES= readline
+
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/elfsh/Makefile b/devel/elfsh/Makefile
index 39752563ef34..d36d5fc27520 100644
--- a/devel/elfsh/Makefile
+++ b/devel/elfsh/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Attractive toolkit for the analysis of ELF object files
-USES= gmake
+USES= gmake readline
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/devel/libreadline-java/Makefile b/devel/libreadline-java/Makefile
index 2585f7e9a40f..fc9bbe2172dc 100644
--- a/devel/libreadline-java/Makefile
+++ b/devel/libreadline-java/Makefile
@@ -21,7 +21,7 @@ SUB_FILES= pkg-message jython.sh
PLIST_FILES= %%JAVAJARDIR%%/libreadline-java.jar lib/libJavaReadline.so \
lib/libJavaEditline.so lib/libJavaGetline.so
PORTDOCS= README.1st README jython.sh JReadlineCompleter.py
-USES= gmake
+USES= gmake readline
USE_JAVA= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/devel/mspdebug/Makefile b/devel/mspdebug/Makefile
index bbc78a5d8ac0..f204250b5c0c 100644
--- a/devel/mspdebug/Makefile
+++ b/devel/mspdebug/Makefile
@@ -11,7 +11,7 @@ COMMENT= Debugger for use with MSP 430 MCUs
LICENSE= GPLv2
-USES= gmake
+USES= gmake readline
PLIST_FILES= bin/mspdebug man/man1/mspdebug.1.gz
diff --git a/devel/openzz/Makefile b/devel/openzz/Makefile
index eab8f1ab6ce4..1264c1d8c573 100644
--- a/devel/openzz/Makefile
+++ b/devel/openzz/Makefile
@@ -13,7 +13,7 @@ COMMENT= Interpreted dynamic parser
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
-USES= libtool
+USES= libtool readline
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CFLAGS+= -Wno-return-type
diff --git a/devel/tdl/Makefile b/devel/tdl/Makefile
index e7efe3b94cb6..cff9dd696707 100644
--- a/devel/tdl/Makefile
+++ b/devel/tdl/Makefile
@@ -11,6 +11,8 @@ COMMENT= To-do list manager
CONFLICTS= devtodo-[0-9]*
+USES= readline
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX}
diff --git a/games/gnurobots/Makefile b/games/gnurobots/Makefile
index 8e5ab962c9a9..3f36f0262fdd 100644
--- a/games/gnurobots/Makefile
+++ b/games/gnurobots/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
-USES= pkgconfig
+USES= pkgconfig readline
USE_GNOME= vte
GNU_CONFIGURE= yes
diff --git a/games/hoichess/Makefile b/games/hoichess/Makefile
index ac6431c58a5f..8f3d4df519c8 100644
--- a/games/hoichess/Makefile
+++ b/games/hoichess/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= johans@FreeBSD.org
COMMENT= Not-so-very-strong chess engine
-USES= gmake perl5
+USES= gmake perl5 readline
USE_PERL5= build
MAKE_JOBS_UNSAFE=yes
MAKE_ENV= HAVE_GETOPT=1
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index a957019982a9..d58076a878a2 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -11,6 +11,8 @@ MASTER_SITES= http://www.reynoldsnet.org/s10sh/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= USB/serial userspace driver for the Canon PowerShot digital cameras
+USES= readline
+
# Don't extract the libusb bundled with s10sh:
EXTRACT_AFTER_ARGS= --exclude '*/libusb*'
diff --git a/lang/kawa/Makefile b/lang/kawa/Makefile
index 5a90f9a34727..84e00f805ee1 100644
--- a/lang/kawa/Makefile
+++ b/lang/kawa/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-USES= gmake
+USES= gmake readline
USE_JAVA= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index bdd2b3c7fed6..0fa471add4e2 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
USE_PYTHON_BUILD= yes
-USES= gmake shebangfix pkgconfig
+USES= gmake shebangfix pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= micropython
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index 42eb82a19cc7..eac5520e42a7 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
CONFLICTS= newlisp-devel-[0-9]*
+USES= readline
+
HAS_CONFIGURE= yes
ALL_TARGET= default
diff --git a/lang/picoc/Makefile b/lang/picoc/Makefile
index 4e6de90eb7de..4a55534c3c91 100644
--- a/lang/picoc/Makefile
+++ b/lang/picoc/Makefile
@@ -10,7 +10,7 @@ COMMENT= Very small C interpreter for scripting
LICENSE= BSD
-USES= gmake
+USES= gmake readline
USE_BZIP2= yes
PLIST_FILES= bin/picoc
diff --git a/math/eval/Makefile b/math/eval/Makefile
index 9ec2e4fd9eb1..d65180f3eb48 100644
--- a/math/eval/Makefile
+++ b/math/eval/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX= .lha
MAINTAINER= slaven@rezic.de
COMMENT= Full featured floating point expression evaluator
-USES= lha
+USES= lha readline
PLIST_FILES= bin/Eval
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index e2d9f875045d..491a34cefda1 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
R:${PORTSDIR}/math/R
+USES= readline
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/math/topaz/Makefile b/math/topaz/Makefile
index 558187f5d1b2..65dbe552b642 100644
--- a/math/topaz/Makefile
+++ b/math/topaz/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= readline
USE_XORG= x11
MAKEFILE= Makefile.freebsd
diff --git a/misc/tempcontrol/Makefile b/misc/tempcontrol/Makefile
index 0f75a90c4e1c..a2d197040b8f 100644
--- a/misc/tempcontrol/Makefile
+++ b/misc/tempcontrol/Makefile
@@ -11,6 +11,7 @@ COMMENT= Temperature control for fermenting beer and other applications
LICENSE= BSD2CLAUSE
+USES= readline
MAKE_ARGS= CFLAGS="${CFLAGS} -Wall -Wno-parentheses"
NO_WRKSUBDIR= yes
diff --git a/multimedia/cx88/Makefile b/multimedia/cx88/Makefile
index 67e6f6e6b006..9d7b057debf1 100644
--- a/multimedia/cx88/Makefile
+++ b/multimedia/cx88/Makefile
@@ -19,7 +19,7 @@ KMODDIR= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR}
MAKE_ARGS+= LIBTUNER_LIB=${LOCALBASE}/lib/libtuner LIBTUNER_HEADER=${LOCALBASE}/include/libtuner KMODDIR=${KMODDIR} PREFIX=${STAGEDIR}${PREFIX}
MAKE_JOBS_UNSAFE= yes
-USES= kmod pkgconfig
+USES= kmod pkgconfig readline
OPTIONS_DEFINE= DEBUG LINUX_COMPAT HAL
diff --git a/net-p2p/shx/Makefile b/net-p2p/shx/Makefile
index db1c8a3348dc..834cef1e7044 100644
--- a/net-p2p/shx/Makefile
+++ b/net-p2p/shx/Makefile
@@ -28,6 +28,7 @@ HAL_DESC= Compile MegaHAL (enables hal command)
XMMS_DESC= Enable trackname command
NOIPV4_DESC= IPv6 support (disables IPv4 support)
+USES= readline
MAKEFILE= makefile
GNU_CONFIGURE= yes
CONFIGURE_ARGS=
diff --git a/net/afpfs-ng/Makefile b/net/afpfs-ng/Makefile
index 1b2251e80de3..ce4196c58488 100644
--- a/net/afpfs-ng/Makefile
+++ b/net/afpfs-ng/Makefile
@@ -13,7 +13,7 @@ COMMENT= Apple Filing Protocol client library
LICENSE= GPLv2
INSTALL_TARGET= install-strip
-USES= gmake iconv libtool tar:bzip2
+USES= gmake iconv libtool tar:bzip2 readline
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
AUTOMAKE_ARGS= --add-missing --copy --force
USE_LDCONFIG= yes
diff --git a/net/nfsshell/Makefile b/net/nfsshell/Makefile
index 1a0ed35c5718..dbe217033a8f 100644
--- a/net/nfsshell/Makefile
+++ b/net/nfsshell/Makefile
@@ -15,6 +15,8 @@ GH_ACCOUNT= NetDirect
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 09cdd52
+USES= readline
+
ALL_TARGET= nfsshell
MAKE_ARGS= CC="${CC}" LIBS="-lreadline"
diff --git a/security/ossec-hids-server/Makefile b/security/ossec-hids-server/Makefile
index 451a605aabf6..59ab81898f79 100644
--- a/security/ossec-hids-server/Makefile
+++ b/security/ossec-hids-server/Makefile
@@ -16,6 +16,8 @@ USE_RC_SUBR= ossec-hids
CFLAGS+= -ferror-limit=0
+USES= readline
+
.if defined(MAINTAINER_MODE)
UID_FILES+= ../../UIDs
GID_FILES+= ../../GIDs
diff --git a/sysutils/xfsprogs/Makefile b/sysutils/xfsprogs/Makefile
index 77c8c558b520..26dc9d986d4a 100644
--- a/sysutils/xfsprogs/Makefile
+++ b/sysutils/xfsprogs/Makefile
@@ -17,7 +17,7 @@ LICENSE= LGPL21 GPLv2
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/doc/COPYING
-USES= gettext gmake libtool
+USES= gettext gmake libtool readline
USE_AUTOTOOLS= autoconf libtoolize
GNU_CONFIGURE= yes
CONFIGURE_ENV+= INSTALL="${INSTALL} ${_BINOWNGRP}" \