aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-09-18 03:56:43 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-09-18 03:56:43 +0800
commite55502624ef142bf4747c472572bc2734cf3a16d (patch)
tree0ea72fd32466f3db46e2ae3ea25d5e1314c3c9fd
parentc114ffd309196732c81ac05b212aa9e2d2c15346 (diff)
downloadfreebsd-ports-gnome-e55502624ef142bf4747c472572bc2734cf3a16d.tar.gz
freebsd-ports-gnome-e55502624ef142bf4747c472572bc2734cf3a16d.tar.zst
freebsd-ports-gnome-e55502624ef142bf4747c472572bc2734cf3a16d.zip
Convert to USE_GECKO and have mozilla dependency correctly detected now.
-rw-r--r--net/blam/Makefile31
1 files changed, 6 insertions, 25 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index b3a25a1ca705..36d634569ac7 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -8,7 +8,7 @@
PORTNAME= blam
PORTVERSION= 1.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.8
@@ -21,38 +21,19 @@ BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
RUN_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
${X11BASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp10
-BROKEN= Does not build
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
-.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-.else
-.if ${WITH_MOZILLA}=="firefox"
-MOZILLA= firefox
-.else
-MOZILLA= mozilla
-.endif
-.endif
-
+USE_GECKO= firefox mozilla
USE_GNOME= gnomeprefix gnomehack intlhack intltool libgnomeui
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
+CONFIGURE_ARGS= --with-mozilla=${GECKO}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= blam.schemas
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " firefox "
- @${ECHO_MSG} ""
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.include <bsd.port.post.mk>