aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-16 02:33:00 +0800
committerpav <pav@FreeBSD.org>2005-07-16 02:33:00 +0800
commite5c74d8f5ebbf63238d62b82d715d8f7e66bb24e (patch)
tree8ab1120196438735bc2ca06c30bf8f7367dca5ec
parent4a44c6ea1214175de3df13f56a22b0299e29edbd (diff)
downloadfreebsd-ports-gnome-e5c74d8f5ebbf63238d62b82d715d8f7e66bb24e.tar.gz
freebsd-ports-gnome-e5c74d8f5ebbf63238d62b82d715d8f7e66bb24e.tar.zst
freebsd-ports-gnome-e5c74d8f5ebbf63238d62b82d715d8f7e66bb24e.zip
Your computer has been invaded! Dozens of little viruses are pouring in via
security holes in Microsoft Internet Explorer, Microsoft Outlook, Microsoft MSN Messenger and Microsoft Recycle Bin!! Using your trusty mouse you must shoot the buggers before they can destroy your files! Some will steal them from their home directories and take them back to their security hole. Others will just eat them right there on the spot! See how long you and your computer can survive the onslaught! PR: ports/83422 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
-rw-r--r--games/Makefile1
-rw-r--r--games/viruskiller/Makefile44
-rw-r--r--games/viruskiller/distinfo2
-rw-r--r--games/viruskiller/files/patch-makefile67
-rw-r--r--games/viruskiller/pkg-descr12
-rw-r--r--games/viruskiller/pkg-plist17
6 files changed, 143 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 13e3114c9165..404f591251db 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -528,6 +528,7 @@
SUBDIR += vavoom
SUBDIR += vectoroids
SUBDIR += virt
+ SUBDIR += viruskiller
SUBDIR += wanderer
SUBDIR += wargus
SUBDIR += wesnoth
diff --git a/games/viruskiller/Makefile b/games/viruskiller/Makefile
new file mode 100644
index 000000000000..4c384a86abdc
--- /dev/null
+++ b/games/viruskiller/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: viruskiller
+# Date created: 13 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viruskiller
+DISTVERSION= 1.0-1
+CATEGORIES= games
+MASTER_SITES= http://www.parallelrealities.co.uk/download.php?type=zip&file=
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= An arcade game that relies on quick reflexes
+
+FETCH_BEFORE_ARGS+= -o ${DISTNAME}${EXTRACT_SUFX}
+
+USE_GMAKE= yes
+USE_SDL= image mixer sdl ttf
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}"
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
+ s|\(-Wall\)|${CFLAGS} \1|' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Fix SDL include statement
+ @${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
+ ${WRKSRC}/src/*.cpp ${WRKSRC}/src/*.h
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${RM} ${DOCSDIR}/LICENSE
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/viruskiller/distinfo b/games/viruskiller/distinfo
new file mode 100644
index 000000000000..235f6572a96b
--- /dev/null
+++ b/games/viruskiller/distinfo
@@ -0,0 +1,2 @@
+MD5 (viruskiller-1.0-1.tar.gz) = de7c78b3abdb4ff488943d78a94f5bb1
+SIZE (viruskiller-1.0-1.tar.gz) = 4402168
diff --git a/games/viruskiller/files/patch-makefile b/games/viruskiller/files/patch-makefile
new file mode 100644
index 000000000000..83961ec599ee
--- /dev/null
+++ b/games/viruskiller/files/patch-makefile
@@ -0,0 +1,67 @@
+--- makefile.orig Sat May 21 14:03:45 2005
++++ makefile Wed Jul 13 19:30:52 2005
+@@ -7,19 +7,18 @@
+ RELEASE = 1
+ USEPAK = 1
+
+-PREFIX=$(DESTDIR)/usr
+-BINDIR = $(PREFIX)/games/
+-DATADIR = $(PREFIX)/share/games/parallelrealities/
+-DOCDIR = $(PREFIX)/share/doc/$(PROG)-$(VERSION)-$(RELEASE)/
++BINDIR = $(PREFIX)/bin/
++DATADIR = $(PREFIX)/share/$(PROG)/
++DOCDIR = $(PREFIX)/share/doc/$(PROG)/
+ ICONDIR = $(PREFIX)/share/icons/
+ KDE = $(PREFIX)/share/applnk/Games/Arcade/
+ GNOME = $(PREFIX)/share/gnome/apps/Games/
+
+ SAFEDIR = /tmp/
+
+-CFLAGS += `sdl-config --cflags` -DVERSION=$(VERSION) -DRELEASE=$(RELEASE) -DUSEPAK=$(USEPAK)
+-CFLAGS += -DPAKNAME=\"$(PAKNAME)\" -DPAKLOCATION=\"$(DATADIR)\" -DSAFEDIR=\"$(SAFEDIR)\" -DUNIX -DGAMEPLAYMANUAL=\"$(DOCDIR)manual.html\" -Wall
+-LIBS = `sdl-config --libs` -lSDL_mixer -lSDL_image -lSDL_ttf
++CFLAGS += `/usr/local/bin/sdl11-config --cflags` -DVERSION=$(VERSION) -DRELEASE=$(RELEASE) -DUSEPAK=$(USEPAK)
++CFLAGS += -DPAKNAME=\"$(PAKNAME)\" -DPAKLOCATION=\"$(DATADIR)\" -DSAFEDIR=\"$(SAFEDIR)\" -DUNIX -DGAMEPLAYMANUAL=\"$(DOCDIR)manual.html\" -Wall
++LIBS = `/usr/local/bin/sdl11-config --libs` -lSDL_mixer -lSDL_image -lSDL_ttf
+
+ OBJS += CAudio.o
+ OBJS += CBase.o
+@@ -51,7 +50,7 @@
+ PAKOBJS = CFileData.o pak.o
+
+ # top-level rule to create the program.
+-all: $(PROG) pak
++all: $(PROG) pak buildpak
+
+ # compiling other source files.
+ %.o: src/%.cpp src/%.h src/defs.h src/headers.h
+@@ -73,23 +72,10 @@
+
+ # install
+ install:
+-
+- ./pak data gfx music sound $(PAKNAME)
+- mkdir -p $(BINDIR)
++ $(BSD_INSTALL_PROGRAM) $(PROG) $(BINDIR)$(PROG)
+ mkdir -p $(DATADIR)
+- mkdir -p $(DOCDIR)
+- mkdir -p $(ICONDIR)
+- mkdir -p $(ICONDIR)mini
+- mkdir -p $(ICONDIR)large
+- mkdir -p $(KDE)
+- mkdir -p $(GNOME)
+-
+- strip $(PROG)
+- install -o root -g games -m 755 $(PROG) $(BINDIR)$(PROG)
+- install -o root -g games -m 644 $(PAKNAME) $(DATADIR)$(PAKNAME)
+- cp $(DOCS) $(DOCDIR)
+- cp $(ICONS)$(PROG).png $(ICONDIR)
+- cp $(ICONS)$(PROG)-mini.png $(ICONDIR)mini/$(PROG).png
+- cp $(ICONS)$(PROG)-large.png $(ICONDIR)large/$(PROG).png
+- cp $(ICONS)$(PROG).desktop $(KDE)
+- cp $(ICONS)$(PROG).desktop $(GNOME)
++ $(BSD_INSTALL_DATA) $(PAKNAME) $(DATADIR)$(PAKNAME)
++ mkdir -p $(PREFIX)/share/applications
++ $(BSD_INSTALL_DATA) $(ICONS)$(PROG).desktop $(PREFIX)/share/applications
++ mkdir -p $(PREFIX)/share/pixmaps
++ $(BSD_INSTALL_DATA) $(ICONS)$(PROG).png $(PREFIX)/share/pixmaps
diff --git a/games/viruskiller/pkg-descr b/games/viruskiller/pkg-descr
new file mode 100644
index 000000000000..1dcc8f748d8f
--- /dev/null
+++ b/games/viruskiller/pkg-descr
@@ -0,0 +1,12 @@
+Your computer has been invaded! Dozens of little viruses are pouring in via
+security holes in Microsoft Internet Explorer, Microsoft Outlook, Microsoft
+MSN Messenger and Microsoft Recycle Bin!! Using your trusty mouse you must
+shoot the buggers before they can destroy your files! Some will steal them
+from their home directories and take them back to their security hole. Others
+will just eat them right there on the spot! See how long you and your computer
+can survive the onslaught!
+
+WWW: http://www.parallelrealities.co.uk/virusKiller.php
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/viruskiller/pkg-plist b/games/viruskiller/pkg-plist
new file mode 100644
index 000000000000..0e25304b3ff2
--- /dev/null
+++ b/games/viruskiller/pkg-plist
@@ -0,0 +1,17 @@
+bin/viruskiller
+share/applications/viruskiller.desktop
+share/pixmaps/viruskiller.png
+%%DATADIR%%/viruskiller.pak
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/battery.png
+%%PORTDOCS%%%%DOCSDIR%%/bomb.png
+%%PORTDOCS%%%%DOCSDIR%%/clock.png
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/title.png
+%%PORTDOCS%%%%DOCSDIR%%/virus1.gif
+%%PORTDOCS%%%%DOCSDIR%%/virus2.gif
+%%PORTDOCS%%%%DOCSDIR%%/virus3.gif
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+@unexec rmdir %D/share/applications 2>/dev/null || true