aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-09 22:13:20 +0800
committeraz <az@FreeBSD.org>2013-09-09 22:13:20 +0800
commite7190d5277e2fbb736fdc8436fd8eab92ae3401b (patch)
tree8d97ef48bf116ebd32fdda982767b19421dff0f2
parentf2c89eeb21960d42b092b2885d7401a353e16e0b (diff)
downloadfreebsd-ports-gnome-e7190d5277e2fbb736fdc8436fd8eab92ae3401b.tar.gz
freebsd-ports-gnome-e7190d5277e2fbb736fdc8436fd8eab92ae3401b.tar.zst
freebsd-ports-gnome-e7190d5277e2fbb736fdc8436fd8eab92ae3401b.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--devel/p5-App-Info/Makefile9
-rw-r--r--devel/p5-CPAN-Uploader/Makefile3
-rw-r--r--devel/p5-Class-Method-Modifiers-Fast/Makefile8
-rw-r--r--devel/p5-Data-Average/Makefile9
-rw-r--r--devel/p5-FreeBSD-i386-Ptrace/Makefile9
-rw-r--r--devel/p5-Geo-ShapeFile/Makefile9
-rw-r--r--devel/p5-Hash-Diff/Makefile9
-rw-r--r--devel/p5-IO-Callback/Makefile8
-rw-r--r--devel/p5-JQuery/Makefile9
-rw-r--r--devel/p5-Log-Any-Adapter/Makefile3
-rw-r--r--devel/p5-Package-Generator/Makefile3
-rw-r--r--devel/p5-SVN-Agent/Makefile9
-rw-r--r--devel/p5-Scope-Guard/Makefile9
-rw-r--r--devel/p5-Test-Mini/Makefile9
-rw-r--r--devel/p5-Test-MockTime/Makefile3
-rw-r--r--devel/p5-Test-More-UTF8/Makefile9
-rw-r--r--devel/p5-Test-UseAllModules/Makefile9
-rw-r--r--devel/p5-Time-Format/Makefile3
-rw-r--r--devel/p5-lib-abs/Makefile9
19 files changed, 50 insertions, 89 deletions
diff --git a/devel/p5-App-Info/Makefile b/devel/p5-App-Info/Makefile
index 5c2a3fa1fc41..bde74b003f2d 100644
--- a/devel/p5-App-Info/Makefile
+++ b/devel/p5-App-Info/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-App-Info
-# Date created: 19 May 2003
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= App-Info
PORTVERSION= 0.57
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Interface for providing metadata about installed software packages
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
MAN3= App::Info::HTTPD.3 App::Info::Lib::Iconv.3 \
App::Info::HTTPD::Apache.3 App::Info::Lib.3 App::Info::RDBMS.3 \
diff --git a/devel/p5-CPAN-Uploader/Makefile b/devel/p5-CPAN-Uploader/Makefile
index b0910512303d..ae760efdc76c 100644
--- a/devel/p5-CPAN-Uploader/Makefile
+++ b/devel/p5-CPAN-Uploader/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= cpan-upload.1
MAN3= CPAN::Uploader.3
diff --git a/devel/p5-Class-Method-Modifiers-Fast/Makefile b/devel/p5-Class-Method-Modifiers-Fast/Makefile
index 512a540f45c9..3222e6ebb6c6 100644
--- a/devel/p5-Class-Method-Modifiers-Fast/Makefile
+++ b/devel/p5-Class-Method-Modifiers-Fast/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Class::Method::Modifiers::Fast
-# Date created: 21 Jan 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Class-Method-Modifiers-Fast
PORTVERSION= 0.041
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Sub-Uplevel>=0.18:${PORTSDIR}/devel/p5-Sub-Uplevel
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Method::Modifiers::Fast.3
diff --git a/devel/p5-Data-Average/Makefile b/devel/p5-Data-Average/Makefile
index 95bc29bbacce..3f125413da1a 100644
--- a/devel/p5-Data-Average/Makefile
+++ b/devel/p5-Data-Average/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Average
-# Date created: 01 Jun 2010
-# Whom: Alexander Kriventsov <avk@vl.ru>
-#
+# Created by: Alexander Kriventsov <avk@vl.ru>
# $FreeBSD$
-#
PORTNAME= Data-Average
PORTVERSION= 0.03000
@@ -18,7 +14,8 @@ COMMENT= Hold Data Set To Calculate Average
BUILD_DEPENDS= p5-UNIVERSAL-isa>=0:${PORTSDIR}/devel/p5-UNIVERSAL-isa
RUN_DEPENDS= p5-UNIVERSAL-isa>=0:${PORTSDIR}/devel/p5-UNIVERSAL-isa
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Average::Bounded.3 Data::Average::BoundedExpires.3 Data::Average::Expires.3 Data::Average.3
diff --git a/devel/p5-FreeBSD-i386-Ptrace/Makefile b/devel/p5-FreeBSD-i386-Ptrace/Makefile
index 5add7eabddc1..60660ce2e81c 100644
--- a/devel/p5-FreeBSD-i386-Ptrace/Makefile
+++ b/devel/p5-FreeBSD-i386-Ptrace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-FreeBSD-i386-Ptrace
-# Date created: 2009-03-15
-# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
-#
+# Created by: TAKAHASHI Kaoru <kaoru@kaisei.org>
# $FreeBSD$
-#
PORTNAME= FreeBSD-i386-Ptrace
PORTVERSION= 0.03
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Perl module for ptrace on FreeBSD-i386
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
ONLY_FOR_ARCHS= i386
MAN3= FreeBSD::i386::Ptrace.3
diff --git a/devel/p5-Geo-ShapeFile/Makefile b/devel/p5-Geo-ShapeFile/Makefile
index 7aacc7f49451..b9c5c4f99397 100644
--- a/devel/p5-Geo-ShapeFile/Makefile
+++ b/devel/p5-Geo-ShapeFile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Point
-# Date created: 27 December 2005
-# Whom: estith
-#
+# Created by: estith
# $FreeBSD$
-#
PORTNAME= Geo-ShapeFile
PORTVERSION= 2.52
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lippe@FreeBSD.org
COMMENT= Perl extension for handling ESRI GIS Shapefiles
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::ShapeFile.3 Geo::ShapeFile::Point.3 Geo::ShapeFile::Shape.3
diff --git a/devel/p5-Hash-Diff/Makefile b/devel/p5-Hash-Diff/Makefile
index e705994a57b1..c08ca787e41e 100644
--- a/devel/p5-Hash-Diff/Makefile
+++ b/devel/p5-Hash-Diff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Hash-Diff
-# Date created: 2012-03-16
-# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
-#
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Hash-Diff
PORTVERSION= 0.005
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Hash-Merge>=0.12:${PORTSDIR}/textproc/p5-Hash-Merge
TEST_DEPENDS= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple \
p5-Test-use-ok>=0.02:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Hash::Diff.3
diff --git a/devel/p5-IO-Callback/Makefile b/devel/p5-IO-Callback/Makefile
index a8eb0082977f..2e7c1999677c 100644
--- a/devel/p5-IO-Callback/Makefile
+++ b/devel/p5-IO-Callback/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: IO::Callback
-# Date created: 02 Jun 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= IO-Callback
PORTVERSION= 1.10
@@ -24,7 +19,8 @@ TEST_DEPENDS= \
p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::Callback.3
diff --git a/devel/p5-JQuery/Makefile b/devel/p5-JQuery/Makefile
index c67450cad8b3..e7e059e8410d 100644
--- a/devel/p5-JQuery/Makefile
+++ b/devel/p5-JQuery/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-JQuery
-# Date created: 2007-07-14
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= JQuery
PORTVERSION= 1.06
@@ -23,7 +19,8 @@ RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= JQuery.3 \
JQuery::Accordion.3 \
diff --git a/devel/p5-Log-Any-Adapter/Makefile b/devel/p5-Log-Any-Adapter/Makefile
index ecfcf64da911..81390a4c18a1 100644
--- a/devel/p5-Log-Any-Adapter/Makefile
+++ b/devel/p5-Log-Any-Adapter/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Capture-Tiny>=0.12:${PORTSDIR}/devel/p5-Capture-Tiny
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Any::Adapter.3 \
Log::Any::Adapter::Base.3 \
diff --git a/devel/p5-Package-Generator/Makefile b/devel/p5-Package-Generator/Makefile
index 3d89edfe66e9..731eda8ec3cc 100644
--- a/devel/p5-Package-Generator/Makefile
+++ b/devel/p5-Package-Generator/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= This module lets you quickly and easily construct new packages
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Package::Reaper.3 Package::Generator.3
diff --git a/devel/p5-SVN-Agent/Makefile b/devel/p5-SVN-Agent/Makefile
index fcedf4ff85a8..122935361aef 100644
--- a/devel/p5-SVN-Agent/Makefile
+++ b/devel/p5-SVN-Agent/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SVN-Agent
-# Date created: 2006-07-12
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
# $FreeBSD$
-#
PORTNAME= SVN-Agent
PORTVERSION= 0.04
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Agent.3
diff --git a/devel/p5-Scope-Guard/Makefile b/devel/p5-Scope-Guard/Makefile
index f84a057f0fa4..e185bca5898c 100644
--- a/devel/p5-Scope-Guard/Makefile
+++ b/devel/p5-Scope-Guard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Scope-Guard
-# Date created: 29 December 2006
-# Whom: Craig Manley
-#
+# Created by: Craig Manley
# $FreeBSD$
-#
PORTNAME= Scope-Guard
PORTVERSION= 0.20
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= v.a.popov@gmail.com
COMMENT= Lexically scoped resource management
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Scope::Guard.3
diff --git a/devel/p5-Test-Mini/Makefile b/devel/p5-Test-Mini/Makefile
index 1e6f362a85a2..2c498de2ae98 100644
--- a/devel/p5-Test-Mini/Makefile
+++ b/devel/p5-Test-Mini/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Mini
-# Date created: 2011-01-13
-# Whom: Kurt Lidl <kurt.lidl@cello.com>
-#
+# Created by: Kurt Lidl <kurt.lidl@cello.com>
# $FreeBSD$
-#
PORTNAME= Test-Mini
PORTVERSION= v1.1.3
@@ -26,7 +22,8 @@ BUILD_DEPENDS= p5-Data-Inspect>=0.03:${PORTSDIR}/devel/p5-Data-Inspect \
p5-namespace-clean>=0.14:${PORTSDIR}/devel/p5-namespace-clean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Mini.3 \
Test::Mini::Assertions.3 \
diff --git a/devel/p5-Test-MockTime/Makefile b/devel/p5-Test-MockTime/Makefile
index 248c6c3be224..9c3602e406cf 100644
--- a/devel/p5-Test-MockTime/Makefile
+++ b/devel/p5-Test-MockTime/Makefile
@@ -14,7 +14,8 @@ COMMENT= Replaces actual time with simulated time
BUILD_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece
RUN_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::MockTime.3
diff --git a/devel/p5-Test-More-UTF8/Makefile b/devel/p5-Test-More-UTF8/Makefile
index 4c248cc67151..09aacfe88e09 100644
--- a/devel/p5-Test-More-UTF8/Makefile
+++ b/devel/p5-Test-More-UTF8/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Test-More-UTF8
-# Date created: 11 Feb 2010
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-More-UTF8
PORTVERSION= 0.04
@@ -17,7 +13,8 @@ COMMENT= Enhancing Test::More for UTF-8-based projects
BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::More::UTF8.3
diff --git a/devel/p5-Test-UseAllModules/Makefile b/devel/p5-Test-UseAllModules/Makefile
index 3e955bffa2a3..52663f08d380 100644
--- a/devel/p5-Test-UseAllModules/Makefile
+++ b/devel/p5-Test-UseAllModules/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-UseAllModules
-# Date created: 2007-10-30
-# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
-#
+# Created by: TAKAHASHI Kaoru <kaoru@kaisei.org>
# $FreeBSD$
-#
PORTNAME= Test-UseAllModules
PORTVERSION= 0.14
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Perl extension to do use_ok() for all modules MANIFESTed
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::UseAllModules.3
diff --git a/devel/p5-Time-Format/Makefile b/devel/p5-Time-Format/Makefile
index bf38b719c3c1..297cceec869e 100644
--- a/devel/p5-Time-Format/Makefile
+++ b/devel/p5-Time-Format/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= Sergey.Dyatko@gmail.com
COMMENT= Easy-to-use date/time formatting
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Time::Format.3
diff --git a/devel/p5-lib-abs/Makefile b/devel/p5-lib-abs/Makefile
index 4ff24f4ed4cd..b8d3c5654ddb 100644
--- a/devel/p5-lib-abs/Makefile
+++ b/devel/p5-lib-abs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-lib-abs
-# Date created: 2009-07-21
-# Whom: Mons Anderson <mons@cpan.org>
-#
+# Created by: Mons Anderson <mons@cpan.org>
# $FreeBSD$
-#
PORTNAME= lib-abs
PORTVERSION= 0.92
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mons@cpan.org
COMMENT= Relative use lib in absolute way
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= lib::abs.3