aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-07-01 17:17:45 +0800
committerlinimon <linimon@FreeBSD.org>2018-07-01 17:17:45 +0800
commite7583aecaa25df453812883269f053fd56ec331e (patch)
tree03d0951296a7fc3c7578f9a9a0fe576a50e1e2bb
parent69d9c48fa7f08a8faa0182ebb4894d7f561a8ec6 (diff)
downloadfreebsd-ports-gnome-e7583aecaa25df453812883269f053fd56ec331e.tar.gz
freebsd-ports-gnome-e7583aecaa25df453812883269f053fd56ec331e.tar.zst
freebsd-ports-gnome-e7583aecaa25df453812883269f053fd56ec331e.zip
Mark these ports broken on mips64 and/or mips.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
-rw-r--r--audio/id3lib/Makefile3
-rw-r--r--audio/jack/Makefile2
-rw-r--r--databases/kyotocabinet/Makefile9
-rw-r--r--devel/judy/Makefile3
-rw-r--r--devel/libffcall/Makefile2
-rw-r--r--devel/skalibs/Makefile2
-rw-r--r--ftp/fastdfs/Makefile3
-rw-r--r--games/crafty/Makefile2
-rw-r--r--graphics/freeimage/Makefile5
-rw-r--r--japanese/mecab/Makefile3
-rw-r--r--lang/f2c/Makefile3
-rw-r--r--lang/guile2/Makefile2
-rw-r--r--math/igraph/Makefile11
-rw-r--r--net/pvm/Makefile3
-rw-r--r--security/php72-hash/Makefile2
-rw-r--r--textproc/libucl/Makefile3
-rw-r--r--www/w3m/Makefile2
17 files changed, 48 insertions, 12 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index 6ce2c679a237..4c2b4ab46c40 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= SF
MAINTAINER= kaeru@inigo-tech.com
COMMENT= Library for manipulating ID3v1/v1.1 and ID3v2 tags
+BROKEN_mips= fails to link: '_ZTSN12_GLOBAL__N_117ConstIteratorImplE' referenced in section '.data.rel.ro' of tag.lo: defined in discarded section
+BROKEN_mips64= fails to link: '_ZTSN12_GLOBAL__N_117ConstIteratorImplE' referenced in section '.data.rel.ro' of tag.lo: defined in discarded section
+
GNU_CONFIGURE= yes
USES= iconv libtool
USE_LDCONFIG= yes
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 6835d8fedaea..29122654944c 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -12,6 +12,8 @@ COMMENT= Low latency audio server
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
+BROKEN_mips= fails to link: undefined reference to '__sync_add_and_fetch_4'
+BROKEN_mips64= fails to link: undefined reference to '__sync_add_and_fetch_4'
BROKEN_powerpc64= fails to build: Unrecognized opcode: 'sldi'
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
diff --git a/databases/kyotocabinet/Makefile b/databases/kyotocabinet/Makefile
index 37bfe91025c9..49d7d0d1bb8b 100644
--- a/databases/kyotocabinet/Makefile
+++ b/databases/kyotocabinet/Makefile
@@ -13,6 +13,10 @@ COMMENT= Straightforward implementation of DBM
LICENSE= GPLv3
+BROKEN_mips= fails to link: hidden symbol '__sync_lock_test_and_set_8' in /usr/lib/libgcc.a(stdatomic.o) is referenced by DSO
+BROKEN_mips64= fails to link: hidden symbol '__sync_lock_test_and_set_8' in /usr/lib/libgcc.a(stdatomic.o) is referenced by DSO
+BROKEN_powerpc= fails to link
+
OPTIONS_DEFINE= DOCS
CPPFLAGS+= -fPIC
@@ -21,11 +25,8 @@ INSTALL_TARGET= install-strip
MAKE_ARGS= PCDIR=${PREFIX}/libdata/pkgconfig
REINPLACE_ARGS= -i ''
TEST_TARGET= check
-USE_LDCONFIG= yes
USES= gmake
-
-NOT_FOR_ARCHS= powerpc
-NOT_FOR_ARCHS_REASON= does not link
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile ${WRKSRC}/lab/kcdict/Makefile
diff --git a/devel/judy/Makefile b/devel/judy/Makefile
index 0aaaf9d8fb68..10241bcb4c20 100644
--- a/devel/judy/Makefile
+++ b/devel/judy/Makefile
@@ -12,6 +12,9 @@ COMMENT= General purpose dynamic array
LICENSE= LGPL21
+BROKEN_mips= fails to compile: unrecognized command line option "-m32"
+BROKEN_mips64= fails to compile: unrecognized command line option "-m64"
+
USES= gmake libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/libffcall/Makefile b/devel/libffcall/Makefile
index 6bfceb8f68b6..f47a240ca8f8 100644
--- a/devel/libffcall/Makefile
+++ b/devel/libffcall/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to build: avcall-armhf.s:46:2: error: '.syntax divided' arm assembly not supported
BROKEN_armv7= fails to build: avcall-armhf.s:46:2: error: '.syntax divided' arm assembly not supported
+BROKEN_mips= fails to build: gmake[2]: No rule to make target 'avcall-mipsn32-macro.S', needed by 'avcall-mipsn32.s'
+BROKEN_mips64= fails to build: gmake[2]: No rule to make target 'avcall-mips64-macro.S', needed by 'avcall-mips64.s'
GNU_CONFIGURE= yes
USES= gmake libtool
diff --git a/devel/skalibs/Makefile b/devel/skalibs/Makefile
index d120c5c5901c..2537205a1bff 100644
--- a/devel/skalibs/Makefile
+++ b/devel/skalibs/Makefile
@@ -12,6 +12,8 @@ COMMENT= General purpose C libraries used by skarnet.org software
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_mips64= fails to build: Checking whether system has auto-close after fd-passing... test crashed, aborting
+
USES= gmake
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
diff --git a/ftp/fastdfs/Makefile b/ftp/fastdfs/Makefile
index c50a2012c881..b3bdfdba3aa1 100644
--- a/ftp/fastdfs/Makefile
+++ b/ftp/fastdfs/Makefile
@@ -11,6 +11,9 @@ COMMENT= High performance distributed file system (DFS)
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING-3_0.txt
+BROKEN_mips= fails to link: tracker_service.c:270: undefined reference to '__sync_add_and_fetch_4'
+BROKEN_mips64= fails to link: tracker_service.c:270: undefined reference to '__sync_add_and_fetch_4'
+
LIB_DEPENDS= libfastcommon.so:devel/libfastcommon
USES= perl5
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index fba6d7ead88c..2398a625532a 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -19,6 +19,8 @@ COMMENT= Chess program for playing and analyzing games
BROKEN_aarch64= fails to compile: invokes x86 assembler
BROKEN_armv6= fails to compile: invokes x86 assembler
BROKEN_armv7= fails to compile: invokes x86 assembler
+BROKEN_mips= fails to compile: unrecognized command line option "-mpopcnt"
+BROKEN_mips64= fails to compile: unrecognized command line option "-mpopcnt"
WRKSRC= ${WRKDIR}
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 371db8b157e7..dea5ab71fa35 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -14,6 +14,9 @@ DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple C/C++ bitmap graphics library
+BROKEN_mips= fails to compile: opcode not supported on this processor: mips3 (mips3) `madd $16,$6'
+BROKEN_mips64= fails to compile: opcode not supported on this processor: mips3 (mips3) 'madd $4,$5'
+
USES= dos2unix gmake zip
DOS2UNIX_FILES= Source/LibOpenJPEG/opj_malloc.h \
Source/LibRawLite/dcraw/dcraw.c \
@@ -40,7 +43,7 @@ PLIST_FILES= include/FreeImage.h \
.include <bsd.port.options.mk>
-.if ${ARCH} == amd64 || ${ARCH} == powerpc
+.if ${ARCH} == amd64 || ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == sparc64
USES+= compiler:c++0x
.endif
diff --git a/japanese/mecab/Makefile b/japanese/mecab/Makefile
index bdcf6b4eaa2d..6a49150d0ed4 100644
--- a/japanese/mecab/Makefile
+++ b/japanese/mecab/Makefile
@@ -13,6 +13,9 @@ COMMENT= Yet Another Part-of-Speech and Morphological Analyzer
LICENSE= BSD3CLAUSE GPLv2 LGPL21
LICENSE_COMB= multi
+BROKEN_mips= fails to link: Nonrepresentable section on output
+BROKEN_mips64= fails to link: Nonrepresentable section on output
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_lib_stdcpp_main=no
INSTALL_TARGET= install-strip
diff --git a/lang/f2c/Makefile b/lang/f2c/Makefile
index d6a4126a30bd..216ff06fdd75 100644
--- a/lang/f2c/Makefile
+++ b/lang/f2c/Makefile
@@ -13,6 +13,9 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= fortran@FreeBSD.org
COMMENT= Fortran-to-C converter and its run-time libraries
+BROKEN_mips= fails to compile: /usr/include/sigfpe.h: No such file or directory
+BROKEN_mips64= fails to compile: /usr/include/sigfpe.h: No such file or directory
+
EXTRACT_DEPENDS= ${UNZIP_CMD}:archivers/unzip
GUNZIP_CMD= minigzip -d
diff --git a/lang/guile2/Makefile b/lang/guile2/Makefile
index e469401985fa..390106aa9f48 100644
--- a/lang/guile2/Makefile
+++ b/lang/guile2/Makefile
@@ -13,6 +13,8 @@ COMMENT= GNU Ubiquitous Intelligent Language for Extension
LICENSE= LGPL21
+BROKEN_mips64= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+
LIB_DEPENDS= libgmp.so:math/gmp \
libltdl.so:devel/libltdl \
libunistring.so:devel/libunistring \
diff --git a/math/igraph/Makefile b/math/igraph/Makefile
index 22afb8287660..8aab95a8e974 100644
--- a/math/igraph/Makefile
+++ b/math/igraph/Makefile
@@ -11,6 +11,9 @@ COMMENT= Package For Manipulating Undirected And Directed Graphs
LICENSE= GPLv2
+BROKEN_mips64= fails to link: relocation truncated to fit: R_MIPS_TLS_GD against 'igraph_i_interruption_handler'
+BROKEN_sparc64= fails to compile: uses x86 asm
+
LIB_DEPENDS= libgmp.so:math/gmp
GNU_CONFIGURE= yes
@@ -22,10 +25,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: uses i386 asm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pvm/Makefile b/net/pvm/Makefile
index dff347248e1f..daa3e7252200 100644
--- a/net/pvm/Makefile
+++ b/net/pvm/Makefile
@@ -13,6 +13,9 @@ COMMENT= Parallel Virtual Machine libraries and environment
LICENSE= MIT
+BROKEN_mips= fails to compile: 'SIGCLD' undeclared (first use in this function)
+BROKEN_mips64= fails to compile: 'SIGCLD' undeclared (first use in this function)
+
USES= tar:tgz
USE_LDCONFIG= yes
diff --git a/security/php72-hash/Makefile b/security/php72-hash/Makefile
index 33c6d4107b4b..c4a1b2792fd0 100644
--- a/security/php72-hash/Makefile
+++ b/security/php72-hash/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -hash
+BROKEN_mips64= fails to compile: KeccakHash.h: No such file or directory
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/libucl/Makefile b/textproc/libucl/Makefile
index 7e2d3cb50ba4..aec86f09202b 100644
--- a/textproc/libucl/Makefile
+++ b/textproc/libucl/Makefile
@@ -11,6 +11,9 @@ COMMENT= Universal configuration library parser
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_mips= fails to link: undefined reference to '__sync_add_and_fetch_4'
+BROKEN_mips64= fails to link: undefined reference to '__sync_add_and_fetch_4'
+
OPTIONS_DEFINE= LUA REGEX SIGNATURES URLS UTILS
OPTIONS_DEFAULT= REGEX UTILS
OPTIONS_SUB= yes
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index ff9054bf85e2..5ac111005e13 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -13,6 +13,8 @@ LICENSE_NAME= w3m
LICENSE_FILE= ${WRKSRC}/doc/README
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_mips64= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+
LIB_DEPENDS= libgc.so:devel/boehm-gc
USES= iconv pkgconfig perl5 ssl