aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-01-20 11:37:03 +0800
committerijliao <ijliao@FreeBSD.org>2003-01-20 11:37:03 +0800
commite7b8f403ad7388d52de80a9b8c54b0477c4ec46e (patch)
treedcca1493bccf3e40ff58e5ce198853642c618de3
parent903467c6a5f9a7120d028ae61237ee9e4e3198bd (diff)
downloadfreebsd-ports-gnome-e7b8f403ad7388d52de80a9b8c54b0477c4ec46e.tar.gz
freebsd-ports-gnome-e7b8f403ad7388d52de80a9b8c54b0477c4ec46e.tar.zst
freebsd-ports-gnome-e7b8f403ad7388d52de80a9b8c54b0477c4ec46e.zip
use REINPLACE_CMD
Submitted by: Ulrich Spoerlein <q@uni.de>
-rw-r--r--emulators/gnuboy/Makefile3
-rw-r--r--net/pfinger/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 0d2178c22f96..680f95eb93ed 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib \
SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_REINPLACE= yes
USE_XLIB= yes
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
@@ -27,7 +28,7 @@ CONFIGURE_ARGS= --with-sdl
post-patch:
.for file in sys/sdl/sdl.c sys/sdl/keymap.c
- @${PERL} -pi -e "s|SDL/|SDL11/|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|SDL/|SDL11/|g" ${WRKSRC}/${file}
.endfor
post-install:
diff --git a/net/pfinger/Makefile b/net/pfinger/Makefile
index a644d4374a5d..2ea32c5f2ded 100644
--- a/net/pfinger/Makefile
+++ b/net/pfinger/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= ftp://ftp.xelia.ch/pub/unix/ \
MAINTAINER= ijliao@FreeBSD.org
+USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
@@ -23,6 +24,6 @@ MAN5= fingerconf.5
MAN8= in.fingerd.8
post-patch:
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/src/configfile.c
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/src/configfile.c
.include <bsd.port.mk>