aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-03-24 06:54:09 +0800
committerarved <arved@FreeBSD.org>2003-03-24 06:54:09 +0800
commite80584120fa5db148159d7f5db0f766ece828b79 (patch)
treedf04d8a05a3c1969542b91172853e8ddac15bbee
parent59523f640290710b27144d9f63d510fb00c471dd (diff)
downloadfreebsd-ports-gnome-e80584120fa5db148159d7f5db0f766ece828b79.tar.gz
freebsd-ports-gnome-e80584120fa5db148159d7f5db0f766ece828b79.tar.zst
freebsd-ports-gnome-e80584120fa5db148159d7f5db0f766ece828b79.zip
accounts with a . are valid
strip -> ${STRIP_CMD} while i'm here PR:i 31462 Submitted by: pirzyk
-rw-r--r--net/rdist6/Makefile4
-rw-r--r--net/rdist6/files/patch-docmd.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index b63f9f00e5fb..6897ad9496a6 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -30,7 +30,7 @@ MAN8= rdistd.8
PLIST_SUB= RDIST_NAME=${RDIST_NAME}
post-install:
- @strip ${PREFIX}/bin/${RDIST_NAME}
- @strip ${PREFIX}/bin/rdistd
+ @${STRIP_CMD} ${PREFIX}/bin/${RDIST_NAME}
+ @${STRIP_CMD} ${PREFIX}/bin/rdistd
.include <bsd.port.post.mk>
diff --git a/net/rdist6/files/patch-docmd.c b/net/rdist6/files/patch-docmd.c
new file mode 100644
index 000000000000..6577745a992f
--- /dev/null
+++ b/net/rdist6/files/patch-docmd.c
@@ -0,0 +1,11 @@
+--- src/docmd.c.orig Mon Nov 9 20:08:32 1998
++++ src/docmd.c Tue Oct 23 14:32:06 2001
+@@ -611,7 +624,7 @@
+ c = *cp;
+ if (c & 0200)
+ isbad = TRUE;
+- if (!isalpha(c) && !isdigit(c) && c != '_' && c != '-')
++ if (!isalpha(c) && !isdigit(c) && c != '_' && c != '-' && c != '.' )
+ isbad = TRUE;
+ }
+