aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsilby <silby@FreeBSD.org>2002-11-25 13:39:04 +0800
committersilby <silby@FreeBSD.org>2002-11-25 13:39:04 +0800
commite84adb553c7b3846e97e110124a06ebc5e1acd3e (patch)
treeccd2117eedbfffb32fe8c5c1e5f50f043839c9fb
parent3b02ed127d2cf67ada358b7ee9a13203f3d925be (diff)
downloadfreebsd-ports-gnome-e84adb553c7b3846e97e110124a06ebc5e1acd3e.tar.gz
freebsd-ports-gnome-e84adb553c7b3846e97e110124a06ebc5e1acd3e.tar.zst
freebsd-ports-gnome-e84adb553c7b3846e97e110124a06ebc5e1acd3e.zip
Add a conditional BROKEN line for 5.x. This port uses the cout.form
operator, which is deprecated in GCC 3, meaning that extensive patches will be necessary to make it work under 5.x.
-rw-r--r--audio/quelcom/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/quelcom/Makefile b/audio/quelcom/Makefile
index 882d1c1caf72..56260639482f 100644
--- a/audio/quelcom/Makefile
+++ b/audio/quelcom/Makefile
@@ -21,10 +21,16 @@ MAN1= qmp3check.1 qmp3cut.1 qmp3info.1 qmp3join.1 qmp3report.1 \
qwavcut.1 qwavfade.1 qwavheaderdump.1 qwavinfo.1 qwavjoin.1 \
qwavsilence.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "does not build on FreeBSD 5.x; cout.form cannot be used with GCC 3.x"
+.endif
+
do-install:
.for F in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/man/${F} ${PREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/src/${F:S/.1//g} ${PREFIX}/bin
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>