aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-02-07 11:12:50 +0800
committerbeech <beech@FreeBSD.org>2009-02-07 11:12:50 +0800
commite8adbe01d900a48e1d8cc1f4d12fe193020ce169 (patch)
tree532e9081ba35b462e97bb3c55a3269e309ceb4ab
parent99ddef85ceed572f9d8b061211dabc8bdd86f93e (diff)
downloadfreebsd-ports-gnome-e8adbe01d900a48e1d8cc1f4d12fe193020ce169.tar.gz
freebsd-ports-gnome-e8adbe01d900a48e1d8cc1f4d12fe193020ce169.tar.zst
freebsd-ports-gnome-e8adbe01d900a48e1d8cc1f4d12fe193020ce169.zip
Guy Carrington works as a courier for the Hyperspace Delivery Service. He has
to get mail and packages to those who need them, no matter where they are. Fight evil enemies, solve unique puzzles and try to save your big love. WWW: http://www.linuxgamepublishing.com/info.php?id=17 PR: ports/131254 Submitted by: Marcus von Appen <mva at sysfault.org>
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-hdb-demo/Makefile59
-rw-r--r--games/linux-hdb-demo/distinfo3
-rw-r--r--games/linux-hdb-demo/files/hdb.in4
-rw-r--r--games/linux-hdb-demo/pkg-descr5
-rw-r--r--games/linux-hdb-demo/pkg-plist14
6 files changed, 86 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d495e6563ee1..8caa71f49403 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -454,6 +454,7 @@
SUBDIR += linux-etqw-demo-server
SUBDIR += linux-etqw-server
SUBDIR += linux-gorky17-demo
+ SUBDIR += linux-hdb-demo
SUBDIR += linux-majesty-demo
SUBDIR += linux-nerogame
SUBDIR += linux-ningpo-demo
diff --git a/games/linux-hdb-demo/Makefile b/games/linux-hdb-demo/Makefile
new file mode 100644
index 000000000000..937a0bd088d0
--- /dev/null
+++ b/games/linux-hdb-demo/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: linux-hdb-demo
+# Date created: 2009-02-01
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hdb-demo
+PORTVERSION= 1.0
+CATEGORIES= games linux
+MASTER_SITES= http://demofiles.linuxgamepublishing.com/hdb/
+PKGNAMEPREFIX= linux-
+DISTNAME= hdb_demo
+EXTRACT_SUFX= .run
+
+MAINTAINER= mva@sysfault.org
+COMMENT= Hyperspace Delivery Boy Demo - deliver mail and packages
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= hdb
+PORTDOCS= README README.licenses README.unixthanks license.txt
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${TAIL} +377 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} jxf -
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/hdb_demo
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/hdb_demo.dynamic
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/bin/Linux/x86 && \
+ ${INSTALL_PROGRAM} hdb_demo hdb_demo.dynamic ${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKDIR}/hdb ${PREFIX}/bin/${PKGNAMEPREFIX}hdb
+ @${CP} -R ${WRKSRC}/Resources ${DATADIR}
+ @${CP} -R ${WRKSRC}/music ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/hyperdemo.mpc ${DATADIR}
+.if !defined (NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-hdb-demo/distinfo b/games/linux-hdb-demo/distinfo
new file mode 100644
index 000000000000..883f4d125aaf
--- /dev/null
+++ b/games/linux-hdb-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (hdb_demo.run) = cd185998c355022e950f009a970a835c
+SHA256 (hdb_demo.run) = 77bf539ca025795b26e365b25c5aebb37adcdb9c7485652fb9c9d305e113fc21
+SIZE (hdb_demo.run) = 12672665
diff --git a/games/linux-hdb-demo/files/hdb.in b/games/linux-hdb-demo/files/hdb.in
new file mode 100644
index 000000000000..5416b7f0386c
--- /dev/null
+++ b/games/linux-hdb-demo/files/hdb.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./hdb_demo "$@"
diff --git a/games/linux-hdb-demo/pkg-descr b/games/linux-hdb-demo/pkg-descr
new file mode 100644
index 000000000000..1950e277a524
--- /dev/null
+++ b/games/linux-hdb-demo/pkg-descr
@@ -0,0 +1,5 @@
+Guy Carrington works as a courier for the Hyperspace Delivery Service. He has
+to get mail and packages to those who need them, no matter where they are.
+Fight evil enemies, solve unique puzzles and try to save your big love.
+
+WWW: http://www.linuxgamepublishing.com/info.php?id=17
diff --git a/games/linux-hdb-demo/pkg-plist b/games/linux-hdb-demo/pkg-plist
new file mode 100644
index 000000000000..3a5e373ef4ea
--- /dev/null
+++ b/games/linux-hdb-demo/pkg-plist
@@ -0,0 +1,14 @@
+bin/linux-hdb
+%%DATADIR%%/hdb_demo
+%%DATADIR%%/hdb_demo.dynamic
+%%DATADIR%%/music/jungle.ogg
+%%DATADIR%%/music/low_techno.ogg
+%%DATADIR%%/music/mysterious_quiet.ogg
+%%DATADIR%%/music/on_a_mission.ogg
+%%DATADIR%%/music/jaround.ogg
+%%DATADIR%%/hyperdemo.mpc
+%%DATADIR%%/Resources/pyrogon.ttf
+%%DATADIR%%/Resources/cruncher.pyz
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/Resources
+@dirrm %%DATADIR%%