aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 11:43:29 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 11:43:29 +0800
commite90518df9cea7f07bec52b2f968a1c23f508b46e (patch)
treecf35baf15161d8c428b197cb90ae2e176f378d0b
parentbcdbf5199c6bf291a2290675fe811517686998e4 (diff)
downloadfreebsd-ports-gnome-e90518df9cea7f07bec52b2f968a1c23f508b46e.tar.gz
freebsd-ports-gnome-e90518df9cea7f07bec52b2f968a1c23f508b46e.tar.zst
freebsd-ports-gnome-e90518df9cea7f07bec52b2f968a1c23f508b46e.zip
This is the MS Windows like taskbar module for Enlightenment.
It will hold all of your open applications for fast switching. There are three basic functionalities that you don't want to miss: 1. If you click on an icon it will be shown and raised to the top and if its on another desk, then you will be switched to it. 2. If you drag an icon out of ITask the App will be shown on the current desktop. 3. Drag an icon to a pagers desk to send it. WWW: http://www.enlightenment.org/ PR: ports/154402 Submitted by: Grzegorz Blach <magik at roorback.net>
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e17-module-itask/Makefile37
-rw-r--r--x11-wm/e17-module-itask/distinfo2
-rw-r--r--x11-wm/e17-module-itask/pkg-descr12
-rw-r--r--x11-wm/e17-module-itask/pkg-plist10
5 files changed, 62 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 6a94e8a80555..7f56b6ece000 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -55,6 +55,7 @@
SUBDIR += e17-module-flame
SUBDIR += e17-module-forecasts
SUBDIR += e17-module-iiirk
+ SUBDIR += e17-module-itask
SUBDIR += e17-module-itask-ng
SUBDIR += e17-module-language
SUBDIR += e17-module-mail
diff --git a/x11-wm/e17-module-itask/Makefile b/x11-wm/e17-module-itask/Makefile
new file mode 100644
index 000000000000..f4ce3a16a887
--- /dev/null
+++ b/x11-wm/e17-module-itask/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-itask
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= itask
+PORTVERSION= 20110129
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2011-01-29/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= MS Windows like taskbar module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-itask/distinfo b/x11-wm/e17-module-itask/distinfo
new file mode 100644
index 000000000000..bde0cdad78ce
--- /dev/null
+++ b/x11-wm/e17-module-itask/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/itask-20110129.tar.bz2) = fed256222a80974450d5876635fa31ca6cba9cf9ee3dd8ea16a4142e40f6eed1
+SIZE (e17/itask-20110129.tar.bz2) = 528462
diff --git a/x11-wm/e17-module-itask/pkg-descr b/x11-wm/e17-module-itask/pkg-descr
new file mode 100644
index 000000000000..03122cbd1a3a
--- /dev/null
+++ b/x11-wm/e17-module-itask/pkg-descr
@@ -0,0 +1,12 @@
+This is the MS Windows like taskbar module for Enlightenment.
+
+It will hold all of your open applications for fast switching.
+
+There are three basic functionalities that you don't want to miss:
+1. If you click on an icon it will be shown and raised to the top
+ and if its on another desk, then you will be switched to it.
+2. If you drag an icon out of ITask the App will be shown on the
+ current desktop.
+3. Drag an icon to a pagers desk to send it.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-itask/pkg-plist b/x11-wm/e17-module-itask/pkg-plist
new file mode 100644
index 000000000000..ef1165c91c06
--- /dev/null
+++ b/x11-wm/e17-module-itask/pkg-plist
@@ -0,0 +1,10 @@
+lib/enlightenment/modules/itask/module.desktop
+lib/enlightenment/modules/itask/itask.edj
+lib/enlightenment/modules/itask/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/itask/itask.edc
+lib/enlightenment/modules/itask/e-module-itask.edj
+lib/enlightenment/modules/itask/module_icon.png
+@dirrm lib/enlightenment/modules/itask/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/itask
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment