aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-12 23:57:11 +0800
committerpawel <pawel@FreeBSD.org>2014-06-12 23:57:11 +0800
commitea5de8008c3fe66bb0e11dfb85ea7b60ddd3b42f (patch)
tree40e6a28534d1b3d8d52ea7acaa9cd272389d05db
parent1e4b94da79d10c2a16886a66f1625cef245db88f (diff)
downloadfreebsd-ports-gnome-ea5de8008c3fe66bb0e11dfb85ea7b60ddd3b42f.tar.gz
freebsd-ports-gnome-ea5de8008c3fe66bb0e11dfb85ea7b60ddd3b42f.tar.zst
freebsd-ports-gnome-ea5de8008c3fe66bb0e11dfb85ea7b60ddd3b42f.zip
- Add staging support
- Respect CFLAGS
-rw-r--r--misc/gkrellm-xkb/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/gkrellm-xkb/Makefile b/misc/gkrellm-xkb/Makefile
index 0034d1efa6d9..b00a46222313 100644
--- a/misc/gkrellm-xkb/Makefile
+++ b/misc/gkrellm-xkb/Makefile
@@ -15,8 +15,14 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/xkb.so
-MAKE_ENV= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
+MAKE_ENV= PLUGIN_DIR=${PLUGINDIR}
ALL_TARGET= xkb.so
+PLUGINDIR= ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+
+post-patch:
+ @${REINPLACE_CMD} '/$$(CC)/ s|FLAGS|CFLAGS|' ${WRKSRC}/Makefile
+
+pre-install:
+ @${MKDIR} ${PLUGINDIR}
-NO_STAGE= yes
.include <bsd.port.mk>