aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-08-05 16:08:53 +0800
committermiwi <miwi@FreeBSD.org>2007-08-05 16:08:53 +0800
commiteb684fc734dca9c9c0f7f8f1e922c1740f416e2f (patch)
tree7263a5b044c4bc39ceda772041d394bbabf38c60
parent2856d18d022b19ed9102b86464c032e93360cf46 (diff)
downloadfreebsd-ports-gnome-eb684fc734dca9c9c0f7f8f1e922c1740f416e2f.tar.gz
freebsd-ports-gnome-eb684fc734dca9c9c0f7f8f1e922c1740f416e2f.tar.zst
freebsd-ports-gnome-eb684fc734dca9c9c0f7f8f1e922c1740f416e2f.zip
- Add missing dependens
- Remove 4.X cruft PR: 115192 Submitted by: Gerrit Beine <gerrit.beine@gmx.de> (maintainer)
-rw-r--r--net-mgmt/p5-Nagios-Plugin/Makefile50
1 files changed, 24 insertions, 26 deletions
diff --git a/net-mgmt/p5-Nagios-Plugin/Makefile b/net-mgmt/p5-Nagios-Plugin/Makefile
index 9fd8f33dd914..284912ebfff2 100644
--- a/net-mgmt/p5-Nagios-Plugin/Makefile
+++ b/net-mgmt/p5-Nagios-Plugin/Makefile
@@ -5,36 +5,34 @@
# $FreeBSD$
#
-PORTNAME= Nagios-Plugin
-PORTVERSION= 0.17
-CATEGORIES= net-mgmt perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+PORTNAME= Nagios-Plugin
+PORTVERSION= 0.17
+PORTREVISION= 1
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/G/GA/GAVINC
-PKGNAMEPREFIX= p5-
+PKGNAMEPREFIX= p5-
-MAINTAINER= gerrit.beine@gmx.de
-COMMENT= Modules to streamline writing Nagios plugins
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Modules to streamline writing Nagios plugins
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= yes
-BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Math/Calc/Units.pm:${PORTSDIR}/math/p5-Math-Calc-Units
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Math/Calc/Units.pm:${PORTSDIR}/math/p5-Math-Calc-Units
-MAN3= Nagios::Plugin.3 \
- Nagios::Plugin::Config.3 \
- Nagios::Plugin::ExitResult.3 \
- Nagios::Plugin::Functions.3 \
- Nagios::Plugin::Getopt.3 \
- Nagios::Plugin::Performance.3 \
- Nagios::Plugin::Range.3 \
- Nagios::Plugin::Threshold.3 \
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= This port requires FreeBSD 5-STABLE.
-.endif
+MAN3= Nagios::Plugin.3 \
+ Nagios::Plugin::Config.3 \
+ Nagios::Plugin::ExitResult.3 \
+ Nagios::Plugin::Functions.3 \
+ Nagios::Plugin::Getopt.3 \
+ Nagios::Plugin::Performance.3 \
+ Nagios::Plugin::Range.3 \
+ Nagios::Plugin::Threshold.3 \
.if !defined(NOPORTDOCS)
PORTDOCS= Changes README
@@ -45,4 +43,4 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>