aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2004-03-13 05:10:58 +0800
committerjoerg <joerg@FreeBSD.org>2004-03-13 05:10:58 +0800
commiteb9dba9cf1b4396e18bb9b983ed0de36e4bb15ae (patch)
tree7d5161563b8df572283952ae94db5e561ba4a215
parent6a25fbb499106dd8e96ad37fbde8a225af6c6edd (diff)
downloadfreebsd-ports-gnome-eb9dba9cf1b4396e18bb9b983ed0de36e4bb15ae.tar.gz
freebsd-ports-gnome-eb9dba9cf1b4396e18bb9b983ed0de36e4bb15ae.tar.zst
freebsd-ports-gnome-eb9dba9cf1b4396e18bb9b983ed0de36e4bb15ae.zip
Remove `inline' from a function gcc 2.95 (in FreeBSD 4.x) warns that
it cannot inline it. This caused the port build in FreeBSD 4.x to break due to -Werror. Submitted by: Theodore A. Roth <troth@openavr.org>
-rw-r--r--devel/simulavr/Makefile1
-rw-r--r--devel/simulavr/files/patch-sim-no-vcd-inline38
2 files changed, 39 insertions, 0 deletions
diff --git a/devel/simulavr/Makefile b/devel/simulavr/Makefile
index a59c55484a2f..12e71b26b1d8 100644
--- a/devel/simulavr/Makefile
+++ b/devel/simulavr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simulavr
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/simulavr/files/patch-sim-no-vcd-inline b/devel/simulavr/files/patch-sim-no-vcd-inline
new file mode 100644
index 000000000000..cd62e62206e6
--- /dev/null
+++ b/devel/simulavr/files/patch-sim-no-vcd-inline
@@ -0,0 +1,38 @@
+2004-03-11 Theodore A. Roth <troth@openavr.org>
+
+ * src/disp-vcd/vcd.c:
+ * src/disp-vcd/vcd.h:
+ Don't inline vcd_set_clock.
+
+Index: src/disp-vcd/vcd.c
+===================================================================
+RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.c,v
+retrieving revision 1.3
+diff -u -p -p -r1.3 vcd.c
+--- src/disp-vcd/vcd.c 1 Dec 2003 05:48:35 -0000 1.3
++++ src/disp-vcd/vcd.c 11 Mar 2004 18:56:24 -0000
+@@ -696,7 +696,7 @@ vcd_write_pc (int pc)
+
+ /* Set the current time. */
+
+-inline int
++int
+ vcd_set_clock (unsigned int c)
+ {
+ clk = c;
+Index: src/disp-vcd/vcd.h
+===================================================================
+RCS file: /cvsroot/simulavr/simulavr/src/disp-vcd/vcd.h,v
+retrieving revision 1.2
+diff -u -p -p -r1.2 vcd.h
+--- src/disp-vcd/vcd.h 17 Nov 2002 00:29:20 -0000 1.2
++++ src/disp-vcd/vcd.h 11 Mar 2004 18:56:24 -0000
+@@ -47,7 +47,7 @@ int vcd_trace_pc( void );
+ /* Interface for disp.c */
+ int vcd_write_header( void );
+
+-inline int vcd_set_clock( unsigned int c );
++int vcd_set_clock( unsigned int c );
+ int vcd_write_clock( void );
+
+ int vcd_bind_io_reg_shortcut( char *io_reg_name, int io_reg_addr );