aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-10 21:50:14 +0800
committeraz <az@FreeBSD.org>2013-09-10 21:50:14 +0800
commitef1952556f8b9ba015765d548e648fa1bc599b4f (patch)
tree72f2c29cf4b63f91edefce693653d6718208d094
parentc011cb0d1ee746bd26607966c3a1cc755bf442de (diff)
downloadfreebsd-ports-gnome-ef1952556f8b9ba015765d548e648fa1bc599b4f.tar.gz
freebsd-ports-gnome-ef1952556f8b9ba015765d548e648fa1bc599b4f.tar.zst
freebsd-ports-gnome-ef1952556f8b9ba015765d548e648fa1bc599b4f.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
-rw-r--r--databases/jdb/Makefile8
-rw-r--r--databases/mysqlreport/Makefile7
-rw-r--r--databases/p5-Class-DBI-Plugin-Pager/Makefile8
-rw-r--r--databases/p5-DBD-Excel/Makefile9
-rw-r--r--databases/p5-DBICx-MapMaker/Makefile9
-rw-r--r--databases/p5-DBIx-Class-AsFdat/Makefile8
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-IP/Makefile3
-rw-r--r--databases/p5-DBIx-Class-IntrospectableM2M/Makefile9
-rw-r--r--databases/p5-DBIx-Class-Schema-Config/Makefile3
-rw-r--r--databases/p5-DBIx-Skinny-InflateColumn-DateTime/Makefile8
-rw-r--r--databases/p5-DBIx-TransactionManager/Makefile3
-rw-r--r--databases/p5-DBIx-VersionedDDL/Makefile3
-rw-r--r--databases/p5-DR-Tarantool/Makefile3
-rw-r--r--databases/p5-Dancer-Plugin-DBIC/Makefile3
-rw-r--r--databases/p5-Dancer-Session-Memcached/Makefile3
-rw-r--r--databases/p5-Memcached-libmemcached/Makefile9
-rw-r--r--databases/p5-Test-mysqld/Makefile3
-rw-r--r--databases/p5-Test-postgresql/Makefile8
-rw-r--r--databases/postgresql-relay/Makefile9
19 files changed, 43 insertions, 73 deletions
diff --git a/databases/jdb/Makefile b/databases/jdb/Makefile
index 6bf4818c313a..fba1cac8e29d 100644
--- a/databases/jdb/Makefile
+++ b/databases/jdb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: jdb
-# Date created: 28 June 2002
-# Whom: Lars Eggert <larse@isi.edu>
-#
+# Created by: Lars Eggert <larse@isi.edu>
# $FreeBSD$
-#
PORTNAME= jdb
PORTVERSION= 1.14
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.isi.edu/~johnh/SOFTWARE/JDB/
MAINTAINER= lars.eggert@gmx.net
COMMENT= JDB manipulates flat-ASCII databases from shell scripts
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --datadir=${PREFIX}/lib/jdb
diff --git a/databases/mysqlreport/Makefile b/databases/mysqlreport/Makefile
index 7c057188d0a1..1e30be05e700 100644
--- a/databases/mysqlreport/Makefile
+++ b/databases/mysqlreport/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: mysqlreport
-# Date created: 2006-11-23
-# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
-#
+# Created by: Alexander Zhuravlev <zaa@zaa.pp.ru>
# $FreeBSD$
PORTNAME= mysqlreport
@@ -18,7 +15,7 @@ RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
PLIST_FILES= bin/mysqlreport
diff --git a/databases/p5-Class-DBI-Plugin-Pager/Makefile b/databases/p5-Class-DBI-Plugin-Pager/Makefile
index 73af88279138..38a05999dd31 100644
--- a/databases/p5-Class-DBI-Plugin-Pager/Makefile
+++ b/databases/p5-Class-DBI-Plugin-Pager/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Class-DBI-Plugin-Pager
-# Date created: 25 Oct 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Class-DBI-Plugin-Pager
PORTVERSION= 0.566
@@ -22,7 +17,8 @@ BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Text-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::Plugin::Pager.3
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
index 4e7d3783e0a3..5928902bb4df 100644
--- a/databases/p5-DBD-Excel/Makefile
+++ b/databases/p5-DBD-Excel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBD::Excel
-# Date created: 24 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= DBD-Excel
PORTVERSION= 0.06
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-SQL-Statement>=0:${PORTSDIR}/databases/p5-SQL-Statement \
RUN_DEPENDS:= ${BUILD_DEPENDS}
EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBD::Excel.3
diff --git a/databases/p5-DBICx-MapMaker/Makefile b/databases/p5-DBICx-MapMaker/Makefile
index b982280da56a..c1dadee78e6f 100644
--- a/databases/p5-DBICx-MapMaker/Makefile
+++ b/databases/p5-DBICx-MapMaker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBICx-MapMaker
-# Date created: 23 Oct 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBICx-MapMaker
PORTVERSION= 0.03
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class \
p5-Moose>=0.39:${PORTSDIR}/devel/p5-Moose
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBICx::MapMaker.3
diff --git a/databases/p5-DBIx-Class-AsFdat/Makefile b/databases/p5-DBIx-Class-AsFdat/Makefile
index a4e277b61d44..01eeca026418 100644
--- a/databases/p5-DBIx-Class-AsFdat/Makefile
+++ b/databases/p5-DBIx-Class-AsFdat/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Class::AsFdat
-# Date created: 18 Mar 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Class-AsFdat
PORTVERSION= 0.03
@@ -27,7 +22,8 @@ TEST_DEPENDS= p5-Test-Declare>=0:${PORTSDIR}/devel/p5-Test-Declare \
p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
p5-DateTime-Format-SQLite>=0:${PORTSDIR}/devel/p5-DateTime-Format-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::AsFdat.3
diff --git a/databases/p5-DBIx-Class-InflateColumn-IP/Makefile b/databases/p5-DBIx-Class-InflateColumn-IP/Makefile
index 12c9a0d9efba..e467213412ad 100644
--- a/databases/p5-DBIx-Class-InflateColumn-IP/Makefile
+++ b/databases/p5-DBIx-Class-InflateColumn-IP/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class \
p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::InflateColumn::IP.3
diff --git a/databases/p5-DBIx-Class-IntrospectableM2M/Makefile b/databases/p5-DBIx-Class-IntrospectableM2M/Makefile
index b6f41caee0e5..528c4aec3c7b 100644
--- a/databases/p5-DBIx-Class-IntrospectableM2M/Makefile
+++ b/databases/p5-DBIx-Class-IntrospectableM2M/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBIx-Class-IntrospectableM2M
-# Date created: 23 Oct 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-IntrospectableM2M
PORTVERSION= 0.001001
@@ -17,7 +13,8 @@ COMMENT= Introspect many-to-many shortcuts
RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::IntrospectableM2M.3
diff --git a/databases/p5-DBIx-Class-Schema-Config/Makefile b/databases/p5-DBIx-Class-Schema-Config/Makefile
index 6cc989a33d01..6998c2127bc9 100644
--- a/databases/p5-DBIx-Class-Schema-Config/Makefile
+++ b/databases/p5-DBIx-Class-Schema-Config/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-Config-Any>=0.23:${PORTSDIR}/devel/p5-Config-Any \
p5-DBD-SQLite>0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Test-MockObject>=1.09:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::Schema::Config.3
diff --git a/databases/p5-DBIx-Skinny-InflateColumn-DateTime/Makefile b/databases/p5-DBIx-Skinny-InflateColumn-DateTime/Makefile
index 5008fbf89570..6f3e202a326a 100644
--- a/databases/p5-DBIx-Skinny-InflateColumn-DateTime/Makefile
+++ b/databases/p5-DBIx-Skinny-InflateColumn-DateTime/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: DBIx::Skinny::InflateColumn::DateTime
-# Date created: 20 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= DBIx-Skinny-InflateColumn-DateTime
PORTVERSION= 0.06
@@ -24,7 +19,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-DBD-Mock>=0:${PORTSDIR}/databases/p5-DBD-Mock
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Skinny::InflateColumn::DateTime.3 \
DBIx::Skinny::InflateColumn::DateTime::Auto.3
diff --git a/databases/p5-DBIx-TransactionManager/Makefile b/databases/p5-DBIx-TransactionManager/Makefile
index f052b9a61859..094ffaac23e2 100644
--- a/databases/p5-DBIx-TransactionManager/Makefile
+++ b/databases/p5-DBIx-TransactionManager/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::TransactionManager.3 \
DBIx::TransactionManager::Developers.3
diff --git a/databases/p5-DBIx-VersionedDDL/Makefile b/databases/p5-DBIx-VersionedDDL/Makefile
index 632c9e4ad39b..96ceff6d4434 100644
--- a/databases/p5-DBIx-VersionedDDL/Makefile
+++ b/databases/p5-DBIx-VersionedDDL/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= p5-DBD-SQLite>=1.31:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-MooseX-Attribute-ENV>=0.01:${PORTSDIR}/devel/p5-MooseX-Attribute-ENV \
p5-MooseX-Object-Pluggable>=0:${PORTSDIR}/devel/p5-MooseX-Object-Pluggable
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= migrate_schema.1
MAN3= DBIx::VersionedDDL.3 \
diff --git a/databases/p5-DR-Tarantool/Makefile b/databases/p5-DR-Tarantool/Makefile
index d8a79a77ddc6..006eb71dff89 100644
--- a/databases/p5-DR-Tarantool/Makefile
+++ b/databases/p5-DR-Tarantool/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl driver for Tarantool
LICENSE= ART10
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= \
DR::README.3 \
diff --git a/databases/p5-Dancer-Plugin-DBIC/Makefile b/databases/p5-Dancer-Plugin-DBIC/Makefile
index d8f72f9bb7ca..e175c87b100d 100644
--- a/databases/p5-Dancer-Plugin-DBIC/Makefile
+++ b/databases/p5-Dancer-Plugin-DBIC/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Plugin::DBIC.3
diff --git a/databases/p5-Dancer-Session-Memcached/Makefile b/databases/p5-Dancer-Session-Memcached/Makefile
index ffcd3979ec51..3d212aaaf9c2 100644
--- a/databases/p5-Dancer-Session-Memcached/Makefile
+++ b/databases/p5-Dancer-Session-Memcached/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Cache-Memcached>=0:${PORTSDIR}/databases/p5-Cache-Memcached \
RUN_DEPENDS= p5-Cache-Memcached>=0:${PORTSDIR}/databases/p5-Cache-Memcached \
p5-Dancer>=0:${PORTSDIR}/www/p5-Dancer
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dancer::Session::Memcached.3
diff --git a/databases/p5-Memcached-libmemcached/Makefile b/databases/p5-Memcached-libmemcached/Makefile
index 8bc83781a5a8..d6832dd031b4 100644
--- a/databases/p5-Memcached-libmemcached/Makefile
+++ b/databases/p5-Memcached-libmemcached/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Memcached-libmemcached
-# Date created: 2008-01-24
-# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
-#
+# Created by: Cheng-Lung Sung <clsung@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Memcached-libmemcached
PORTVERSION= 0.44.06
@@ -16,7 +12,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= swills@FreeBSD.org
COMMENT= Thin fast full interface to the libmemcached client API
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_LDCONFIG= yes
MAN3= Memcached::libmemcached.3 \
diff --git a/databases/p5-Test-mysqld/Makefile b/databases/p5-Test-mysqld/Makefile
index 39b536f8212f..549df9ec7d5e 100644
--- a/databases/p5-Test-mysqld/Makefile
+++ b/databases/p5-Test-mysqld/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= \
p5-Test-SharedFork>=0.06:${PORTSDIR}/devel/p5-Test-SharedFork
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::mysqld.3
diff --git a/databases/p5-Test-postgresql/Makefile b/databases/p5-Test-postgresql/Makefile
index d0ac1fa7e62b..d97cdf4f74b3 100644
--- a/databases/p5-Test-postgresql/Makefile
+++ b/databases/p5-Test-postgresql/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Test::postgresql
-# Date created: 26 Dec 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Test-postgresql
PORTVERSION= 0.09
@@ -21,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-SharedFork>=0.06:${PORTSDIR}/devel/p5-Test-SharedFork
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::postgresql.3
diff --git a/databases/postgresql-relay/Makefile b/databases/postgresql-relay/Makefile
index 47cd345ae425..8168ed9507f5 100644
--- a/databases/postgresql-relay/Makefile
+++ b/databases/postgresql-relay/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: postgresql-relay
-# Date created: 14 February 2003
-# Whom: Edwin Groothuis (edwin@mavetju.org)
-#
+# Created by: Edwin Groothuis (edwin@mavetju.org)
# $FreeBSD$
-#
PORTNAME= postgresql-relay
PORTVERSION= 1.3.2
@@ -19,7 +15,8 @@ PLIST_FILES= bin/postgresql-relay \
etc/postgresql-relay.conf-sample
USE_RC_SUBR= postgresql-relay
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/postgresql-relay ${PREFIX}/bin