aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-08-11 00:03:12 +0800
committersobomax <sobomax@FreeBSD.org>2003-08-11 00:03:12 +0800
commitf0751ff77cad26b5b7659f5a82b3986eeafea422 (patch)
treedf0f12c73f4e216086e01c171435664c62dcb66e
parent6246576cb3177a8aeda6461e21adab4f23de415f (diff)
downloadfreebsd-ports-gnome-f0751ff77cad26b5b7659f5a82b3986eeafea422.tar.gz
freebsd-ports-gnome-f0751ff77cad26b5b7659f5a82b3986eeafea422.tar.zst
freebsd-ports-gnome-f0751ff77cad26b5b7659f5a82b3986eeafea422.zip
Patch include so that it works with c++.
-rw-r--r--devel/libexecinfo/Makefile1
-rw-r--r--devel/libexecinfo/files/patch-execinfo.h22
2 files changed, 23 insertions, 0 deletions
diff --git a/devel/libexecinfo/Makefile b/devel/libexecinfo/Makefile
index 6b2b2df0b281..92496dace646 100644
--- a/devel/libexecinfo/Makefile
+++ b/devel/libexecinfo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libexecinfo
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://demo.portaone.com/~sobomax/freestuff/
diff --git a/devel/libexecinfo/files/patch-execinfo.h b/devel/libexecinfo/files/patch-execinfo.h
new file mode 100644
index 000000000000..8ac54b9c108d
--- /dev/null
+++ b/devel/libexecinfo/files/patch-execinfo.h
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- execinfo.h 2003/08/10 05:43:54 1.1
++++ execinfo.h 2003/08/10 05:44:11
+@@ -29,8 +29,16 @@
+ #ifndef _EXECINFO_H_
+ #define _EXECINFO_H_
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ int backtrace(void **, int);
+ char ** backtrace_symbols(void *const *, int);
+ void backtrace_symbols_fd(void *const *, int, int);
++
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* _EXECINFO_H_ */