aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-14 18:01:09 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-14 18:01:09 +0800
commitf2295e5c2b5245909d82b0bfdcee7642fb397a1d (patch)
tree9dbc04e3e3b07134c20eee01f265e95dd799e4a9
parent7efac6a47c35147e84da099faa9a75793b15f509 (diff)
downloadfreebsd-ports-gnome-f2295e5c2b5245909d82b0bfdcee7642fb397a1d.tar.gz
freebsd-ports-gnome-f2295e5c2b5245909d82b0bfdcee7642fb397a1d.tar.zst
freebsd-ports-gnome-f2295e5c2b5245909d82b0bfdcee7642fb397a1d.zip
- Fix the build with recent GCC [1]
- Use commas in sed(1) regexps for consistency - Wrap lines so they fit in standard terminal width - Pacify portlint(1) to some extent Reported by: pointyhat [1]
-rw-r--r--multimedia/bmp-extra-plugins/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/multimedia/bmp-extra-plugins/Makefile b/multimedia/bmp-extra-plugins/Makefile
index fa36bd3b6856..7fb0e99f7e5e 100644
--- a/multimedia/bmp-extra-plugins/Makefile
+++ b/multimedia/bmp-extra-plugins/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
artsc.0:${PORTSDIR}/audio/arts
USE_GNOME= libglade2 esound
-USE_X_PREFIX= yes
+USE_GETTEXT= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -29,7 +29,11 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g ; s|echo aout|echo elf|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g ; \
+ s,echo aout,echo elf,' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '38,40s,^static ,,' \
+ ${WRKSRC}/output/crossfade/monitor.c
+ @${REINPLACE_CMD} -e '97s,^static ,,' \
+ ${WRKSRC}/output/crossfade/oss.c
.include <bsd.port.mk>