aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-03-24 02:04:20 +0800
committerrm <rm@FreeBSD.org>2013-03-24 02:04:20 +0800
commitf27faf673d126e14282a4cc404e0d90acf64c5ad (patch)
treeda9ca1dff47f31fe710448bb8227496a5d0e6c33
parente4a8d669511177e7af49d843d51038fffc5c487d (diff)
downloadfreebsd-ports-gnome-f27faf673d126e14282a4cc404e0d90acf64c5ad.tar.gz
freebsd-ports-gnome-f27faf673d126e14282a4cc404e0d90acf64c5ad.tar.zst
freebsd-ports-gnome-f27faf673d126e14282a4cc404e0d90acf64c5ad.zip
- remove corrupted patch and use REINPLACE_CMD instead
- bump PORTREVISION PR: 177093 Reported by: John Marino <draco@marino.st> Submitted by: Olivier Cochard-Labbe <olivier@cochard.me> (maintainer)
-rw-r--r--comms/deforaos-phone/Makefile5
-rw-r--r--comms/deforaos-phone/files/patch-src-modems-hayes.c3
2 files changed, 5 insertions, 3 deletions
diff --git a/comms/deforaos-phone/Makefile b/comms/deforaos-phone/Makefile
index 4a1bdbeeb6a5..2fa3cce8f97b 100644
--- a/comms/deforaos-phone/Makefile
+++ b/comms/deforaos-phone/Makefile
@@ -3,6 +3,7 @@
PORTNAME= phone
PORTVERSION= 0.3.11
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.defora.org/os/download/download/3721/
PKGNAMEPREFIX= deforaos-
@@ -27,4 +28,8 @@ USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
+post-patch:
+ @${REINPLACE_CMD} -e 's,/dev/modem,/dev/cuaU0,g' \
+ ${WRKSRC}/src/modems/hayes.c
+
.include <bsd.port.mk>
diff --git a/comms/deforaos-phone/files/patch-src-modems-hayes.c b/comms/deforaos-phone/files/patch-src-modems-hayes.c
deleted file mode 100644
index ea8f6aa724fb..000000000000
--- a/comms/deforaos-phone/files/patch-src-modems-hayes.c
+++ /dev/null
@@ -1,3 +0,0 @@
-d2108 1
-a2108 1
- device = "/dev/cuaU0";